summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-27 08:03:35 +0100
committerSam James <sam@gentoo.org>2023-07-27 08:03:35 +0100
commit7ac728cba6134ea687a4ff73eb010b6ae42d4f59 (patch)
tree08c5548dd674f40ae931c4ccc6bd5edd1db40042 /sys-block
parentapp-admin/setools: add 4.4.2 (diff)
downloadgentoo-7ac728cba6134ea687a4ff73eb010b6ae42d4f59.tar.gz
gentoo-7ac728cba6134ea687a4ff73eb010b6ae42d4f59.tar.bz2
gentoo-7ac728cba6134ea687a4ff73eb010b6ae42d4f59.zip
sys-block/seekwatcher: add 0.14
Closes: https://bugs.gentoo.org/898732 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/seekwatcher/Manifest1
-rw-r--r--sys-block/seekwatcher/seekwatcher-0.14.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-block/seekwatcher/Manifest b/sys-block/seekwatcher/Manifest
index f4bb7972648a..2f56c58d040d 100644
--- a/sys-block/seekwatcher/Manifest
+++ b/sys-block/seekwatcher/Manifest
@@ -1 +1,2 @@
DIST seekwatcher-0.13.tar.gz 25811 BLAKE2B 72c574e239a346620eb5a1c574365f18dc745e926bfb4f191dd9997ff73b26e716ded9679481be34149c3e5e424077a23a264e7dabe9423eafb396f687085dbd SHA512 687c1190a4d62ee4d7237c6930358d69d2045a7fd5af19caf9fdde8dfae8fcc64ba2d382445af2b038bc31f77c356f31b8dbff2d52cdaf4320881d1b1340dd17
+DIST seekwatcher-0.14.tar.gz 26282 BLAKE2B bd6fbadce452384e8998e16040ec5920c67122a4f2e44f76f6ca858bee89af18ab734b60b66bfb15e8134f59b6d54fdaf21c5f2a06b0249af6e974922f9b900d SHA512 664a3af6aaec218c0628cec5317f414993ef087e8302f906fc21c32f85ae90939aee8c2d620e39fc80947af09f13ea35888dec2678390840c8398d061a8b0f39
diff --git a/sys-block/seekwatcher/seekwatcher-0.14.ebuild b/sys-block/seekwatcher/seekwatcher-0.14.ebuild
new file mode 100644
index 000000000000..06cc3475743f
--- /dev/null
+++ b/sys-block/seekwatcher/seekwatcher-0.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generates graphs from blktrace to help visualize IO patterns and performance"
+HOMEPAGE="https://github.com/trofi/seekwatcher"
+SRC_URI="https://github.com/trofi/seekwatcher/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ')
+ sys-block/blktrace
+"