summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2019-08-05 21:22:04 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2019-08-05 21:22:26 +0200
commitc24972258d3a3d31bb960d79be1b14928e98b7dd (patch)
tree81aeff33455a505b17f5462f0e84ec67440647e9 /sys-apps/firejail
parentdev-libs/libgee: Bump to 0.20.2 (diff)
downloadgentoo-c24972258d3a3d31bb960d79be1b14928e98b7dd.tar.gz
gentoo-c24972258d3a3d31bb960d79be1b14928e98b7dd.tar.bz2
gentoo-c24972258d3a3d31bb960d79be1b14928e98b7dd.zip
sys-apps/firejail: [QA] fix compressed man pages
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Package-Manager: Portage-2.3.69, Repoman-2.3.16
Diffstat (limited to 'sys-apps/firejail')
-rw-r--r--sys-apps/firejail/files/firejail-compressed-manpages.patch17
-rw-r--r--sys-apps/firejail/firejail-0.9.60-r1.ebuild65
2 files changed, 82 insertions, 0 deletions
diff --git a/sys-apps/firejail/files/firejail-compressed-manpages.patch b/sys-apps/firejail/files/firejail-compressed-manpages.patch
new file mode 100644
index 000000000000..8a43bcac2618
--- /dev/null
+++ b/sys-apps/firejail/files/firejail-compressed-manpages.patch
@@ -0,0 +1,17 @@
+diff --git a/Makefile b/Makefile
+index 9c9b93d..2eb8ab2 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -141,10 +141,9 @@ endif
+ install -m 0755 -d $(DESTDIR)/$(mandir)/man5
+ for man in $(MANPAGES); do \
+ rm -f $$man.gz; \
+- gzip -9n $$man; \
+ case "$$man" in \
+- *.1) install -c -m 0644 $$man.gz $(DESTDIR)/$(mandir)/man1/; ;; \
+- *.5) install -c -m 0644 $$man.gz $(DESTDIR)/$(mandir)/man5/; ;; \
++ *.1) install -c -m 0644 $$man $(DESTDIR)/$(mandir)/man1/; ;; \
++ *.5) install -c -m 0644 $$man $(DESTDIR)/$(mandir)/man5/; ;; \
+ esac; \
+ done
+ rm -f $(MANPAGES) $(MANPAGES:%=%.gz)
diff --git a/sys-apps/firejail/firejail-0.9.60-r1.ebuild b/sys-apps/firejail/firejail-0.9.60-r1.ebuild
new file mode 100644
index 000000000000..c8262c74d0d9
--- /dev/null
+++ b/sys-apps/firejail/firejail-0.9.60-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Security sandbox for any type of processes"
+HOMEPAGE="https://firejail.wordpress.com/"
+
+SRC_URI="https://github.com/netblue30/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="apparmor +chroot contrib debug +file-transfer +globalcfg +network +overlayfs +private-home +seccomp +suid test +userns vim-syntax +whitelist x11"
+
+DEPEND="!sys-apps/firejail-lts
+ apparmor? ( sys-libs/libapparmor )
+ test? ( dev-tcltk/expect )"
+
+RDEPEND="apparmor? ( sys-libs/libapparmor )"
+
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-compressed-manpages.patch" )
+
+src_prepare() {
+ default
+
+ find ./contrib -type f -name '*.py' | xargs sed --in-place 's-#!/usr/bin/python3-#!/usr/bin/env python3-g' || die
+
+ find -type f -name Makefile.in | xargs sed --in-place --regexp-extended \
+ --expression='/^\tinstall .*COPYING /d' \
+ --expression='/CFLAGS/s: (-O2|-ggdb) : :g' || die
+
+ sed --in-place --regexp-extended '/CFLAGS/s: (-O2|-ggdb) : :g' ./src/common.mk.in || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable apparmor) \
+ $(use_enable chroot) \
+ $(use_enable contrib contrib-install) \
+ $(use_enable file-transfer) \
+ $(use_enable globalcfg) \
+ $(use_enable network) \
+ $(use_enable overlayfs) \
+ $(use_enable private-home) \
+ $(use_enable seccomp) \
+ $(use_enable suid) \
+ $(use_enable userns) \
+ $(use_enable whitelist) \
+ $(use_enable x11)
+}
+
+src_install() {
+ default
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins contrib/vim/ftdetect/firejail.vim
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins contrib/vim/syntax/firejail.vim
+ fi
+}