summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-06-19 09:00:10 +0800
committerJason Zaman <perfinion@gentoo.org>2019-06-19 12:03:32 +0800
commitb1ccdd0dfbeaeee5daae91b79a020d72cd3ed02f (patch)
tree1d12469978d2b4bba17ac459cd0592239199bca5 /sci-visualization
parentsci-libs/tensorflow-estimator: bump 1.14.0_rc1 (diff)
downloadgentoo-b1ccdd0dfbeaeee5daae91b79a020d72cd3ed02f.tar.gz
gentoo-b1ccdd0dfbeaeee5daae91b79a020d72cd3ed02f.tar.bz2
gentoo-b1ccdd0dfbeaeee5daae91b79a020d72cd3ed02f.zip
sci-visualization/tensorboard: bump 1.14.0
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/tensorboard/Manifest1
-rw-r--r--sci-visualization/tensorboard/tensorboard-1.14.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index 419c6f79841e..07af54fe92dc 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1 +1,2 @@
DIST tensorboard-1.13.1.zip 3187614 BLAKE2B e1b8cb43f7941b843e4fa8c84746f4b341e7c7e246422182eec9e1d3e2a5c367fb818c8e3ddd20cb6b5f64515a986dc5e814728340f0592d346dc55ec6065648 SHA512 d1581b7f694909e94a09d4c3fb2d34ddc31a18a6a09323ef48221e88560a9ec3bbb050ff12a2cd78607a2545053cabc448eab7264036a54dddc4720becfc44b3
+DIST tensorboard-1.14.0.zip 3149160 BLAKE2B 85a3544c2274757cdfb99e3d82751082415d9283a68808de50c4b14662542bd278db3320560cb39aee6bb62d1434dedfa720cfc83b7d464d99256cfe46081f78 SHA512 b19856b1c252b22e472efb9b91ea5c4509d0c3a9d5f99071dea04325e2346b37967b0be151227d150cf013aee5ae6f6273cd311085f4c6b1ca8021d14c2cf562
diff --git a/sci-visualization/tensorboard/tensorboard-1.14.0.ebuild b/sci-visualization/tensorboard/tensorboard-1.14.0.ebuild
new file mode 100644
index 000000000000..1665bc00912b
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-1.14.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Jason Zaman
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit python-r1 python-utils-r1
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]"
+BDEPEND="app-arch/unzip"
+PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eapply_user
+
+ rm -rf "${S}/${PN}/_vendor/bleach" || die
+ rm -rf "${S}/${PN}/_vendor/html5lib" || die
+ sed -i -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import html5lib/import html5lib/' \
+ -e 's/^from tensorboard\._vendor import bleach/import bleach/' \
+ -e 's/^from tensorboard\._vendor\.html5lib/from html5lib/' \
+ -e 's/^from tensorboard\._vendor\.bleach/from bleach/' \
+ {} + || die "failed to unvendor"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}