summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <www.sobhan.mohammadpour@gmail.com>2017-10-23 15:58:39 +0330
committerMark Wright <gienah@gentoo.org>2017-10-24 17:46:05 +1100
commita36219a050e6d671f2c796191b1273153b640a35 (patch)
tree403584ae7300eade87613121f41f442c4acf8dcf /sci-mathematics/rstudio/files
parentsys-libs/glibc: stable 2.25-r8 for ia64, bug #628180 (diff)
downloadgentoo-a36219a050e6d671f2c796191b1273153b640a35.tar.gz
gentoo-a36219a050e6d671f2c796191b1273153b640a35.tar.bz2
gentoo-a36219a050e6d671f2c796191b1273153b640a35.zip
sci-mathematics/rstudio: version bump to 1.1.368
Bump to 1.1.368. This also updates the clang pandoc patch Fixes bug 626056, thanks to Harris Landgarten for reporting, Sobhan Mohammadpour for adding the missing dependency in 1.1.383. Fixes bug 626062 by bumping rstudio to version 1.1.383 that builds with R 3.4. Thanks to Harris Landgarten for reporting, jstein, Volkmar Glauche, Bernd Feige and yuri for testing and helping, Sobhan Mohammadpour for bumping rstudio in PR #6003. Fixes bug 622254, thanks to jstein for reporting, Volkmar Glauche, Bernd Feige, Carl W. Harlow, Rolf S. Arvidson, Oleg, Alex and Sobhan Mohammadpour for testing and helping. Fixes bug 633936, thanks to Neil for reporting, François Valenduc and Bernd for helping. Suggested-by: Bernd Feige <Bernd.Feige@gmx.net> Gentoo-bug: 626056, 626062. 622254, 633936
Diffstat (limited to 'sci-mathematics/rstudio/files')
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.1.357-clang-pandoc.patch76
1 files changed, 76 insertions, 0 deletions
diff --git a/sci-mathematics/rstudio/files/rstudio-1.1.357-clang-pandoc.patch b/sci-mathematics/rstudio/files/rstudio-1.1.357-clang-pandoc.patch
new file mode 100644
index 000000000000..28b0220912a0
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-1.1.357-clang-pandoc.patch
@@ -0,0 +1,76 @@
+Index: rstudio-1.1.357/src/cpp/session/CMakeLists.txt
+===================================================================
+--- rstudio-1.1.357.orig/src/cpp/session/CMakeLists.txt
++++ rstudio-1.1.357/src/cpp/session/CMakeLists.txt
+@@ -25,9 +25,6 @@ endif()
+ if(NOT EXISTS "${RSTUDIO_DEPENDENCIES_DIR}/common/mathjax-26")
+ message(FATAL_ERROR "Mathjax 2.6 not found (re-run install-dependencies script to install)")
+ endif()
+-if(NOT EXISTS "${RSTUDIO_DEPENDENCIES_DIR}/common/pandoc")
+- message(FATAL_ERROR "pandoc not found (re-run install-dependencies script to install)")
+-endif()
+
+ # we often install embedded versions of these packages but don't do so currently
+
+@@ -38,22 +35,6 @@ endif()
+ # message(FATAL_ERROR "rsconnect package not found (re-run install-dependencies script to install)")
+ # endif()
+
+-# verify libclang is installed
+-if(WIN32)
+- set(LIBCLANG_VERSION "3.4")
+-else()
+- set(LIBCLANG_VERSION "3.5")
+-endif()
+-set(LIBCLANG_DIR "${RSTUDIO_DEPENDENCIES_DIR}/common/libclang/${LIBCLANG_VERSION}")
+-if(NOT EXISTS "${LIBCLANG_DIR}")
+- message(FATAL_ERROR "libclang ${LIBCLANG_VERSION} not found (re-run install-dependencies script to install)")
+-endif()
+-set(LIBCLANG_HEADERS_DIR "${RSTUDIO_DEPENDENCIES_DIR}/common/libclang/builtin-headers")
+-if(NOT EXISTS "${LIBCLANG_HEADERS_DIR}")
+- message(FATAL_ERROR "libclang builtin-headers not found (re-run install-dependencies script to install)")
+-endif()
+-
+-
+ # include files
+ file(GLOB_RECURSE SESSION_HEADER_FILES "*.h*")
+
+@@ -465,13 +446,6 @@ if (NOT RSTUDIO_SESSION_WIN64)
+ install(DIRECTORY "resources/connections"
+ DESTINATION ${RSTUDIO_INSTALL_SUPPORTING}/resources)
+
+- # install pandoc
+- set(PANDOC_BIN "${RSTUDIO_DEPENDENCIES_DIR}/common/pandoc/1.19.2.1")
+- file(GLOB PANDOC_FILES "${PANDOC_BIN}/pandoc*")
+- install(FILES ${PANDOC_FILES}
+- PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+- DESTINATION ${RSTUDIO_INSTALL_BIN}/pandoc)
+-
+ # install rmarkdown package
+ # file(GLOB RMARKDOWN_PACKAGE "${RSTUDIO_DEPENDENCIES_DIR}/common/rmarkdown*.tar.gz")
+ # install(FILES ${RMARKDOWN_PACKAGE}
+@@ -502,24 +476,6 @@ if (NOT RSTUDIO_SESSION_WIN64)
+ install(DIRECTORY "resources/profiler"
+ DESTINATION ${RSTUDIO_INSTALL_SUPPORTING}/resources)
+
+- # install libclang
+- if(WIN32)
+- file(GLOB LIBCLANG_32_FILES "${LIBCLANG_DIR}/x86/libclang.*")
+- install(PROGRAMS ${LIBCLANG_32_FILES}
+- DESTINATION ${RSTUDIO_INSTALL_BIN}/rsclang/x86)
+- file(GLOB LIBCLANG_64_FILES "${LIBCLANG_DIR}/x86_64/libclang.*")
+- install(PROGRAMS ${LIBCLANG_64_FILES}
+- DESTINATION ${RSTUDIO_INSTALL_BIN}/rsclang/x86_64)
+- else()
+- file(GLOB_RECURSE LIBCLANG_FILES "${LIBCLANG_DIR}/libclang.*")
+- install(PROGRAMS ${LIBCLANG_FILES}
+- DESTINATION ${RSTUDIO_INSTALL_BIN}/rsclang)
+- endif()
+-
+- # install libclang builtin-headers
+- install(DIRECTORY "${RSTUDIO_DEPENDENCIES_DIR}/common/libclang/builtin-headers"
+- DESTINATION "${RSTUDIO_INSTALL_SUPPORTING}/resources/libclang")
+-
+ # install winpty on windows
+ if(WIN32)
+ install(PROGRAMS "${WINPTY_BINDIR_32}/winpty.dll"