summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-05-27 23:05:44 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-27 23:05:44 +0200
commit0689b79b9127b5d60b85b8196ac03c9907be357f (patch)
treeb03eaa519d5157f488ab3ad9c2e1e4ccac31149d /sci-mathematics/normaliz
parentsci-libs/mpir: Port to EAPI 7, drop static-libs (diff)
downloadgentoo-0689b79b9127b5d60b85b8196ac03c9907be357f.tar.gz
gentoo-0689b79b9127b5d60b85b8196ac03c9907be357f.tar.bz2
gentoo-0689b79b9127b5d60b85b8196ac03c9907be357f.zip
sci-mathematics/normaliz: version bump to 3.8.10
* Authored by Aisha with few small tweaks by me Closes: https://github.com/gentoo/gentoo/pull/17908 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics/normaliz')
-rw-r--r--sci-mathematics/normaliz/Manifest1
-rw-r--r--sci-mathematics/normaliz/normaliz-3.8.10.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sci-mathematics/normaliz/Manifest b/sci-mathematics/normaliz/Manifest
index ff22aa67e421..7e0cf396686d 100644
--- a/sci-mathematics/normaliz/Manifest
+++ b/sci-mathematics/normaliz/Manifest
@@ -1,2 +1,3 @@
DIST normaliz-3.1.3.tar.gz 3075453 BLAKE2B 0860b466dfa5335a58a496c21f7567e7e4682b07c73e36dbbd947eb65500e03758577d32355adb02fa4e271ca2f49bc5cb0449e26f1bdd11eab2dd5dbafd8f17 SHA512 c7fb1620e758dc59de88f0d7c55f50db0f67be772a00af27205e478f30c3836b7cf012a16a8adfdee3f0367d3adb4e3f887dc7d03793a7ca1601968ddb1946ce
DIST normaliz-3.3.0.tar.gz 4243027 BLAKE2B 4785c47a2d815518e98b012dcbfe3cb70aac0ea8e06ad8f15ad6ba73120589e24f82050c25368775299974a43fce42052ffdf49379cd2b14ef4e415f6bb2d8f9 SHA512 3e09be1a265746c2cedf24c6a38de2f3801a906a66a0fa73a98b05916a5e6f412d84f5e38276781b5d99ff779a2db3fc420acdadd036e9822cae41b2ed539be5
+DIST normaliz-3.8.10.tar.gz 5086191 BLAKE2B b40de665718dc1cee8a7246ccfb9b8496bdfa0754408f0260421352f1b4776133047ed1a5e8e0f044bdc15dde63a9f7d9ea1721773f36ecdccce3a8575493772 SHA512 8755011b1305b571d6bef7b6200e01bb56dbadce3f67de022fae0ef42c69c095b1f7cd2a2a432282098277ee39aa17caeffda15c806b28a6060a737930d5b82c
diff --git a/sci-mathematics/normaliz/normaliz-3.8.10.ebuild b/sci-mathematics/normaliz/normaliz-3.8.10.ebuild
new file mode 100644
index 000000000000..bac3b0b1866a
--- /dev/null
+++ b/sci-mathematics/normaliz/normaliz-3.8.10.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Tool for computations in affine monoids and more"
+HOMEPAGE="http://www.mathematik.uni-osnabrueck.de/normaliz/"
+SRC_URI="https://github.com/Normaliz/Normaliz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/Normaliz-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc extras openmp"
+
+# would be nice to package scip and cocoalib
+RDEPEND="
+ dev-libs/gmp:=[cxx]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
+# Only a boost header is needed -> not RDEPEND
+
+pkg_setup() {
+ use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable openmp) \
+ --disable-static
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+
+ use doc && dodoc doc/Normaliz.pdf
+ if use extras; then
+ newdoc Singular/normaliz.pdf singular-normaliz.pdf
+ insinto /usr/share/${PN}
+ doins Singular/normaliz.lib
+ doins Macaulay2/Normaliz.m2
+ fi
+}