summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-20 20:44:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-20 21:36:14 +0100
commitff2566ea218834a85008e385a89f97f7d46415e5 (patch)
tree6d2533a0ab5b6c754a227e8364893eba67640e40 /sci-libs/libnova
parentsys-kernel/gentoo-sources: Linux patch 4.19.85 (diff)
downloadgentoo-ff2566ea218834a85008e385a89f97f7d46415e5.tar.gz
gentoo-ff2566ea218834a85008e385a89f97f7d46415e5.tar.bz2
gentoo-ff2566ea218834a85008e385a89f97f7d46415e5.zip
sci-libs/libnova: 0.16.0 version bump
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/libnova')
-rw-r--r--sci-libs/libnova/Manifest1
-rw-r--r--sci-libs/libnova/libnova-0.16.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sci-libs/libnova/Manifest b/sci-libs/libnova/Manifest
index 932ef1e10880..344cba8f3123 100644
--- a/sci-libs/libnova/Manifest
+++ b/sci-libs/libnova/Manifest
@@ -1 +1,2 @@
DIST libnova-0.15.0.tar.gz 1533794 BLAKE2B e87ffd3b8a895ca7ac9913ad3aacff526718442546df5687f2156718f721665ffff27e69af4bcb65bac5df1fda89fc6fc8fe9876a4b74392986771cf157dc48c SHA512 77ab0ccbfe462c03a21e88656cb4d6389994ea1da0ee8da997f19a83d24ad8fd9e505e70e1580b75332e826e5b7859b5f2af4417f65eb811440493ba586f2574
+DIST libnova-0.16.0.tar.xz 909212 BLAKE2B ae7efef8295dafd3715c37506d7403fc38a951c9a7c43e41e3c6ca3c922243a396052bbb71f07901bbd3aae2b2bee183efbd9e3e9c50dce72379f6ced80d5701 SHA512 f1c33421b7f09097223afe1bd5c31fa9a4591e4c965ba8a5ae1f164367717aa03986970ffe9c01e400b27aea43843fbb67cfbfe6ef44ec2c519f524aab9ea86f
diff --git a/sci-libs/libnova/libnova-0.16.0.ebuild b/sci-libs/libnova/libnova-0.16.0.ebuild
new file mode 100644
index 000000000000..7d3e9344735e
--- /dev/null
+++ b/sci-libs/libnova/libnova-0.16.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Celestial Mechanics and Astronomical Calculation Library"
+HOMEPAGE="http://libnova.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~asturm/distfiles/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0/0.16"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_compile() {
+ default
+ use doc && emake -C doc doc
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/html/. )
+ default
+
+ if use examples; then
+ emake clean
+ rm examples/Makefile* || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}