summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/htslib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/htslib')
-rw-r--r--sci-libs/htslib/Manifest3
-rw-r--r--sci-libs/htslib/htslib-1.0.ebuild45
-rw-r--r--sci-libs/htslib/htslib-1.1.ebuild43
-rw-r--r--sci-libs/htslib/htslib-1.2.1.ebuild21
-rw-r--r--sci-libs/htslib/metadata.xml8
5 files changed, 120 insertions, 0 deletions
diff --git a/sci-libs/htslib/Manifest b/sci-libs/htslib/Manifest
new file mode 100644
index 000000000000..1618f6e60f4d
--- /dev/null
+++ b/sci-libs/htslib/Manifest
@@ -0,0 +1,3 @@
+DIST htslib-1.0.tar.bz2 842174 SHA256 3d53fb081fafd930cadfee6f950faacc1993a0f4a9fa329fc897865fc6b331bc SHA512 aee7080a31c3fe5bd1fe4a16102da4aef7d415fd022781c1a5bdc1316ca50f8fcabbb95a39adc867e4eb5ac2d8ed63ab15ceafcd768e840d2593282916313507 WHIRLPOOL 512f4a95e98129151fef34fb90294138bc0aec40d5c2345d15d49ded02810c4663b8ff65726ced9f0d9ceb300295da066f6025d2b1966224937fc9ff58f2b58f
+DIST htslib-1.1.tar.bz2 844870 SHA256 204e894074d9a864d27b607fda19f6240c5da351bb61bfc6c94beaa8790e4d58 SHA512 cde0b01583035f139203b8e9884dc97846bdf02fbb6dd2af74d0829270c2141ac490d0ca3ece4f9afd9d66d6af235452d3e94bbe0ea6e1a8625405735a813271 WHIRLPOOL 56e986cd7ee29d2d680ef55fd9128d4e43bacff4d72bc83df7b8c1e6c8d53b4a726c576d690dee272397778a6796096072fc3fffe4a4f1cbc0179a91fe9405b6
+DIST htslib-1.2.1.tar.bz2 911326 SHA256 bddb1372b9215b32e0f21d8394bab859c57cb00324a8dc06775cdac5b4d662b0 SHA512 23db1861cd08b503223f14dcbbdf9c6ae24dec648c987816abc47cc85fa7287c2405be72193cf492fff4f5991ff7b1f55dc386004588971a0e43a2f1c7355199 WHIRLPOOL d81f1cc74bb7e70d538f3e616f290a50017c56c517d9986f84c897b75524848135dd1788f92ff983c701ab7d5e84163123c570a200b83bea6a7922f4c1293107
diff --git a/sci-libs/htslib/htslib-1.0.ebuild b/sci-libs/htslib/htslib-1.0.ebuild
new file mode 100644
index 000000000000..f3ab7398967a
--- /dev/null
+++ b/sci-libs/htslib/htslib-1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="C library for high-throughput sequencing data formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="mirror://sourceforge/samtools/${PV}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ sed \
+ -e "/libdir/s:lib$:$(get_libdir):g" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ install
+
+ rm "${ED}/usr/share/man/man1/libhts.so.1" || die
+
+ if ! use static-libs; then
+ find "${ED}" -type f -name "*.a" -delete || die
+ fi
+
+ dodoc README
+}
diff --git a/sci-libs/htslib/htslib-1.1.ebuild b/sci-libs/htslib/htslib-1.1.ebuild
new file mode 100644
index 000000000000..0c3207ab84a0
--- /dev/null
+++ b/sci-libs/htslib/htslib-1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="C library for high-throughput sequencing data formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="mirror://sourceforge/samtools/${PV}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ sed \
+ -e "/libdir/s:lib$:$(get_libdir):g" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ install
+
+ if ! use static-libs; then
+ find "${ED}" -type f -name "*.a" -delete || die
+ fi
+
+ dodoc README
+}
diff --git a/sci-libs/htslib/htslib-1.2.1.ebuild b/sci-libs/htslib/htslib-1.2.1.ebuild
new file mode 100644
index 000000000000..36fc9bdd399b
--- /dev/null
+++ b/sci-libs/htslib/htslib-1.2.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="C library for high-throughput sequencing data formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="mirror://sourceforge/samtools/${PV}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+src_install() {
+ default
+ if ! use static-libs; then
+ find "${ED}" -type f -name "*.a" -delete || die
+ fi
+}
diff --git a/sci-libs/htslib/metadata.xml b/sci-libs/htslib/metadata.xml
new file mode 100644
index 000000000000..74dc02bc9826
--- /dev/null
+++ b/sci-libs/htslib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <upstream>
+ <remote-id type="sourceforge">samtools</remote-id>
+ </upstream>
+</pkgmetadata>