summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGavin D. Howard <gavin@gavinhoward.com>2024-09-17 21:28:24 -0600
committerEli Schwartz <eschwartz@gentoo.org>2024-09-19 19:51:17 -0400
commit65aceba01ac1611a944e4223e181b55b0536ec9b (patch)
tree373b1aeddf98256a0f57b0132cbcde8631c88014 /sci-calculators
parentx11-drivers/nvidia-drivers: config check for DRM_TTM_HELPER w/ 6.11+ (diff)
downloadgentoo-65aceba01ac1611a944e4223e181b55b0536ec9b.tar.gz
gentoo-65aceba01ac1611a944e4223e181b55b0536ec9b.tar.bz2
gentoo-65aceba01ac1611a944e4223e181b55b0536ec9b.zip
sci-calculators/bc-gh: add 7.0.2
Someone found another bug. Sorry. Will clean up when we stabilize. Signed-off-by: Gavin D. Howard <gavin@gavinhoward.com> Closes: https://github.com/gentoo/gentoo/pull/38655 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/bc-gh/Manifest1
-rw-r--r--sci-calculators/bc-gh/bc-gh-7.0.2.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/sci-calculators/bc-gh/Manifest b/sci-calculators/bc-gh/Manifest
index 8009bee745eb..f4ff0def93f3 100644
--- a/sci-calculators/bc-gh/Manifest
+++ b/sci-calculators/bc-gh/Manifest
@@ -2,3 +2,4 @@ DIST bc-6.5.0.tar.xz 461380 BLAKE2B e4aa633162d03fc5723e967ba81f985ab1b16e47b3c9
DIST bc-6.7.5.tar.xz 468572 BLAKE2B 3942cfbbc2b8a307bc24b9f7c3e037bce374bd17332b236a8c76ccacef1177e36669b7f61944a5c5791b0a436dec171991cfc821526865a816fba91e65aa1f04 SHA512 5f689fd20801ea7ede725ae5dc4e8744bdf2d72424bffef99c53193a950f4bd83b6eb4c5a07556576d0b3f5b6cd7f9fc7cbcb41d27891f488bb2e97a186f76a4
DIST bc-7.0.0.tar.xz 474468 BLAKE2B 2905f96639558a7f1203a0f63207f26b5e4cb75a91c4b848a4ef7f0313dfaa698499f948eb7ecdbc5eb3fcd0bd3ecf8c2f005256e48a58615fa8b69ec19932ae SHA512 ef89525eea8773dddb7efd3dd33f589de287ac807b772480e884bd666f29b2b0b362c999029cc6d82733f830195ca3f6fd867f15190fbcbf807ddbc4b24abb65
DIST bc-7.0.1.tar.xz 474272 BLAKE2B ed83854828a917c5e5cdfcb46d2b0a2769f937c45cb454533ad42c3037331fcf4a668acaffb11acde733f587270d121ed3f6677f50b751de25835bd9b267f63a SHA512 376ef1b4a72a64ee114ee5a835ea36ad4f26fdd06662df2db387e645c7ab86b49b019461928e891455daeae9afddb496959c4b2aebeafb1b37051c379c62a888
+DIST bc-7.0.2.tar.xz 475084 BLAKE2B f4d17f9669eb941e0314a174b17dfde46040eafc31fc0f45930a78920a92aee306031e57ff310e2485a1d77074760c992587ed0251a20e084a1e4df14060a46a SHA512 deac1ffa11562b71ec9c238d375e16d46b63b7330092ef43e38f087fc5f9c813adb6fa352aab45cb96a17206de3d2d2e62825aef19ff9aed72ea63fc3b9ea603
diff --git a/sci-calculators/bc-gh/bc-gh-7.0.2.ebuild b/sci-calculators/bc-gh/bc-gh-7.0.2.ebuild
new file mode 100644
index 000000000000..9617ad8ff871
--- /dev/null
+++ b/sci-calculators/bc-gh/bc-gh-7.0.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo
+
+MY_P="bc-${PV}"
+DESCRIPTION="Implementation of POSIX bc with GNU extensions"
+HOMEPAGE="
+ https://git.gavinhoward.com/gavin/bc/
+ https://github.com/gavinhoward/bc/
+"
+SRC_URI="
+ https://github.com/gavinhoward/bc/releases/download/${PV}/${MY_P}.tar.xz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="libedit readline"
+
+DEPEND="
+ !readline? (
+ libedit? ( dev-libs/libedit:= )
+ )
+ readline? (
+ sys-libs/readline:=
+ sys-libs/ncurses:=
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ local myconf=(
+ # GNU and BSD bc's have slightly different behavior. This bc can act
+ # like both, changing at runtime with environment variables, but it
+ # needs defaults, which can be set at compile time. This option sets all
+ # of the defaults to match the GNU bc/dc since it's common on Linux.
+ -pGNU
+ # A lot of test results are generated first by a bc compatible with the
+ # GNU bc. If there is no GNU bc installed, then those tests should be
+ # skipped. That's what this option does. Without it, we would have a
+ # dependency cycle. Those tests are super long, anyway.
+ -G
+ # Disables the automatic stripping of binaries.
+ -T
+ # Enables installing all locales, which is important for packages.
+ -l
+ # Disables some "problematic" tests that need specific options on Linux
+ # to not trigger the OOM killer because malloc() lies.
+ -P
+ )
+ if use readline ; then
+ myconf+=( -r )
+ elif use libedit ; then
+ myconf+=( -e )
+ fi
+
+ local -x EXECSUFFIX="-gh"
+ local -x PREFIX="${EPREFIX}/usr"
+ edo ./configure.sh "${myconf[@]}"
+}
+
+src_test() {
+ # This is to fix a bug encountered on Arch. It is to ensure we don't get
+ # segfaults on `make check` when the error messages change because the error
+ # messages are passed to printf(); they have format specifiers. With these
+ # env vars, the internal error messages are used, instead of the installed
+ # locales, which might be different since the new locale files are not
+ # installed yet. (It is impossible to use uninstalled locales because of the
+ # poor design of POSIX locales.)
+ env LANG=C LC_ALL=C emake check
+}