summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Vinson <nvinson234@gmail.com>2017-01-11 07:57:17 -0800
committerLars Wendler <polynomial-c@gentoo.org>2017-01-11 18:16:03 +0100
commitfcdf7766b661a2b8c881a728792b25d7eec18f5a (patch)
tree9dee420edecfb5266ea4122a7c24411af77a309d /sci-biology
parentapp-shells/thefuck: Add pytest-mock dependency (diff)
downloadgentoo-fcdf7766b661a2b8c881a728792b25d7eec18f5a.tar.gz
gentoo-fcdf7766b661a2b8c881a728792b25d7eec18f5a.tar.bz2
gentoo-fcdf7766b661a2b8c881a728792b25d7eec18f5a.zip
sci-biology/mira: Force rebuild of lexer C++ source files
Upstream ships pregenerated C++ source files for its lexers. These files fail to compile under newer versions of GCC. This update forces them to be rebuilt by removing them before compilaiton starts. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/mira/mira-4.0.2.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/sci-biology/mira/mira-4.0.2.ebuild b/sci-biology/mira/mira-4.0.2.ebuild
index 9de22bb71e2a..9413101bf2fa 100644
--- a/sci-biology/mira/mira-4.0.2.ebuild
+++ b/sci-biology/mira/mira-4.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -49,6 +49,17 @@ src_prepare() {
-i configure.ac || die
eautoreconf
+
+ # Remove C++ source files that were built with flex by upstream.
+ local f
+ local PREBUILT_CXX_LEXER_FILES=(
+ "$S"/src/io/exp_flexer.cc
+ "$S"/src/mira/parameters_flexer.cc
+ )
+
+ for f in "${PREBUILT_CXX_LEXER_FILES[@]}"; do
+ [[ -f $f ]] && { rm "$f" || die "Failed to remove $f"; } || die "$f not found"
+ done
}
src_configure() {