summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-24 16:48:06 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-24 16:48:34 +0100
commit8ae0a404819aea5af6bc920231434c3523fb8281 (patch)
tree92a48593f0bb11af6f3d11acdb1f344d934aabd9 /sci-biology/seqan
parentsys-apps/usbguard: 1.1.0 (diff)
downloadgentoo-8ae0a404819aea5af6bc920231434c3523fb8281.tar.gz
gentoo-8ae0a404819aea5af6bc920231434c3523fb8281.tar.bz2
gentoo-8ae0a404819aea5af6bc920231434c3523fb8281.zip
sci-biology/seqan: add version 3.1.0
Closes: https://bugs.gentoo.org/774702 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-biology/seqan')
-rw-r--r--sci-biology/seqan/Manifest1
-rw-r--r--sci-biology/seqan/seqan-3.1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sci-biology/seqan/Manifest b/sci-biology/seqan/Manifest
index b8572815a1e0..f9ddca8ef871 100644
--- a/sci-biology/seqan/Manifest
+++ b/sci-biology/seqan/Manifest
@@ -1 +1,2 @@
DIST seqan-v2.4.0.tar.gz 109626901 BLAKE2B a10b5ee9a95667f560a8c2aec3808131f5f838f3c07d56584f4b29e9622912bf3d00b958b02db7c9d62dd52d9d08a171abcccef7f50cddf0407538168cf2c592 SHA512 f92cfc97304581920850c5d49fe4336f7c3855e99c3bcb035b6172fa7307e08e6f06fb06d1cd8f5b447c3220fc7f669684fbfe25641b43e9f6953999cf9ddd4b
+DIST seqan3-3.1.0-Source.tar.xz 2656120 BLAKE2B 6a18844f62d935fdbd7008822f83ffeefd596e93b704a8c7b0f478dec87b2265ff532be107ebfd1adc248e2b1db65e4b86cdce2e989c7ac097054d43633a24bd SHA512 686d0ffbe32951e7f831e399a3eab35b7249f45408b7de27ee9cfd6a012215603f033afa6082c8a81783de1cc7c93d3ffbae42cabc122d3b77988c236a049ffd
diff --git a/sci-biology/seqan/seqan-3.1.0.ebuild b/sci-biology/seqan/seqan-3.1.0.ebuild
new file mode 100644
index 000000000000..fc9dd78e4233
--- /dev/null
+++ b/sci-biology/seqan/seqan-3.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ Sequence Analysis Library"
+HOMEPAGE="https://www.seqan.de/"
+SRC_URI="https://github.com/seqan/seqan3/releases/download/${PV}/seqan3-${PV}-Source.tar.xz"
+S="${WORKDIR}/seqan3-${PV}-Source"
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE="cpu_flags_x86_sse4_2"
+REQUIRED_USE="cpu_flags_x86_sse4_2"
+
+RDEPEND="
+ app-arch/bzip2:=
+ dev-cpp/range-v3
+ dev-libs/cereal
+ sci-libs/lemon
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ cmake_src_install
+ dodoc -r doc/*
+}