summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/phyml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/phyml')
-rw-r--r--sci-biology/phyml/Manifest1
-rw-r--r--sci-biology/phyml/metadata.xml11
-rw-r--r--sci-biology/phyml/phyml-2.4.5-r2.ebuild34
3 files changed, 46 insertions, 0 deletions
diff --git a/sci-biology/phyml/Manifest b/sci-biology/phyml/Manifest
new file mode 100644
index 000000000000..d285799277e1
--- /dev/null
+++ b/sci-biology/phyml/Manifest
@@ -0,0 +1 @@
+DIST phyml_v2.4.5.tar.gz 92143 SHA256 e8a1d3980137f8e528d0e59472aff37dbac615860a7d3ee4cdb64f30dfea296e SHA512 119716290eca0de4da05b0bacbec96139f4c89f6a033b861d1cb2655a620766bd0bea0675c4d7722a31d888652a28bf3544a643f39f11682982ede80dc5928c3 WHIRLPOOL e9c0e36ea871c61fc617ed0a10d306bdb66d84da0b9a08107fb9e1f6370e10676c5ad8a0a5e5404ccad6ae2f62551d566614a173cfdd4a0a523f727fc7924ce0
diff --git a/sci-biology/phyml/metadata.xml b/sci-biology/phyml/metadata.xml
new file mode 100644
index 000000000000..d0355f85e406
--- /dev/null
+++ b/sci-biology/phyml/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription lang="en">
+ Phyml is a simple, fast, and accurate algorithm to estimate large
+ phylogenies by maximum likelihood. Given input sequence files, it
+ estimates phylogenies using maximum likelihood, and is capable of
+ processing large amounts of phylogenetic data.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-biology/phyml/phyml-2.4.5-r2.ebuild b/sci-biology/phyml/phyml-2.4.5-r2.ebuild
new file mode 100644
index 000000000000..7d9815baa78b
--- /dev/null
+++ b/sci-biology/phyml/phyml-2.4.5-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit toolchain-funcs
+
+MY_P=${PN}_v${PV}
+
+DESCRIPTION="Estimation of large phylogenies by maximum likelihood"
+HOMEPAGE="http://atgc.lirmm.fr/phyml/"
+SRC_URI="http://www.lirmm.fr/~guindon/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e 's/^hello !!!//' \
+ -e 's/$(CC) -o/$(CC) $(LDFLAGS) -o/' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake -e CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin phyml || die
+}