summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2022-06-29 18:54:42 -0400
committerKenton Groombridge <concord@gentoo.org>2022-06-29 20:14:20 -0400
commited813abc5426cd324dfb8d30894fb837e5612ee7 (patch)
tree2c6d18fdddd93439c04bc6c658906499a1a48d5d /net-voip
parentmedia-sound/mumble: fix build with dev-lang/python-exec[-native-symlinks] (diff)
downloadgentoo-ed813abc5426cd324dfb8d30894fb837e5612ee7.tar.gz
gentoo-ed813abc5426cd324dfb8d30894fb837e5612ee7.tar.bz2
gentoo-ed813abc5426cd324dfb8d30894fb837e5612ee7.zip
net-voip/mumble: rename media-sound/mumble
Closes: https://bugs.gentoo.org/show_bug.cgi?id=291072 Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/mumble/Manifest3
-rw-r--r--net-voip/mumble/files/mumble-1.4.230-gcc12-include-memory.patch28
-rw-r--r--net-voip/mumble/files/mumble-1.4.230-poco-link-cmake.patch24
-rw-r--r--net-voip/mumble/metadata.xml17
-rw-r--r--net-voip/mumble/mumble-1.3.4.ebuild166
-rw-r--r--net-voip/mumble/mumble-1.4.230-r1.ebuild135
-rw-r--r--net-voip/mumble/mumble-9999.ebuild132
7 files changed, 505 insertions, 0 deletions
diff --git a/net-voip/mumble/Manifest b/net-voip/mumble/Manifest
new file mode 100644
index 000000000000..0f2194f6c401
--- /dev/null
+++ b/net-voip/mumble/Manifest
@@ -0,0 +1,3 @@
+DIST mumble-1.3.4.tar.gz 8592741 BLAKE2B bcde3fd859ec4faea06f996cd4c583af7c0b8409cca79cb05ef8ba7fcdeac9e49ed1d07a4131225dd582da7610190d4006abc731fd4276b2288e02e8c18effb6 SHA512 e2dde5aad30d1a931e7acd8d7db0b8c785d3a268d0b8cf5626fa03953a51bcadb719c6682c440d02524e83beee13d73d8f5bb3fdf98ab1c82d3ecf824cc25f68
+DIST mumble-1.4-openssl3.patch.xz 4172 BLAKE2B 5b68f023e218628a4d73b0991dcc7790ce5f92ce6a27c372c5e80b1f3a8beafa3ddd6416b884705b321aee31ea4f5e09dda6ceb240272dde64f420fbeb06845a SHA512 3a4e504f3365e93418cb85d0da4e6f2f54ab904283743907604bb39276560a4215d9bea1b225601789d1c3d84d270c04840ec57cd04e3df1204cc586ea42562a
+DIST mumble-1.4.230.tar.gz 9441667 BLAKE2B da433f3c15d7e45dfac0c8a78c9dbe86ba8d5cd078d2d87fd4d90718968fc9e5928c3c5c5ba2e40a8a54d02a646c5fc6a7ee2fff4b71dfa411d74f395b097c26 SHA512 6cffc7a95d88b33876f4093b99266468210f5c14f190fbd2fbe4991bef91a567e55296e7c8c6cc99e19c054853211085cc3cc08109e367e6776afb70766b3a53
diff --git a/net-voip/mumble/files/mumble-1.4.230-gcc12-include-memory.patch b/net-voip/mumble/files/mumble-1.4.230-gcc12-include-memory.patch
new file mode 100644
index 000000000000..624a8594d995
--- /dev/null
+++ b/net-voip/mumble/files/mumble-1.4.230-gcc12-include-memory.patch
@@ -0,0 +1,28 @@
+https://github.com/mumble-voip/mumble/commit/36398fb3b293fc889bbc38df29665359f5c2a0ca
+
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Sun, 27 Feb 2022 10:59:57 +0000
+Subject: [PATCH] BUILD(positional-audio): Fix missing <memory> include
+
+Without the change the build fails on upcoming gcc-12 as:
+
+ /build/mumble/plugins/gtav/gtav.cpp:13:13:
+ error: 'unique_ptr' in namespace 'std' does not name a template type
+ 13 | static std::unique_ptr< Game > game;
+ | ^~~~~~~~~~
+ /build/mumble/plugins/gtav/gtav.cpp:12:1:
+ note: 'std::unique_ptr' is defined in header '<memory>';
+ did you forget to '#include <memory>'?
+ 11 | #include <cstring>
+ +++ |+#include <memory>
+ 12 |
+--- a/plugins/gtav/gtav.cpp
++++ b/plugins/gtav/gtav.cpp
+@@ -9,6 +9,7 @@
+ #include "mumble_positional_audio_utils.h"
+
+ #include <cstring>
++#include <memory>
+
+ static std::unique_ptr< Game > game;
+
diff --git a/net-voip/mumble/files/mumble-1.4.230-poco-link-cmake.patch b/net-voip/mumble/files/mumble-1.4.230-poco-link-cmake.patch
new file mode 100644
index 000000000000..d1b4dee11d51
--- /dev/null
+++ b/net-voip/mumble/files/mumble-1.4.230-poco-link-cmake.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/842984
+https://github.com/mumble-voip/mumble/commit/fefdd79ebcd53a3035967789d004938ee39e2030
+
+Fix underlinking against Poco.
+--- a/src/mumble/CMakeLists.txt
++++ b/src/mumble/CMakeLists.txt
+@@ -383,11 +383,16 @@ target_include_directories(mumble
+ "${PLUGINS_DIR}"
+ )
+
+-find_pkg(Poco COMPONENTS Zip)
++find_pkg(Poco
++ COMPONENTS
++ XML
++ Zip
++)
+
+ if(TARGET Poco::Zip)
+ target_link_libraries(mumble
+ PRIVATE
++ Poco::XML
+ Poco::Zip
+ )
+ else()
diff --git a/net-voip/mumble/metadata.xml b/net-voip/mumble/metadata.xml
new file mode 100644
index 000000000000..4155b39a062c
--- /dev/null
+++ b/net-voip/mumble/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>concord@gentoo.org</email>
+ <name>Kenton Groombridge</name>
+ </maintainer>
+ <use>
+ <flag name="g15">Enable support for the Logitech G15 LCD (and compatible devices).</flag>
+ <flag name="pipewire">Enable pipewire support for audio output.</flag>
+ <flag name="rnnoise">Enable alternative noise suppression option based on RNNoise.</flag>
+ <flag name="speech">Enable text-to-speech support in Mumble.</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">mumble</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-voip/mumble/mumble-1.3.4.ebuild b/net-voip/mumble/mumble-1.3.4.ebuild
new file mode 100644
index 000000000000..b34bfa5eec22
--- /dev/null
+++ b/net-voip/mumble/mumble-1.3.4.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit desktop multilib-build python-any-r1 qmake-utils xdg
+
+DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
+HOMEPAGE="https://wiki.mumble.info"
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mumble-voip/mumble.git"
+ EGIT_SUBMODULES=( '-*' celt-0.7.0-src celt-0.11.0-src themes/Mumble 3rdparty/rnnoise-src )
+else
+ if [[ "${PV}" == *_pre* ]] ; then
+ SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${P}.tar.xz"
+ else
+ MY_PV="${PV/_/-}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://github.com/mumble-voip/mumble/releases/download/${MY_PV}/${MY_P}.tar.gz
+ https://dl.mumble.info/${MY_P}.tar.gz"
+ S="${WORKDIR}/${P/_*}"
+ fi
+ KEYWORDS="amd64 ~arm64 ~ppc64 x86"
+fi
+
+LICENSE="BSD MIT"
+SLOT="0"
+IUSE="+alsa +dbus debug g15 jack +opus oss pch portaudio pulseaudio +rnnoise speech zeroconf"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ >=dev-libs/protobuf-2.2.0:=
+ >=media-libs/libsndfile-1.0.20[-minimal]
+ >=media-libs/speex-1.2.0
+ media-libs/speexdsp
+ sys-apps/lsb-release
+ x11-libs/libX11
+ x11-libs/libXi
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:5 )
+ g15? ( app-misc/g15daemon )
+ jack? ( virtual/jack )
+ >=dev-libs/openssl-1.0.0b:0=
+ opus? ( >=media-libs/opus-1.0.1 )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ speech? ( >=app-accessibility/speech-dispatcher-0.8.0 )
+ zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-libs/boost-1.41.0
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+# NB: qmake does not support multilib but it's fine to configure
+# for the native ABI here
+src_configure() {
+ myuse() {
+ [[ -n "${1}" ]] || die "myuse: No use option given"
+ use ${1} || echo no-${1}
+ }
+
+ local conf_add=(
+ bundled-celt
+ no-bundled-opus
+ no-bundled-speex
+ no-embed-qt-translations
+ no-server
+ no-update
+ $(myuse alsa)
+ $(myuse dbus)
+ $(usex debug 'symbols debug' release)
+ $(myuse g15)
+ $(usex jack '' no-jackaudio)
+ $(myuse opus)
+ $(myuse oss)
+ $(myuse portaudio)
+ $(myuse pulseaudio)
+ $(usex rnnoise bundled-rnnoise '')
+ $(usex speech '' no-speechd)
+ $(usex zeroconf '' no-bonjour)
+ )
+
+ use pch || conf_add+=( no-pch )
+
+ eqmake5 "${S}/main.pro" -recursive \
+ CONFIG+="${conf_add[*]}" \
+ DEFINES+="PLUGIN_PATH=/usr/$(get_libdir)/mumble"
+}
+
+multilib_src_compile() {
+ local emake_args=(
+ # place libmumble* in a subdirectory
+ DESTDIR_ADD="/${MULTILIB_ABI_FLAG}"
+ {C,L}FLAGS_ADD="$(get_abi_CFLAGS)"
+ )
+ # build only overlay library for other ABIs
+ multilib_is_native_abi || emake_args+=( -C overlay_gl )
+ emake "${emake_args[@]}"
+ emake clean
+}
+
+src_compile() {
+ multilib_foreach_abi multilib_src_compile
+}
+
+multilib_src_install() {
+ local dir=$(usex debug debug release)
+ insinto /usr/$(get_libdir)/${PN}
+ doins "${dir}/${MULTILIB_ABI_FLAG}"/libmumble.so*
+ if multilib_is_native_abi; then
+ dobin "${dir}"/mumble
+ doins "${dir}"/libcelt0.so* "${dir}"/plugins/lib*.so*
+ fi
+}
+
+src_install() {
+ multilib_foreach_abi multilib_src_install
+
+ newdoc README.Linux README
+ dodoc CHANGES
+ dobin scripts/mumble-overlay
+
+ insinto /usr/share/services
+ doins scripts/mumble.protocol
+
+ domenu scripts/mumble.desktop
+
+ doicon -s scalable icons/mumble.svg
+
+ doman man/mumble-overlay.1
+ doman man/mumble.1
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ echo
+ elog "Visit https://wiki.mumble.info/ for futher configuration instructions."
+ elog "Run mumble-overlay to start the OpenGL overlay (after starting mumble)."
+ echo
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}
diff --git a/net-voip/mumble/mumble-1.4.230-r1.ebuild b/net-voip/mumble/mumble-1.4.230-r1.ebuild
new file mode 100644
index 000000000000..690186d97251
--- /dev/null
+++ b/net-voip/mumble/mumble-1.4.230-r1.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
+HOMEPAGE="https://wiki.mumble.info"
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mumble-voip/mumble.git"
+ EGIT_SUBMODULES=( '-*' celt-0.7.0-src celt-0.11.0-src themes/Mumble 3rdparty/rnnoise-src 3rdparty/FindPythonInterpreter )
+else
+ if [[ "${PV}" == *_pre* ]] ; then
+ SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${P}.tar.xz"
+ else
+ MY_PV="${PV/_/-}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://github.com/mumble-voip/mumble/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+ S="${WORKDIR}/${P/_*}.src"
+ fi
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+SRC_URI+=" https://dev.gentoo.org/~polynomial-c/${PN}-1.4-openssl3.patch.xz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+IUSE="+alsa +dbus debug g15 jack pipewire portaudio pulseaudio multilib nls +rnnoise speech test zeroconf"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/openssl-1.0.0b:0=
+ dev-libs/poco[util,xml,zip]
+ >=dev-libs/protobuf-2.2.0:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ >=media-libs/libsndfile-1.0.20[-minimal]
+ >=media-libs/opus-1.3.1
+ >=media-libs/speex-1.2.0
+ media-libs/speexdsp
+ sys-apps/lsb-release
+ x11-libs/libX11
+ x11-libs/libXi
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:5 )
+ g15? ( app-misc/g15daemon:= )
+ jack? ( virtual/jack )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ pipewire? ( media-video/pipewire )
+ speech? ( >=app-accessibility/speech-dispatcher-0.8.0 )
+ zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ dev-qt/qttest:5
+ >=dev-libs/boost-1.41.0
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${WORKDIR}/${PN}-1.4-openssl3.patch"
+ "${FILESDIR}/${PN}-1.4.230-gcc12-include-memory.patch"
+ "${FILESDIR}/${PN}-1.4.230-poco-link-cmake.patch"
+)
+
+src_prepare() {
+ # required because of xdg.eclass also providing src_prepare
+ cmake_src_prepare
+}
+
+src_configure() {
+
+ local mycmakeargs=(
+ -Dalsa="$(usex alsa)"
+ -Dtests="$(usex test)"
+ -Dbundled-celt="ON"
+ -Dbundled-opus="OFF"
+ -Dbundled-speex="OFF"
+ -Ddbus="$(usex dbus)"
+ -Dg15="$(usex g15)"
+ -Djackaudio="$(usex jack)"
+ -Doverlay="ON"
+ -Dportaudio="$(usex portaudio)"
+ -Doverlay-xcompile="$(usex multilib)"
+ -Dpipewire="$(usex pipewire)"
+ -Dpulseaudio="$(usex pulseaudio)"
+ -Drnnoise="$(usex rnnoise)"
+ -Dserver="OFF"
+ -Dspeechd="$(usex speech)"
+ -Dtranslations="$(usex nls)"
+ -Dupdate="OFF"
+ -Dwarnings-as-errors="OFF"
+ -Dzeroconf="$(usex zeroconf)"
+ )
+
+ if [[ "${PV}" != 9999 ]] ; then
+ mycmakeargs+=( -DBUILD_NUMBER="$(ver_cut 3)" )
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use amd64 && use multilib ; then
+ # The 32bit overlay library gets built when multilib is enabled.
+ # Install it into the correct 32bit lib dir.
+ local libdir_64="/usr/$(get_libdir)/mumble"
+ local libdir_32="/usr/$(get_abi_var LIBDIR x86)/mumble"
+ dodir ${libdir_32}
+ mv "${ED}"/${libdir_64}/libmumbleoverlay.x86.so* \
+ "${ED}"/${libdir_32}/ || die
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ echo
+ elog "Visit https://wiki.mumble.info/ for futher configuration instructions."
+ elog "Run 'mumble-overlay <program>' to start the OpenGL overlay (after starting mumble)."
+ echo
+}
diff --git a/net-voip/mumble/mumble-9999.ebuild b/net-voip/mumble/mumble-9999.ebuild
new file mode 100644
index 000000000000..009f89b12418
--- /dev/null
+++ b/net-voip/mumble/mumble-9999.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
+HOMEPAGE="https://wiki.mumble.info"
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mumble-voip/mumble.git"
+ EGIT_SUBMODULES=( '-*' celt-0.7.0-src celt-0.11.0-src themes/Mumble 3rdparty/rnnoise-src 3rdparty/FindPythonInterpreter 3rdparty/tracy )
+else
+ if [[ "${PV}" == *_pre* ]] ; then
+ SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${P}.tar.xz"
+ else
+ MY_PV="${PV/_/-}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://github.com/mumble-voip/mumble/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+ S="${WORKDIR}/${P/_*}.src"
+ fi
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="BSD MIT"
+SLOT="0"
+IUSE="+alsa +dbus debug g15 jack pipewire portaudio pulseaudio multilib nls +rnnoise speech test zeroconf"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/openssl-1.0.0b:0=
+ dev-libs/poco[util,xml,zip]
+ >=dev-libs/protobuf-2.2.0:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ >=media-libs/libsndfile-1.0.20[-minimal]
+ >=media-libs/opus-1.3.1
+ >=media-libs/speex-1.2.0
+ media-libs/speexdsp
+ sys-apps/lsb-release
+ x11-libs/libX11
+ x11-libs/libXi
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:5 )
+ g15? ( app-misc/g15daemon:= )
+ jack? ( virtual/jack )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ pipewire? ( media-video/pipewire )
+ speech? ( >=app-accessibility/speech-dispatcher-0.8.0 )
+ zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
+"
+DEPEND="${RDEPEND}
+ dev-cpp/nlohmann_json
+ dev-qt/qtconcurrent:5
+ dev-qt/qttest:5
+ >=dev-libs/boost-1.41.0
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed '/TRACY_ON_DEMAND/s@ ON @ OFF @' -i src/CMakeLists.txt || die
+
+ # required because of xdg.eclass also providing src_prepare
+ cmake_src_prepare
+}
+
+src_configure() {
+
+ local mycmakeargs=(
+ -Dalsa="$(usex alsa)"
+ -Dbundled-celt="ON"
+ -Dbundled-json="OFF"
+ -Dbundled-opus="OFF"
+ -Dbundled-speex="OFF"
+ -Ddbus="$(usex dbus)"
+ -Dg15="$(usex g15)"
+ -Djackaudio="$(usex jack)"
+ -Doverlay="ON"
+ -Dportaudio="$(usex portaudio)"
+ -Doverlay-xcompile="$(usex multilib)"
+ -Dpipewire="$(usex pipewire)"
+ -Dpulseaudio="$(usex pulseaudio)"
+ -Drnnoise="$(usex rnnoise)"
+ -Dserver="OFF"
+ -Dspeechd="$(usex speech)"
+ -Dtests="$(usex test)"
+ -Dtracy="OFF"
+ -Dtranslations="$(usex nls)"
+ -Dupdate="OFF"
+ -Dwarnings-as-errors="OFF"
+ -Dzeroconf="$(usex zeroconf)"
+ )
+
+ if [[ "${PV}" != 9999 ]] ; then
+ mycmakeargs+=( -DBUILD_NUMBER="$(ver_cut 3)" )
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use amd64 && use multilib ; then
+ # The 32bit overlay library gets built when multilib is enabled.
+ # Install it into the correct 32bit lib dir.
+ local libdir_64="/usr/$(get_libdir)/mumble"
+ local libdir_32="/usr/$(get_abi_var LIBDIR x86)/mumble"
+ dodir ${libdir_32}
+ mv "${ED}"/${libdir_64}/libmumbleoverlay.x86.so* \
+ "${ED}"/${libdir_32}/ || die
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ echo
+ elog "Visit https://wiki.mumble.info/ for futher configuration instructions."
+ elog "Run 'mumble-overlay <program>' to start the OpenGL overlay (after starting mumble)."
+ echo
+}