summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-10-31 23:15:06 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-10-31 23:16:15 +0300
commit9d99d1b2d4d56710ea6a9e1897549a6896205dc2 (patch)
tree1ec8597ba5ff949768895a803e402400250a10be /net-p2p
parentdev-python/ddt: drop 1.4.2, 1.4.3 (diff)
downloadgentoo-9d99d1b2d4d56710ea6a9e1897549a6896205dc2.tar.gz
gentoo-9d99d1b2d4d56710ea6a9e1897549a6896205dc2.tar.bz2
gentoo-9d99d1b2d4d56710ea6a9e1897549a6896205dc2.zip
net-p2p/qbittorrent: Version bump (v4.3.9)
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.3.9.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 762b43e25a30..131553e3d8ed 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -4,3 +4,4 @@ DIST qbittorrent-4.3.4.1.tar.gz 8057119 BLAKE2B a5e59aab555feaa2638c3ff60df97ae0
DIST qbittorrent-4.3.5.tar.gz 8128281 BLAKE2B 656b64cfcddba37197b7a87ff3281168649d51e127a69dd489c89f11d8ff6cca7de722f4a5188742cf4efb592e0acbf3b1be69dd804d52d25d8c3e13fdf39e32 SHA512 7bfc9e280e70093b74dafae9a6f921cf27f6828ea03ac3510c3419131b40a1610090d335a831697c9b690f47e396700f7b5a4b14dec47a9f12f4ed797f30d0dd
DIST qbittorrent-4.3.7.tar.gz 8494224 BLAKE2B 68f402619069fea87c5120e97f381d589f2acdede125644feb6b9e57f334ffebe8d9f95dc3da2b819f783414249da78357fcba64910ca4e77af8860afbcc046c SHA512 53a7bd7b21f0439d9407e8c823086004c1f01d856903e22a7f5a5b97c5ef39f807d6168158af1eb008fab21c78f7c81b8d8e142a3f3f74d5232653f43559cafd
DIST qbittorrent-4.3.8.tar.gz 8506355 BLAKE2B e59be1556ad0be697e32d69d890115df6ce20a46f883a9060994558db02f06cf87fbf68a17e6317e1b5819af523281bdd8cfdcc8ae68a0d707a238023dcc7840 SHA512 bb03f27f0807dfac867ddf5a6fcec1687946068a7e7d88483f0ded34d7279aa0d3324fe25f23c22ce80ee98437d8914229c5969ea8849eed1d4ad68e031601e2
+DIST qbittorrent-4.3.9.tar.gz 8510414 BLAKE2B de98aff6d81f43c3ad87f6c5f800a4488e18173fb96713d0a2420cf4d4708c9b1f2f54c8d0aa566e7738b4f94d192aad9f0196a05d43724582ef81833901727f SHA512 ec33f67895fbf47acc2f79d9c9e16db8b96c756cf493b76eb24b90e13a790a709104ea9aa378ee111d8c38b605bed5192b366d1917bbf160b21aa2ae3aacd2d1
diff --git a/net-p2p/qbittorrent/qbittorrent-4.3.9.ebuild b/net-p2p/qbittorrent/qbittorrent-4.3.9.ebuild
new file mode 100644
index 000000000000..43ca7eae242b
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.3.9.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.2.12:0=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ econf \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui)
+}
+
+src_install() {
+ emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}