summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-01 16:19:35 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-01 16:19:51 +0200
commit8d06a65cb72da5389edd4979e802beb662d7fc4f (patch)
tree83effac63842b2745a833364ea311ed426475526 /net-p2p
parentmedia-libs/libxmi: Stable for HPPA (bug #563956). (diff)
downloadgentoo-8d06a65cb72da5389edd4979e802beb662d7fc4f.tar.gz
gentoo-8d06a65cb72da5389edd4979e802beb662d7fc4f.tar.bz2
gentoo-8d06a65cb72da5389edd4979e802beb662d7fc4f.zip
net-p2p/amule: Version bump, also use wxGTK3.0 (supported now officially by upstream).
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/Manifest1
-rw-r--r--net-p2p/amule/amule-2.3.2.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/net-p2p/amule/Manifest b/net-p2p/amule/Manifest
index f28d61eb9213..2503136cb440 100644
--- a/net-p2p/amule/Manifest
+++ b/net-p2p/amule/Manifest
@@ -1 +1,2 @@
DIST aMule-2.3.1.tar.bz2 4565232 SHA256 d2eda19c34ec574fa123efb95726c7cc241b093c95d074a5161ee7330dece69d SHA512 3310aa6e92dde0e27df032da701bc28533c703277ddeec3766fb0e945725ed340b2d3fe54016172621a47559b6c13fb2893cba0d2469a1038ab35c3ee2d5a3c3 WHIRLPOOL 1e1a27ebaed1c8f49093dc6a75a0b9c5fd1ad5a3390585d08b1db2b8cd00397e2d519b01720d5d2131b779f9bc0137d9a6aba603117295b185c3db716cc7dba2
+DIST aMule-2.3.2.tar.xz 3895300 SHA256 f64720fdc8c6cfa06bdcd4ca3922d30a0ddddba9c897f5bec7605009c7683928 SHA512 3064b086f8459b4372ea0c11f239a08167c7beac3dde26889f056f617b480b487bea10c2cae8fdfa1ae99c10fc9e715adc8e01e4b968389861aa47c3ec8c0016 WHIRLPOOL 2907069f705dcb438fb78e049d9a417d42401bff659924c7ed66451b22c6dd35baf52e8100ca81e06c24cd1418ba586e16746bcb4e27314c15fd29407b4e3298
diff --git a/net-p2p/amule/amule-2.3.2.ebuild b/net-p2p/amule/amule-2.3.2.ebuild
new file mode 100644
index 000000000000..1445fd5fd1e8
--- /dev/null
+++ b/net-p2p/amule/amule-2.3.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+WX_GTK_VER="3.0"
+
+inherit wxwidgets user
+
+MY_P=${PN/m/M}-${PV}
+S="${WORKDIR}"/${MY_P}
+
+DESCRIPTION="aMule, the all-platform eMule p2p client"
+HOMEPAGE="http://www.amule.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="daemon debug geoip nls remote stats unicode upnp +X"
+
+DEPEND="
+ >=dev-libs/crypto++-5
+ sys-libs/binutils-libs:0=
+ >=sys-libs/zlib-1.2.1
+ x11-libs/wxGTK:${WX_GTK_VER}[X?]
+ stats? ( >=media-libs/gd-2.0.26:=[jpeg] )
+ geoip? ( dev-libs/geoip )
+ upnp? ( >=net-libs/libupnp-1.6.6 )
+ remote? ( >=media-libs/libpng-1.2.0:0=
+ unicode? ( >=media-libs/gd-2.0.26:= ) )
+ !net-p2p/imule
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.6-fallocate.diff
+)
+
+pkg_setup() {
+ if use stats && ! use X; then
+ einfo "Note: You would need both the X and stats USE flags"
+ einfo "to compile aMule Statistics GUI."
+ einfo "I will now compile console versions only."
+ fi
+}
+
+pkg_preinst() {
+ if use daemon || use remote; then
+ enewgroup p2p
+ enewuser p2p -1 -1 /home/p2p p2p
+ fi
+}
+
+src_configure() {
+ local myconf
+
+ if use X; then
+ einfo "wxGTK with X support will be used"
+ need-wxwidgets unicode
+ else
+ einfo "wxGTK without X support will be used"
+ need-wxwidgets base-unicode
+ fi
+
+ if use X ; then
+ use stats && myconf="${myconf}
+ --enable-wxcas
+ --enable-alc"
+ use remote && myconf="${myconf}
+ --enable-amule-gui"
+ else
+ myconf="
+ --disable-monolithic
+ --disable-amule-gui
+ --disable-wxcas
+ --disable-alc"
+ fi
+
+ econf \
+ --with-denoise-level=0 \
+ --with-wx-config="${WX_CONFIG}" \
+ --enable-amulecmd \
+ --without-boost \
+ $(use_enable debug) \
+ $(use_enable daemon amule-daemon) \
+ $(use_enable geoip) \
+ $(use_enable nls) \
+ $(use_enable remote webserver) \
+ $(use_enable stats cas) \
+ $(use_enable stats alcc) \
+ $(use_enable upnp) \
+ ${myconf}
+}
+
+src_install() {
+ default
+
+ if use daemon; then
+ newconfd "${FILESDIR}"/amuled.confd amuled
+ newinitd "${FILESDIR}"/amuled.initd amuled
+ fi
+ if use remote; then
+ newconfd "${FILESDIR}"/amuleweb.confd amuleweb
+ newinitd "${FILESDIR}"/amuleweb.initd amuleweb
+ fi
+}