summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-08-06 17:00:19 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-08-06 17:00:19 -0500
commit940883306bdc93e28601f8bdc36ed872dbb6b772 (patch)
tree0cf10e4bc62cccc7059195f8bbaa86b01b18ab5f /net-p2p
parentnet-p2p/kubo: add 0.14.0 (diff)
downloadgentoo-940883306bdc93e28601f8bdc36ed872dbb6b772.tar.gz
gentoo-940883306bdc93e28601f8bdc36ed872dbb6b772.tar.bz2
gentoo-940883306bdc93e28601f8bdc36ed872dbb6b772.zip
net-p2p/kubo: drop 0.13.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/kubo/Manifest1
-rw-r--r--net-p2p/kubo/kubo-0.13.1.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/net-p2p/kubo/Manifest b/net-p2p/kubo/Manifest
index 967a7462e020..4da89e4f1e0d 100644
--- a/net-p2p/kubo/Manifest
+++ b/net-p2p/kubo/Manifest
@@ -1,3 +1,2 @@
-DIST kubo-0.13.1.tar.gz 13474891 BLAKE2B 2e6e056e27a8783c9d04ea5d8c41d86e45250f5ba95c57737aaf52d36d453be31baab21767008596710d7eb84f471460c32de70faf1764740ea551a5aa4bd38e SHA512 3257d49df61bb31d4054934506ea543df2d9ed1f57b9b6aeef001bb77fe9fdce646fec96ded72b7f9f99e3bc687da77997b1295ebb5a40e20e4df0413e15bfd7
DIST kubo-0.14.0-deps.tar.xz 169389828 BLAKE2B 9b664286885ad16eba2697bfbd87286fc35edb034beb0b80bcfa307af507013964f83783b0036d35d1e132f0a2a549e96f50f527cb3812cfe1417b36f7c416ed SHA512 cabb3c48bfc5d38996c5635b62b4a8dc49ca497cbe011e51c33086f18882fa74bc613644a4289639a7278dad634c66351c650c8ae041c9fca7f9f2c914644dd2
DIST kubo-0.14.0.tar.gz 2224560 BLAKE2B d03f2ae98833f07a55cb8d929e3433ee35ad53345c31c80963ff4a183cbfa2ebf803607e0123b08304022673c1aa05013698d2cd3b97b4ecae84f4c4c5b69ab4 SHA512 ecba5d3669d50c382bff1b4d0197f5d8f67f36bb6e995d1db5791413bcf813ea8bf22fd3ea00368c0cf33cfc45621ea2f258acb52bda2b42ee2e1a7392195c10
diff --git a/net-p2p/kubo/kubo-0.13.1.ebuild b/net-p2p/kubo/kubo-0.13.1.ebuild
deleted file mode 100644
index 82573032a2ae..000000000000
--- a/net-p2p/kubo/kubo-0.13.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 go-module systemd
-
-DESCRIPTION="Main implementation of IPFS"
-HOMEPAGE="https://ipfs.io/"
-SRC_URI="https://github.com/ipfs/${PN}/releases/download/v${PV}/go-ipfs-source.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- acct-group/ipfs
- acct-user/ipfs
- sys-fs/fuse:0
-"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md docs/ )
-
-S="${WORKDIR}"
-
-src_compile() {
- default
-
- local mygoargs
- mygoargs=(
- -tags release
- )
-
- go build "${mygoargs[@]}" -o ipfs ./cmd/ipfs || die
- go build "${mygoargs[@]}" -o ipfswatch ./cmd/ipfswatch || die
-
- IPFS_PATH="" ./ipfs commands completion bash > ipfs-completion.bash || die
-}
-
-src_test() {
- go test ./cmd/ipfs/... ./cmd/ipfswatch/... || die
-}
-
-src_install() {
- dobin ipfs
- dobin ipfswatch
- newbashcomp ipfs-completion.bash ipfs
- einstalldocs
-
- systemd_dounit "${FILESDIR}/ipfs.service"
- systemd_newunit "${FILESDIR}/ipfs-at.service" "ipfs@.service"
-
- newinitd "${FILESDIR}/ipfs.init" ipfs
- newconfd "${FILESDIR}/ipfs.confd" ipfs
-
- keepdir /var/log/ipfs
- fowners -R ipfs:ipfs /var/log/ipfs
-}
-
-pkg_postinst() {
- elog 'To be able to use the ipfs service you will need to create the ipfs repository'
- elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
- elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
-
- # See https://bugs.gentoo.org/838238
- ewarn 'In case kubo CPU usage is too high run the next workaround'
- ewarn 'su -s /bin/sh -c "ipfs config profile apply lowpower" ipfs'
- ewarn 'Be aware that this will make your node less visible to other peers'
-}