summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-02 23:57:26 +0000
committerSam James <sam@gentoo.org>2021-06-03 19:15:02 +0000
commite300beafe0bd18c72b852405ba3a24ee9ac67c8b (patch)
treee35fa2275c5adf0a72ab46072b187a699136fcc8 /net-nds
parentnet-misc/asterisk: fix BadDefaultUseFlags (diff)
downloadgentoo-e300beafe0bd18c72b852405ba3a24ee9ac67c8b.tar.gz
gentoo-e300beafe0bd18c72b852405ba3a24ee9ac67c8b.tar.bz2
gentoo-e300beafe0bd18c72b852405ba3a24ee9ac67c8b.zip
net-nds/openldap: fix BadDefaultUseFlags
-foo in IUSE is discouraged. It is equivalent (in every meaningful case) to 'foo' but confuses parsing tools like e.g. packages.gentoo.org. Dropping '-' from these flags has no impact on the actual default behaviour. See: https://devmanual.gentoo.org/general-concepts/use-flags/index.html#iuse-defaults Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/openldap-2.4.57.ebuild2
-rw-r--r--net-nds/openldap/openldap-2.4.58.ebuild2
-rw-r--r--net-nds/openldap/openldap-2.5.4.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/net-nds/openldap/openldap-2.4.57.ebuild b/net-nds/openldap/openldap-2.4.57.ebuild
index 275d24ff2e0b..2a461032a16c 100644
--- a/net-nds/openldap/openldap-2.4.57.ebuild
+++ b/net-nds/openldap/openldap-2.4.57.ebuild
@@ -29,7 +29,7 @@ IUSE_BACKEND="+berkdb"
IUSE_OVERLAY="overlays perl"
IUSE_OPTIONAL="gnutls iodbc sasl ssl odbc debug ipv6 +syslog selinux static-libs test"
IUSE_CONTRIB="smbkrb5passwd kerberos kinit pbkdf2 sha2"
-IUSE_CONTRIB="${IUSE_CONTRIB} -cxx"
+IUSE_CONTRIB="${IUSE_CONTRIB} cxx"
IUSE="${IUSE_DAEMON} ${IUSE_BACKEND} ${IUSE_OVERLAY} ${IUSE_OPTIONAL} ${IUSE_CONTRIB}"
RESTRICT="!test? ( test )"
diff --git a/net-nds/openldap/openldap-2.4.58.ebuild b/net-nds/openldap/openldap-2.4.58.ebuild
index 02f6d9096b6b..67b024653c5f 100644
--- a/net-nds/openldap/openldap-2.4.58.ebuild
+++ b/net-nds/openldap/openldap-2.4.58.ebuild
@@ -29,7 +29,7 @@ IUSE_BACKEND="+berkdb"
IUSE_OVERLAY="overlays perl"
IUSE_OPTIONAL="gnutls iodbc sasl ssl odbc debug ipv6 +syslog selinux static-libs test"
IUSE_CONTRIB="smbkrb5passwd kerberos kinit pbkdf2 sha2"
-IUSE_CONTRIB="${IUSE_CONTRIB} -cxx"
+IUSE_CONTRIB="${IUSE_CONTRIB} cxx"
IUSE="${IUSE_DAEMON} ${IUSE_BACKEND} ${IUSE_OVERLAY} ${IUSE_OPTIONAL} ${IUSE_CONTRIB}"
RESTRICT="!test? ( test )"
diff --git a/net-nds/openldap/openldap-2.5.4.ebuild b/net-nds/openldap/openldap-2.5.4.ebuild
index dccb2e94a857..b43e411f2758 100644
--- a/net-nds/openldap/openldap-2.5.4.ebuild
+++ b/net-nds/openldap/openldap-2.5.4.ebuild
@@ -28,7 +28,7 @@ IUSE_DAEMON="crypt samba tcpd experimental minimal"
IUSE_OVERLAY="overlays perl"
IUSE_OPTIONAL="gnutls iodbc sasl ssl odbc debug ipv6 +syslog selinux static-libs test"
IUSE_CONTRIB="smbkrb5passwd kerberos kinit pbkdf2 sha2"
-IUSE_CONTRIB="${IUSE_CONTRIB} -cxx"
+IUSE_CONTRIB="${IUSE_CONTRIB} cxx"
IUSE="${IUSE_DAEMON} ${IUSE_BACKEND} ${IUSE_OVERLAY} ${IUSE_OPTIONAL} ${IUSE_CONTRIB}"
RESTRICT="!test? ( test )"