summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-03-01 10:55:00 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-03-01 11:00:49 -0500
commit65ab9d921b8a33b6cbcbf6504f76974889168407 (patch)
tree09e4ea1dbbf7efae7acadfb065c557e8bc232b77 /net-misc/ytfzf
parentgames-arcade/kobodeluxe: Update icon cache (diff)
downloadgentoo-65ab9d921b8a33b6cbcbf6504f76974889168407.tar.gz
gentoo-65ab9d921b8a33b6cbcbf6504f76974889168407.tar.bz2
gentoo-65ab9d921b8a33b6cbcbf6504f76974889168407.zip
net-misc/ytfzf: add 2.5.5
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/ytfzf')
-rw-r--r--net-misc/ytfzf/Manifest1
-rw-r--r--net-misc/ytfzf/ytfzf-2.5.5.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
index eee178f4360e..a97b233c2ef3 100644
--- a/net-misc/ytfzf/Manifest
+++ b/net-misc/ytfzf/Manifest
@@ -1,2 +1,3 @@
DIST ytfzf-2.5.3.tar.gz 3265442 BLAKE2B e920bf60a567741cc84739d20f282c27036eafaa823ea273439e49f9b855798a11f611ee8b4893490538d24c3039f2780451272f82ead73c45fb0f2124e05417 SHA512 fcc9e6064fe381972f30a94fd418ba9a497fed4be891f40b75e608a4c095f7b311000ae104d8e877b52622defa4ff57cb0ec1ace4d034ba08f0ff3985438d58d
DIST ytfzf-2.5.4.tar.gz 3273455 BLAKE2B 9e4ba90cca7a17fc8c7283097db1925582b9dbb85b9b83db77f2e20a48db7566a8396114256bcb61bffb281ac0ce64f199702f495cd07f2e4e11d0c81605a973 SHA512 48ab12314a638d2682eb387c1d0bd2c8979762287194d897d801c1b845c28e3e6c2b383e1fede75e0b0649ab401855e6a9ee48a58cfc4e08b0f291da877ed150
+DIST ytfzf-2.5.5.tar.gz 3278740 BLAKE2B e80ee83cbd80fd3d53dd4e3f9aca4fed71b6bbebc6b0f0d8c85263efa4dfd184e45998719df966279365378669624119035f069c4d2b2d5f820e5304bd36604d SHA512 811fbc1de1b23bddd988c74212f0d6b314e5a7998ebc06e0481d42a5e6afa530f10a0e749a293a76799eff1fc380ebd54210f5e152c6d8ab07fd39327544c9d7
diff --git a/net-misc/ytfzf/ytfzf-2.5.5.ebuild b/net-misc/ytfzf/ytfzf-2.5.5.ebuild
new file mode 100644
index 000000000000..28d4e09cb02b
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.5.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X minimal"
+
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ app-alternatives/awk
+ !minimal? (
+ X? ( media-gfx/ueberzug )
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ )"
+
+src_compile() { :; }
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ emake "${emakeargs[@]}" addons doc install
+ einstalldocs
+
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that ${PN} supports many methods to display menus/thumbnails."
+ elog "This ebuild primarily covers defaults and major features, additional"
+ elog "dependencies may be needed for others. Set USE=minimal if want full"
+ elog "control over optional dependencies (e.g. fzf is optional if use dmenu)."
+ fi
+}