summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2021-01-07 01:22:23 +0200
committerAndreas K. Huettel <dilfridge@gentoo.org>2021-01-07 01:22:51 +0200
commit4d9f459c5afd7b7fe9ae0068b4ad655606c3a544 (patch)
tree78da80965480034979d0ea854a90366292571491 /net-misc/ntp
parentnet-p2p/opendchub: Apply gcc-10 workaround (diff)
downloadgentoo-4d9f459c5afd7b7fe9ae0068b4ad655606c3a544.tar.gz
gentoo-4d9f459c5afd7b7fe9ae0068b4ad655606c3a544.tar.bz2
gentoo-4d9f459c5afd7b7fe9ae0068b4ad655606c3a544.zip
net-misc/ntp: Fix build with gcc-10
Closes: https://bugs.gentoo.org/759409 Bug: https://bugs.ntp.org/show_bug.cgi?id=3688 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
Diffstat (limited to 'net-misc/ntp')
-rw-r--r--net-misc/ntp/files/ntp-4.2.8_p15-gcc10.patch75
-rw-r--r--net-misc/ntp/ntp-4.2.8_p15.ebuild3
2 files changed, 77 insertions, 1 deletions
diff --git a/net-misc/ntp/files/ntp-4.2.8_p15-gcc10.patch b/net-misc/ntp/files/ntp-4.2.8_p15-gcc10.patch
new file mode 100644
index 000000000000..619ea07558c2
--- /dev/null
+++ b/net-misc/ntp/files/ntp-4.2.8_p15-gcc10.patch
@@ -0,0 +1,75 @@
+
+Source:
+https://bugs.ntp.org/show_bug.cgi?id=3688
+
+Juergen Perlinger 2020-12-24 07:10:49 UTC
+Created attachment 1760 [details]
+ultimate patch, v00
+
+--- a/sntp/log.c 2020-12-24 08:02:05.206004072 +0100
++++ a/sntp/log.c 2020-12-24 08:02:05.206004072 +0100
+@@ -2,7 +2,7 @@
+
+ #include "log.h"
+
+-const char *progname; /* for msyslog use too */
++extern const char *progname; /* for msyslog use too */
+
+ static int counter = 0;
+
+--- a/sntp/main.c 2020-12-24 08:02:05.210003956 +0100
++++ a/sntp/main.c 2020-12-24 08:02:05.210003956 +0100
+@@ -20,7 +20,6 @@
+ #include "log.h"
+ #include "libntp.h"
+
+-
+ int shutting_down;
+ int time_derived;
+ int time_adjusted;
+--- a/sntp/main.h 2020-12-24 08:02:05.210003956 +0100
++++ a/sntp/main.h 2020-12-24 08:02:05.210003956 +0100
+@@ -16,6 +16,14 @@
+
+ #include "crypto.h"
+
++/* !Attention! 'progname' must de instantiated in any program that wants
++ * to use this library. Putting it into the library breaks a lot of
++ * things, since many programs define it itself and then the symbol
++ * might end up twice in the linker.
++ */
++extern const char * progname;
++
++
+ void set_li_vn_mode(struct pkt *spkt, char leap, char version, char mode);
+ extern int sntp_main(int argc, char **argv, const char *);
+ int generate_pkt(struct pkt *x_pkt, const struct timeval *tv_xmt,
+--- a/sntp/sntp.c 2020-12-24 08:02:05.210003956 +0100
++++ a/sntp/sntp.c 2020-12-24 08:02:05.210003956 +0100
+@@ -2,6 +2,8 @@
+
+ #include "main.h"
+
++const char * progname;
++
+ int
+ main (
+ int argc,
+--- a/sntp/tests/t-log.c 2020-12-24 08:02:05.210003956 +0100
++++ a/sntp/tests/t-log.c 2020-12-24 08:02:05.210003956 +0100
+@@ -3,7 +3,6 @@
+ #include "ntp_types.h"
+
+
+-//#include "log.h"
+ #include "log.c"
+
+ void setUp(void);
+--- a/tests/libntp/test-libntp.h 2020-12-24 08:02:05.210003956 +0100
++++ a/tests/libntp/test-libntp.h 2020-12-24 08:02:05.210003956 +0100
+@@ -5,4 +5,4 @@
+
+ time_t timefunc(time_t *ptr);
+ void settime(int y, int m, int d, int H, int M, int S);
+-time_t nowtime;
++extern time_t nowtime;
diff --git a/net-misc/ntp/ntp-4.2.8_p15.ebuild b/net-misc/ntp/ntp-4.2.8_p15.ebuild
index 7864b4189d44..1405367f2d42 100644
--- a/net-misc/ntp/ntp-4.2.8_p15.ebuild
+++ b/net-misc/ntp/ntp-4.2.8_p15.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -48,6 +48,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.2.8_p10-fix-build-wo-ssl-or-libressl.patch
"${FILESDIR}"/${PN}-4.2.8_p12-libressl-2.8.patch
"${FILESDIR}"/${PN}-4.2.8_p14-add_cap_ipc_lock.patch #711530
+ "${FILESDIR}"/${PN}-4.2.8_p15-gcc10.patch #759409
)
src_prepare() {