summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-11 07:15:32 +0100
committerSam James <sam@gentoo.org>2022-06-11 07:15:32 +0100
commit9cbba7cb4ccab1d8c79371d75ef63cd0a12bce3d (patch)
tree7255935626ea081c3aec57dc0e2af6c0883cfc1a /net-misc/mptcpd
parentapp-misc/ddcutil: drop Werror (diff)
downloadgentoo-9cbba7cb4ccab1d8c79371d75ef63cd0a12bce3d.tar.gz
gentoo-9cbba7cb4ccab1d8c79371d75ef63cd0a12bce3d.tar.bz2
gentoo-9cbba7cb4ccab1d8c79371d75ef63cd0a12bce3d.zip
net-misc/mptcpd: drop Werror
Doesn't fix the actual musl issue though Bug: https://bugs.gentoo.org/832563 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/mptcpd')
-rw-r--r--net-misc/mptcpd/files/mptcpd-0.9-no-werror.patch21
-rw-r--r--net-misc/mptcpd/mptcpd-0.9.ebuild8
-rw-r--r--net-misc/mptcpd/mptcpd-9999.ebuild4
3 files changed, 31 insertions, 2 deletions
diff --git a/net-misc/mptcpd/files/mptcpd-0.9-no-werror.patch b/net-misc/mptcpd/files/mptcpd-0.9-no-werror.patch
new file mode 100644
index 000000000000..7e3357c8e361
--- /dev/null
+++ b/net-misc/mptcpd/files/mptcpd-0.9-no-werror.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/832563
+--- a/configure.ac
++++ b/configure.ac
+@@ -31,7 +31,7 @@ dnl Support "--enable-debug=..." configure script command line option.
+ AX_IS_RELEASE([git-directory])
+ AX_CHECK_ENABLE_DEBUG([yes])
+
+-AM_INIT_AUTOMAKE([1.15 -Wall -Werror -Wno-portability silent-rules std-options check-news])
++AM_INIT_AUTOMAKE([1.15 -Wall -Wno-portability silent-rules std-options check-news])
+ AM_SILENT_RULES([yes])
+ LT_INIT([disable-static])
+
+@@ -301,7 +301,7 @@ LIBS=$mptcpd_save_libs
+ # warning free.
+ # ---------------------------------------------------------------
+ AX_CFLAGS_WARN_ALL([CFLAGS])
+-AX_APPEND_COMPILE_FLAGS([-Wextra -Werror -pedantic])
++AX_APPEND_COMPILE_FLAGS([-Wextra -pedantic])
+
+ # ---------------------------------------------------------------
+ # Enable compile-time defense
diff --git a/net-misc/mptcpd/mptcpd-0.9.ebuild b/net-misc/mptcpd/mptcpd-0.9.ebuild
index a35610eb41ad..f678fe599d7a 100644
--- a/net-misc/mptcpd/mptcpd-0.9.ebuild
+++ b/net-misc/mptcpd/mptcpd-0.9.ebuild
@@ -41,9 +41,15 @@ fi
CONFIG_CHECK="MPTCP"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9-no-werror.patch
+)
+
src_prepare() {
default
- [[ ${PV} == 9999* ]] && eautoreconf
+
+ # For Werror patch
+ eautoreconf
}
src_configure() {
diff --git a/net-misc/mptcpd/mptcpd-9999.ebuild b/net-misc/mptcpd/mptcpd-9999.ebuild
index 8f307676ab46..8265562c6a0c 100644
--- a/net-misc/mptcpd/mptcpd-9999.ebuild
+++ b/net-misc/mptcpd/mptcpd-9999.ebuild
@@ -40,7 +40,9 @@ CONFIG_CHECK="MPTCP"
src_prepare() {
default
- [[ ${PV} == 9999* ]] && eautoreconf
+
+ # For Werror patch
+ eautoreconf
}
src_configure() {