summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2019-04-21 14:24:04 +0900
committerNaohiro Aota <naota@gentoo.org>2019-04-21 14:31:02 +0900
commit591e3361d6f28687c51958e4d0bfe9b634406da3 (patch)
treef5c2bc000647929d96ae3a8d72b3cbac6aa248d5 /net-misc/mikutter
parentdev-ruby/diva: add new package (diff)
downloadgentoo-591e3361d6f28687c51958e4d0bfe9b634406da3.tar.gz
gentoo-591e3361d6f28687c51958e4d0bfe9b634406da3.tar.bz2
gentoo-591e3361d6f28687c51958e4d0bfe9b634406da3.zip
net-misc/mikutter: version bump to 3.8.6
bump to 3.8.6; dropped old ruby versions. Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Naohiro Aota <naota@gentoo.org>
Diffstat (limited to 'net-misc/mikutter')
-rw-r--r--net-misc/mikutter/Manifest2
-rw-r--r--net-misc/mikutter/mikutter-3.8.6.ebuild121
-rw-r--r--net-misc/mikutter/mikutter-9999.ebuild87
3 files changed, 187 insertions, 23 deletions
diff --git a/net-misc/mikutter/Manifest b/net-misc/mikutter/Manifest
index 95c5b6fe4e26..a19eb82d4654 100644
--- a/net-misc/mikutter/Manifest
+++ b/net-misc/mikutter/Manifest
@@ -1 +1,3 @@
DIST mikutter.3.5.4.tar.gz 3743674 BLAKE2B af166219af2a36e84c4e13209830d12be6e085e6c76fa101c265c40bc85d465f50f56311783b647f10ec0021450fd45ca411643e7612e8225df6c9e75ac83be1 SHA512 adb7a1902026ee01737840d0b7f9004ab363e874e01f7c497bd9252fccb3cc16f86f1959bb2eff3d309cb7ba1fa93376d9a1e46d5226859a1279069de7f2ba8e
+DIST mikutter.3.8.6.tar.gz 3174454 BLAKE2B 3fc3802ae840fc310f1b9abd51c560fb804b57aad6bf78bd1e3b8046a42dc785c8a454de722a5e57d499bda15884a255da50d3919a1c5bbcd9e5753948d45f46 SHA512 102c25263df804fd005928ac8605ca4d115040c0e3bd13a09e73bac5b1a4ddedff92b45ac38c54692bf388b5ac8ea422a0b5c42851bb3616c74991943f1cd98f
+DIST twitter_api_keys.rb 336 BLAKE2B 9b134fb9169f96c99582d1ceffe39cfa1675b6e747a8a46f6123cbff73b7e255e59aba3f6cf247decc9824244947d260658011b5aa72a915d50565e797e31703 SHA512 39efeed878f763101329c781fb501c5b5df848e4ae3c1f6bcdf3e6b151c5d647c68127f906eccf7861466d2ff88e7f1bdc27065205ed91a80e9cdc89fa5152e4
diff --git a/net-misc/mikutter/mikutter-3.8.6.ebuild b/net-misc/mikutter/mikutter-3.8.6.ebuild
new file mode 100644
index 000000000000..06d5346485a6
--- /dev/null
+++ b/net-misc/mikutter/mikutter-3.8.6.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25"
+
+inherit eutils ruby-ng
+
+PLUGIN_HASH="30071c3008e4616e723cf4e734fc79254019af09"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://toshia.dip.jp/mikutter.git
+ https://github.com/toshia/twitter_api_keys.git"
+ inherit git-r3
+ SRC_URI="https://raw.githubusercontent.com/toshia/twitter_api_keys/${PLUGIN_HASH}/twitter_api_keys.rb"
+ KEYWORDS=""
+ EGIT_CHECKOUT_DIR="${WORKDIR}/all"
+else
+ MY_P="${PN}.${PV}"
+ SRC_URI="http://mikutter.hachune.net/bin/${MY_P}.tar.gz
+ https://raw.githubusercontent.com/toshia/twitter_api_keys/${PLUGIN_HASH}/twitter_api_keys.rb"
+ KEYWORDS="~amd64"
+ RUBY_S="${PN}"
+fi
+
+DESCRIPTION="Simple, powerful and moeful twitter client"
+HOMEPAGE="http://mikutter.hachune.net/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+libnotify"
+
+DEPEND=""
+RDEPEND="
+ libnotify? ( x11-libs/libnotify )
+ media-sound/alsa-utils"
+
+ruby_add_rdepend "<dev-ruby/addressable-2.6
+ dev-ruby/delayer
+ >=dev-ruby/delayer-deferred-2.0
+ >=dev-ruby/diva-0.3.2
+ dev-ruby/httpclient
+ dev-ruby/json:0
+ dev-ruby/instance_storage
+ dev-ruby/memoist
+ dev-ruby/moneta
+ dev-ruby/nokogiri
+ >=dev-ruby/oauth-0.5.1
+ >=dev-ruby/pluggaloid-1.1.1
+ dev-ruby/rcairo
+ >=dev-ruby/ruby-gettext-3.2.9
+ >=dev-ruby/ruby-gtk2-3.3.0
+ >dev-ruby/ruby-hmac-0.4
+ dev-ruby/totoridipjp
+ dev-ruby/twitter-text:=
+ >dev-ruby/typed-array-0.1
+ virtual/ruby-ssl"
+
+all_ruby_unpack() {
+ if [ "${PV}" = "9999" ];then
+ git-3_src_unpack
+ else
+ default
+ fi
+}
+
+all_ruby_install() {
+ local rubyversion
+
+ if use ruby_targets_ruby25; then
+ rubyversion=ruby25
+ elif use ruby_targets_ruby24; then
+ rubyversion=ruby24
+ fi
+
+ exeinto /usr/share/mikutter
+ doexe mikutter.rb
+ insinto /usr/share/mikutter
+ doins -r core plugin
+ sed -e "s/ruby19/${rubyversion}/" "${FILESDIR}"/mikutter \
+ | newbin - mikutter
+ dodoc README
+ make_desktop_entry mikutter Mikutter \
+ /usr/share/mikutter/core/skin/data/icon.png
+
+ insinto /usr/share/mikutter/plugin/twitter_api_keys
+ newins "${DISTDIR}"/twitter_api_keys.rb twitter_api_keys.rb.in
+}
+
+pkg_postinst() {
+ echo
+ elog "To use Twitter, you need to setup your Consumer Key/Consumer Secret by running"
+ elog " emerge --config =${PF}"
+}
+
+pkg_config() {
+ local PLUGIN_DIR="${EROOT}"/usr/share/mikutter/plugin
+ local CK CS
+
+ echo
+ einfon "Please input your Consumer Key for Twitter: "
+ read -r CK
+
+ echo
+ einfon "Please input your Consumer Secret for Twitter: "
+ read -r CS
+
+ if [ -z "${CK}" -o -z "${CS}" ]; then
+ eerror "Consumer Key or Consumer Secret is missing."
+ return
+ fi
+
+ sed -e "/consumer_key = /s!''!'${CK}'!" \
+ -e "/consumer_secret = /s!''!'${CS}'!" \
+ ${PLUGIN_DIR}/twitter_api_keys/twitter_api_keys.rb.in > \
+ ${PLUGIN_DIR}/twitter_api_keys/twitter_api_keys.rb
+
+ echo
+ einfo "Consuker Key/Consumer secret is set."
+}
diff --git a/net-misc/mikutter/mikutter-9999.ebuild b/net-misc/mikutter/mikutter-9999.ebuild
index 04d1acc69b11..06d5346485a6 100644
--- a/net-misc/mikutter/mikutter-9999.ebuild
+++ b/net-misc/mikutter/mikutter-9999.ebuild
@@ -1,20 +1,25 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-USE_RUBY="ruby22 ruby23"
+USE_RUBY="ruby24 ruby25"
inherit eutils ruby-ng
+PLUGIN_HASH="30071c3008e4616e723cf4e734fc79254019af09"
+
if [ "${PV}" = "9999" ]; then
- EGIT_REPO_URI="git://toshia.dip.jp/mikutter.git"
- inherit git-2
+ EGIT_REPO_URI="git://toshia.dip.jp/mikutter.git
+ https://github.com/toshia/twitter_api_keys.git"
+ inherit git-r3
+ SRC_URI="https://raw.githubusercontent.com/toshia/twitter_api_keys/${PLUGIN_HASH}/twitter_api_keys.rb"
KEYWORDS=""
- EGIT_SOURCEDIR="${WORKDIR}/all"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/all"
else
MY_P="${PN}.${PV}"
- SRC_URI="http://mikutter.hachune.net/bin/${MY_P}.tar.gz"
+ SRC_URI="http://mikutter.hachune.net/bin/${MY_P}.tar.gz
+ https://raw.githubusercontent.com/toshia/twitter_api_keys/${PLUGIN_HASH}/twitter_api_keys.rb"
KEYWORDS="~amd64"
RUBY_S="${PN}"
fi
@@ -31,41 +36,42 @@ RDEPEND="
libnotify? ( x11-libs/libnotify )
media-sound/alsa-utils"
-ruby_add_rdepend "dev-ruby/addressable
+ruby_add_rdepend "<dev-ruby/addressable-2.6
dev-ruby/delayer
- dev-ruby/delayer-deferred
+ >=dev-ruby/delayer-deferred-2.0
+ >=dev-ruby/diva-0.3.2
dev-ruby/httpclient
dev-ruby/json:0
dev-ruby/instance_storage
dev-ruby/memoist
- >=dev-ruby/moneta-0.7
+ dev-ruby/moneta
dev-ruby/nokogiri
- >=dev-ruby/oauth-0.4.7
- dev-ruby/pluggaloid
+ >=dev-ruby/oauth-0.5.1
+ >=dev-ruby/pluggaloid-1.1.1
dev-ruby/rcairo
- >=dev-ruby/ruby-gettext-3.0.1
- >=dev-ruby/ruby-gtk2-2.2.0
- dev-ruby/ruby-hmac
+ >=dev-ruby/ruby-gettext-3.2.9
+ >=dev-ruby/ruby-gtk2-3.3.0
+ >dev-ruby/ruby-hmac-0.4
dev-ruby/totoridipjp
- dev-ruby/twitter-text
- dev-ruby/typed-array
+ dev-ruby/twitter-text:=
+ >dev-ruby/typed-array-0.1
virtual/ruby-ssl"
all_ruby_unpack() {
if [ "${PV}" = "9999" ];then
- git-2_src_unpack
+ git-3_src_unpack
else
default
fi
}
-each_ruby_install() {
+all_ruby_install() {
local rubyversion
- if use ruby_targets_ruby23; then
- rubyversion=ruby23
- elif use ruby_targets_ruby22; then
- rubyversion=ruby22
+ if use ruby_targets_ruby25; then
+ rubyversion=ruby25
+ elif use ruby_targets_ruby24; then
+ rubyversion=ruby24
fi
exeinto /usr/share/mikutter
@@ -77,4 +83,39 @@ each_ruby_install() {
dodoc README
make_desktop_entry mikutter Mikutter \
/usr/share/mikutter/core/skin/data/icon.png
+
+ insinto /usr/share/mikutter/plugin/twitter_api_keys
+ newins "${DISTDIR}"/twitter_api_keys.rb twitter_api_keys.rb.in
+}
+
+pkg_postinst() {
+ echo
+ elog "To use Twitter, you need to setup your Consumer Key/Consumer Secret by running"
+ elog " emerge --config =${PF}"
+}
+
+pkg_config() {
+ local PLUGIN_DIR="${EROOT}"/usr/share/mikutter/plugin
+ local CK CS
+
+ echo
+ einfon "Please input your Consumer Key for Twitter: "
+ read -r CK
+
+ echo
+ einfon "Please input your Consumer Secret for Twitter: "
+ read -r CS
+
+ if [ -z "${CK}" -o -z "${CS}" ]; then
+ eerror "Consumer Key or Consumer Secret is missing."
+ return
+ fi
+
+ sed -e "/consumer_key = /s!''!'${CK}'!" \
+ -e "/consumer_secret = /s!''!'${CS}'!" \
+ ${PLUGIN_DIR}/twitter_api_keys/twitter_api_keys.rb.in > \
+ ${PLUGIN_DIR}/twitter_api_keys/twitter_api_keys.rb
+
+ echo
+ einfo "Consuker Key/Consumer secret is set."
}