summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-18 18:44:23 +0000
committerSam James <sam@gentoo.org>2022-07-18 18:44:23 +0000
commitd48fd2cd2c455abce55ff43c684136e3b0d8a1de (patch)
tree17c1395a351f2e8cdac565a2c9d9e4905476112e /net-libs
parentgames-strategy/augustus: update EAPI 7 -> 8 (diff)
downloadgentoo-d48fd2cd2c455abce55ff43c684136e3b0d8a1de.tar.gz
gentoo-d48fd2cd2c455abce55ff43c684136e3b0d8a1de.tar.bz2
gentoo-d48fd2cd2c455abce55ff43c684136e3b0d8a1de.zip
net-libs/libgssglue: add README; RDEPEND on virtual/krb5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libgssglue/libgssglue-0.5-r1.ebuild (renamed from net-libs/libgssglue/libgssglue-0.5.ebuild)24
1 files changed, 22 insertions, 2 deletions
diff --git a/net-libs/libgssglue/libgssglue-0.5.ebuild b/net-libs/libgssglue/libgssglue-0.5-r1.ebuild
index 83b13a4f094e..11a29340a820 100644
--- a/net-libs/libgssglue/libgssglue-0.5.ebuild
+++ b/net-libs/libgssglue/libgssglue-0.5-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools
+inherit autotools readme.gentoo-r1
DESCRIPTION="Exports a gssapi interface which calls other random gssapi libraries"
HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux https://gitlab.com/gsasl/libgssglue"
@@ -14,11 +14,25 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+RDEPEND="virtual/krb5"
+
PATCHES=(
"${FILESDIR}"/${PN}-0.3-protos.patch
"${FILESDIR}"/${PN}-0.4-implicit-declarations.patch
)
+DOC_CONTENTS="
+This package allows choosing a Kerberos or GSSAPI implementation
+at runtime.
+
+See
+https://blog.josefsson.org/2022/07/14/towards-pluggable-gss-api-modules/
+for more details.
+
+A system-wide implementation can be chosen by editing ${EROOT}/etc/gssapi_mech.conf,
+or it can be set per-process via the GSSAPI_MECH_CONF environment variable.
+"
+
src_prepare() {
default
@@ -31,8 +45,14 @@ src_prepare() {
src_install() {
default
- find "${ED}" -name '*.la' -delete || die
+ readme.gentoo_create_doc
insinto /etc
doins doc/gssapi_mech.conf
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
}