summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-10 20:58:36 +0100
committerSam James <sam@gentoo.org>2022-07-10 20:59:04 +0100
commit7d720afe07de3ae029931c2a7c4bc1b4588e8d48 (patch)
tree3fb7f4a008bfaebbe39e33a6c40d3ab5c75c032f /net-libs
parentdev-java/tomcat-servlet-api: drop 10.0.21 (diff)
downloadgentoo-7d720afe07de3ae029931c2a7c4bc1b4588e8d48.tar.gz
gentoo-7d720afe07de3ae029931c2a7c4bc1b4588e8d48.tar.bz2
gentoo-7d720afe07de3ae029931c2a7c4bc1b4588e8d48.zip
net-libs/gtk-vnc: fix build w/ meson 0.63
Closes: https://bugs.gentoo.org/846467 Thanks-to: Alexandre Ferreira <alexandref75@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gtk-vnc/Manifest1
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-1.3.0-r1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-libs/gtk-vnc/Manifest b/net-libs/gtk-vnc/Manifest
index 33c4db829efa..5eb0dc70e300 100644
--- a/net-libs/gtk-vnc/Manifest
+++ b/net-libs/gtk-vnc/Manifest
@@ -1 +1,2 @@
+DIST gtk-vnc-1.3.0-meson-0.63.patch.xz 5328 BLAKE2B d671622ad02bb253c6648515005db12306f9a093d8c26db12faa6a549397b0d18a696cdca5cf4eaead9d70fb827dc8f1715ba95051e11bc604f3af41821c6c19 SHA512 4ed806de86ac8c6773621d276f35e592f1f3e03c4f610d1386426833f345f1aac113dc31e24e86f93a4122d2fb49d00daa7f3df6883944c567daa4cda62c9249
DIST gtk-vnc-1.3.0.tar.xz 220488 BLAKE2B ea5070cc396fe4ef52fe980b766658f1a4f82eb7dec52856ab79836363c8fdb48827d52c0df7edb2c943f5087fcfd87898aa43457f7cbf5a544a4c7063f84f3d SHA512 ff25c19a1cbd4588990f1f3a2448fd2e0b694b933ca1a7be9565188db78055efe13f90ad1243bf8237d6a29d38987d7b3e77344e50d09191207b09200b01f5df
diff --git a/net-libs/gtk-vnc/gtk-vnc-1.3.0-r1.ebuild b/net-libs/gtk-vnc/gtk-vnc-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..25489f20be46
--- /dev/null
+++ b/net-libs/gtk-vnc/gtk-vnc-1.3.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org vala meson python-any-r1 xdg
+
+DESCRIPTION="VNC viewer widget for GTK"
+HOMEPAGE="https://wiki.gnome.org/Projects/gtk-vnc"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-meson-0.63.patch.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection pulseaudio sasl +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gdk-pixbuf-2.36.0:2
+ >=dev-libs/libgcrypt-1.8.0:0=
+ >=net-libs/gnutls-3.6.0:0=
+ >=sys-libs/zlib-1.2.11
+ sasl? ( >=dev-libs/cyrus-sasl-2.1.27 )
+ >=x11-libs/gtk+-3.22.0:3[introspection?]
+ >=x11-libs/cairo-1.15.0
+ >=x11-libs/libX11-1.6.5
+ pulseaudio? ( >=media-sound/pulseaudio-11.0 )
+ introspection? ( >=dev-libs/gobject-introspection-1.56.0:= )
+"
+# Keymap databases code is generated with python3; configure picks up $PYTHON exported from python-any-r1_pkg_setup
+# perl for pod2man
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/perl-5
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${WORKDIR}"/${P}-meson-0.63.patch
+)
+
+src_prepare() {
+ default
+
+ use vala & vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature introspection)
+ $(meson_feature pulseaudio)
+ $(meson_feature sasl)
+ -Dwith-coroutine=auto # gthread on windows, libc ucontext elsewhere; neither has extra deps
+ $(meson_feature vala with-vala)
+ )
+ meson_src_configure
+}