summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/gupnp-av
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/gupnp-av')
-rw-r--r--net-libs/gupnp-av/Manifest2
-rw-r--r--net-libs/gupnp-av/gupnp-av-0.12.6.ebuild44
-rw-r--r--net-libs/gupnp-av/gupnp-av-0.12.7.ebuild44
-rw-r--r--net-libs/gupnp-av/metadata.xml5
4 files changed, 95 insertions, 0 deletions
diff --git a/net-libs/gupnp-av/Manifest b/net-libs/gupnp-av/Manifest
new file mode 100644
index 000000000000..f047682b21da
--- /dev/null
+++ b/net-libs/gupnp-av/Manifest
@@ -0,0 +1,2 @@
+DIST gupnp-av-0.12.6.tar.xz 348264 SHA256 e0553d60dd7c7277c65c02a68a270c4dcb9036a4c7075c902fc8111c6a5e6a44 SHA512 0eee23c8b30eae445cb9732d030d89dd6538f2683ed57482ceebc611b8a0524b60760bc76a1b26a9d2d8845dfa836183c636a798c165102f0ecdcd3ba7d9121e WHIRLPOOL c401829e74395697a6ed1e5d9e183794f3875d718517ee3ccd50f83bd30e4f69190cc7396b87f48a3add8c2384164c3141d3cead6b1eeb695c185d0b41a29f2d
+DIST gupnp-av-0.12.7.tar.xz 349292 SHA256 35e775bc4f7801d65dcb710905a6b8420ce751a239b5651e6d830615dc906ea8 SHA512 21af09a74409c696124b7d92746ba72a46f804df65ca968034cbfe10f0c73b18446b7cceceb8e62e4d1689f699ef9a785c465cb8caf9294ec8e9bc38e86d16c2 WHIRLPOOL 4c102cb8ebab50e377159b12e0d633718fa60365f2099a8e7c0680367c41e3d7dbace96abb4790600ad2d5d1c67123883ad50e2dd978f9a0e3be16b08af56f60
diff --git a/net-libs/gupnp-av/gupnp-av-0.12.6.ebuild b/net-libs/gupnp-av/gupnp-av-0.12.6.ebuild
new file mode 100644
index 000000000000..fd60afe33890
--- /dev/null
+++ b/net-libs/gupnp-av/gupnp-av-0.12.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.22" #532568
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 vala
+
+DESCRIPTION="Utility library aiming to ease the handling UPnP A/V profiles"
+HOMEPAGE="http://gupnp.org/"
+
+LICENSE="LGPL-2"
+SLOT="0/2" # subslot: soname version
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.16:2
+ >=net-libs/gssdp-0.9.2[introspection?]
+ >=net-libs/libsoup-2.28.2:2.4[introspection?]
+ dev-libs/libxml2
+ >=net-libs/gupnp-0.19[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ !net-libs/gupnp-vala
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ virtual/pkgconfig
+ introspection? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-static
+}
diff --git a/net-libs/gupnp-av/gupnp-av-0.12.7.ebuild b/net-libs/gupnp-av/gupnp-av-0.12.7.ebuild
new file mode 100644
index 000000000000..c9e36a65ea61
--- /dev/null
+++ b/net-libs/gupnp-av/gupnp-av-0.12.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.22"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 vala
+
+DESCRIPTION="Utility library aiming to ease the handling UPnP A/V profiles"
+HOMEPAGE="http://gupnp.org/"
+
+LICENSE="LGPL-2"
+SLOT="0/2" # subslot: soname version
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.16:2
+ >=net-libs/gssdp-0.9.2[introspection?]
+ >=net-libs/libsoup-2.28.2:2.4[introspection?]
+ dev-libs/libxml2
+ >=net-libs/gupnp-0.19[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ !net-libs/gupnp-vala
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ virtual/pkgconfig
+ introspection? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-static
+}
diff --git a/net-libs/gupnp-av/metadata.xml b/net-libs/gupnp-av/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/net-libs/gupnp-av/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>