summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/ptlink-opm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/ptlink-opm')
-rw-r--r--net-irc/ptlink-opm/Manifest1
-rw-r--r--net-irc/ptlink-opm/files/ptlink-opm.conf.d6
-rw-r--r--net-irc/ptlink-opm/files/ptlink-opm.init.d22
-rw-r--r--net-irc/ptlink-opm/metadata.xml5
-rw-r--r--net-irc/ptlink-opm/ptlink-opm-1.3.1.ebuild49
5 files changed, 83 insertions, 0 deletions
diff --git a/net-irc/ptlink-opm/Manifest b/net-irc/ptlink-opm/Manifest
new file mode 100644
index 000000000000..7386fdaae252
--- /dev/null
+++ b/net-irc/ptlink-opm/Manifest
@@ -0,0 +1 @@
+DIST PTlink.OPM1.3.1.tar.gz 156068 SHA256 0392e9e2a121fd3ae529c49306cfc7450236c6881ff38134f86883c16a26802a SHA512 1a8955486db8c1a318dda1b7bfdaf1be9f55d68a5acafde37a5f15e80e21b8d45c51138efb9d5ca1d1fad9f46d0ccdc4b91cf9128ba2ca7086f1c0925a36a141 WHIRLPOOL 6d814f14a612717f0d3e74e8f050b3b27e20a0adf62ba93a5b9cfd314212ece0e9f3a9567814f967f7eed66816020ec1318529a5f6904914803c49fccf4a331e
diff --git a/net-irc/ptlink-opm/files/ptlink-opm.conf.d b/net-irc/ptlink-opm/files/ptlink-opm.conf.d
new file mode 100644
index 000000000000..620320d7ac96
--- /dev/null
+++ b/net-irc/ptlink-opm/files/ptlink-opm.conf.d
@@ -0,0 +1,6 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# User to run ptlink-opm as
+PTLINKOPM_USER="ptlink-opm"
diff --git a/net-irc/ptlink-opm/files/ptlink-opm.init.d b/net-irc/ptlink-opm/files/ptlink-opm.init.d
new file mode 100644
index 000000000000..0994939065f0
--- /dev/null
+++ b/net-irc/ptlink-opm/files/ptlink-opm.init.d
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+ use dns ircd
+}
+
+start() {
+ ebegin "Starting ptlink-opm"
+ start-stop-daemon --start --quiet --exec /usr/bin/ptlink-opm \
+ --chuid ${PTLINKOPM_USER} >/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Shutting down ptlink-opm"
+ start-stop-daemon --stop --exec /usr/bin/ptlink-opm
+ eend $?
+}
diff --git a/net-irc/ptlink-opm/metadata.xml b/net-irc/ptlink-opm/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/ptlink-opm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>
diff --git a/net-irc/ptlink-opm/ptlink-opm-1.3.1.ebuild b/net-irc/ptlink-opm/ptlink-opm-1.3.1.ebuild
new file mode 100644
index 000000000000..f5f64ee5069b
--- /dev/null
+++ b/net-irc/ptlink-opm/ptlink-opm-1.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils user
+
+MY_P="PTlink.OPM${PV}"
+
+DESCRIPTION="PTlink Open Proxy Monitor"
+HOMEPAGE="http://www.ptlink.net/"
+SRC_URI="ftp://ftp.sunsite.dk/projects/ptlink/ptopm/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND=""
+DEPEND=">=sys-apps/sed-4"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/ptlink-opm \
+ --localstatedir=/var/lib/ptlink-opm \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ newbin src/ptopm ptlink-opm || die "newbin failed"
+
+ insinto /etc/ptlink-opm
+ newins samples/ptopm.dconf.sample ptopm.dconf || die "newins failed"
+ doins samples/scan_rules.dconf || die "doins failed"
+
+ keepdir /var/{lib,log}/ptlink-opm || die "keepdir failed"
+ dosym /var/log/ptlink-opm /var/lib/ptlink-opm/log || die "dosym failed"
+
+ dodoc CHANGES README || die "dodoc failed"
+
+ newinitd ${FILESDIR}/ptlink-opm.init.d ptlink-opm || die "newinitd failed"
+ newconfd ${FILESDIR}/ptlink-opm.conf.d ptlink-opm || die "newconfd failed"
+}
+
+pkg_postinst() {
+ enewuser ptlink-opm
+ chown ptlink-opm ${ROOT}/var/{log,lib}/ptlink-opm
+}