summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-30 21:40:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-30 22:00:14 +0200
commit31bf5adcf643bf78f7e1db259b2ca6efd57505c4 (patch)
treeb7e898f66edeed245da8b96d18f56caf7069c161 /net-dns
parentmedia-video/pipewire: tweak audio group message further (diff)
downloadgentoo-31bf5adcf643bf78f7e1db259b2ca6efd57505c4.tar.gz
gentoo-31bf5adcf643bf78f7e1db259b2ca6efd57505c4.tar.bz2
gentoo-31bf5adcf643bf78f7e1db259b2ca6efd57505c4.zip
net-dns/dnsviz: PEP517, py3.11
Closes: https://bugs.gentoo.org/897084 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnsviz/Manifest1
-rw-r--r--net-dns/dnsviz/dnsviz-0.9.4-r1.ebuild61
-rw-r--r--net-dns/dnsviz/metadata.xml1
3 files changed, 63 insertions, 0 deletions
diff --git a/net-dns/dnsviz/Manifest b/net-dns/dnsviz/Manifest
index ed5d40952fa9..be89f25e6332 100644
--- a/net-dns/dnsviz/Manifest
+++ b/net-dns/dnsviz/Manifest
@@ -1 +1,2 @@
+DIST dnsviz-0.9.4.gh.tar.gz 477971 BLAKE2B 3c8bebcea89bc6e78247c45c4266f73be4f9f618bfaa48a47460a43deb4789fe71eaa77eb4ff59c2d8e863cdfdddaf5908279aad93ffd63fdbe16d0966aa943b SHA512 b88d0ddff6279078a5222b4250a404c39db6d896d57bba51c878c8b8d01582deda2fe67b5f6370d7a98389e09ad46bdf3903d77fee91c0291b14a9109f1739e3
DIST dnsviz-0.9.4.tar.gz 477971 BLAKE2B 3c8bebcea89bc6e78247c45c4266f73be4f9f618bfaa48a47460a43deb4789fe71eaa77eb4ff59c2d8e863cdfdddaf5908279aad93ffd63fdbe16d0966aa943b SHA512 b88d0ddff6279078a5222b4250a404c39db6d896d57bba51c878c8b8d01582deda2fe67b5f6370d7a98389e09ad46bdf3903d77fee91c0291b14a9109f1739e3
diff --git a/net-dns/dnsviz/dnsviz-0.9.4-r1.ebuild b/net-dns/dnsviz/dnsviz-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..9b1dd27567af
--- /dev/null
+++ b/net-dns/dnsviz/dnsviz-0.9.4-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Tool suite for analysis and visualization of DNS and DNSSEC"
+HOMEPAGE="
+ https://dnsviz.net/
+ https://github.com/dnsviz/dnsviz/
+ https://pypi.org/project/dnsviz/
+"
+SRC_URI="
+ https://github.com/dnsviz/dnsviz/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/dnspython-1.13[${PYTHON_USEDEP}]
+ >=dev-python/m2crypto-0.37.0[${PYTHON_USEDEP}]
+ >=dev-python/pygraphviz-1.3.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ media-gfx/graphviz
+ test? (
+ ${RDEPEND}
+ net-dns/bind
+ )
+"
+
+python_prepare_all() {
+ # Fix the ebuild to use correct FHS/Gentoo policy paths
+ sed -i \
+ -e "s|share/doc/dnsviz|share/doc/${PF}|g" \
+ "${S}"/setup.py \
+ || die
+
+ # skip online tests
+ rm tests/*_online.py tests/dnsviz_probe_options.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ eunittest -s tests -p "*.py" || die
+}
+
+pkg_postinst() {
+ optfeature "Support for pre-deployment testing" net-dns/bind
+ optfeature "Support for DNSSEC signatures using GOST algorithm or digest" dev-libs/ghost-engine
+}
diff --git a/net-dns/dnsviz/metadata.xml b/net-dns/dnsviz/metadata.xml
index 4d5fa79a603b..7c2d577552be 100644
--- a/net-dns/dnsviz/metadata.xml
+++ b/net-dns/dnsviz/metadata.xml
@@ -9,5 +9,6 @@
</longdescription>
<upstream>
<remote-id type="github">dnsviz/dnsviz</remote-id>
+ <remote-id type="pypi">dnsviz</remote-id>
</upstream>
</pkgmetadata>