summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-15 22:46:35 +0100
committerSam James <sam@gentoo.org>2022-06-15 22:46:35 +0100
commita0a54438749c44e03fb7c3cb02957bcef3127dfd (patch)
tree576714aecbc184277974062e2b7df4b68f18e096 /net-analyzer
parentnet-libs/gloox: fix build with GCC 12; fix bashism (diff)
downloadgentoo-a0a54438749c44e03fb7c3cb02957bcef3127dfd.tar.gz
gentoo-a0a54438749c44e03fb7c3cb02957bcef3127dfd.tar.bz2
gentoo-a0a54438749c44e03fb7c3cb02957bcef3127dfd.zip
net-analyzer/xprobe: fix build with GCC 12
Closes: https://bugs.gentoo.org/852119 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/xprobe/files/xprobe-0.3-gcc-12.patch21
-rw-r--r--net-analyzer/xprobe/xprobe-0.3-r1.ebuild9
2 files changed, 28 insertions, 2 deletions
diff --git a/net-analyzer/xprobe/files/xprobe-0.3-gcc-12.patch b/net-analyzer/xprobe/files/xprobe-0.3-gcc-12.patch
new file mode 100644
index 000000000000..534d17cb019b
--- /dev/null
+++ b/net-analyzer/xprobe/files/xprobe-0.3-gcc-12.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/852119
+--- a/libs-external/USI++/src/datalink.cc
++++ b/libs-external/USI++/src/datalink.cc
+@@ -15,6 +15,7 @@
+ #include <string.h>
+ #include <unistd.h>
+ #include <errno.h>
++#include <ctime>
+ #include <sys/ioctl.h>
+
+ #ifdef IMMEDIATE
+--- a/libs-external/USI++/src/tcp.cc
++++ b/libs-external/USI++/src/tcp.cc
+@@ -16,6 +16,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <errno.h>
++#include <ctime>
+
+ namespace usipp {
+
diff --git a/net-analyzer/xprobe/xprobe-0.3-r1.ebuild b/net-analyzer/xprobe/xprobe-0.3-r1.ebuild
index db0208e8db4a..d630b7fd1214 100644
--- a/net-analyzer/xprobe/xprobe-0.3-r1.ebuild
+++ b/net-analyzer/xprobe/xprobe-0.3-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
MY_P=${PN}2-${PV}
@@ -9,6 +10,7 @@ MY_P=${PN}2-${PV}
DESCRIPTION="Active OS fingerprinting tool - this is Xprobe2"
HOMEPAGE="http://sys-security.com/blog/xprobe2"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="GPL-2"
SLOT="0"
@@ -16,14 +18,16 @@ KEYWORDS="~amd64 ~ppc ~sparc x86"
DEPEND="net-libs/libpcap"
RDEPEND="${DEPEND}"
+
PATCHES=(
"${FILESDIR}"/${P}-gcc43.patch
"${FILESDIR}"/${P}-cxx11.patch
+ "${FILESDIR}"/${P}-gcc-12.patch
)
-S=${WORKDIR}/${MY_P}
src_prepare() {
default
+
sed -i -e 's:strip:true:' src/Makefile.in || die
sed -i -e 's:ar cr:$(AR) cr:g' $(find -name '*Makefile*') || die
@@ -32,5 +36,6 @@ src_prepare() {
src_install() {
default
+
dodoc AUTHORS CHANGELOG CREDITS README TODO docs/*.{txt,pdf}
}