summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 01:57:44 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:55:16 +0100
commitc825a52204681acacf4e66c6f91e15fb173aae67 (patch)
treeb0da5d3f42132fb8362dea641d824cf5ca2e3c87 /net-analyzer/symon
parentnet-analyzer/ssmping: EAPI 7, eutils-- (diff)
downloadgentoo-c825a52204681acacf4e66c6f91e15fb173aae67.tar.gz
gentoo-c825a52204681acacf4e66c6f91e15fb173aae67.tar.bz2
gentoo-c825a52204681acacf4e66c6f91e15fb173aae67.zip
net-analyzer/symon: port to EAPI 7, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/symon')
-rw-r--r--net-analyzer/symon/symon-2.88.ebuild21
1 files changed, 8 insertions, 13 deletions
diff --git a/net-analyzer/symon/symon-2.88.ebuild b/net-analyzer/symon/symon-2.88.ebuild
index 0250b6eec39b..521fcb00eb67 100644
--- a/net-analyzer/symon/symon-2.88.ebuild
+++ b/net-analyzer/symon/symon-2.88.ebuild
@@ -1,31 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils perl-module toolchain-funcs
+EAPI=7
+
+inherit perl-module toolchain-funcs
DESCRIPTION="Performance and information monitoring tool"
HOMEPAGE="https://wpd.home.xs4all.nl/symon/"
SRC_URI="https://wpd.home.xs4all.nl/symon/philes/${P}.tar.gz"
+S="${WORKDIR}"/${PN}
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
IUSE="perl +symon symux"
-REQUIRED_USE="
- || ( perl symon symux )
-"
+REQUIRED_USE="|| ( perl symon symux )"
+BDEPEND="sys-devel/pmake"
RDEPEND="
perl? ( dev-lang/perl )
symux? ( net-analyzer/rrdtool )
"
-DEPEND="
- ${RDEPEND}
- sys-devel/pmake
-"
-
-S=${WORKDIR}/${PN}
+DEPEND="${RDEPEND}"
# Deletes the directory passed as an argument from the internal pmake
# variable SUBDIR.
@@ -84,7 +80,6 @@ src_install() {
doman symux/symux.8
dosbin symux/symux
- dodir /usr/share/symon
insinto /usr/share/symon
doins symux/c_smrrds.sh
fperms a+x /usr/share/symon/c_smrrds.sh