summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-09-04 08:57:14 +0200
committerJeroen Roovers <jer@gentoo.org>2019-09-04 08:58:19 +0200
commit379648951fb191bd5a4ac67631bc1b5befb4b806 (patch)
tree1d07d7074722250e7b10ceb51303ecc1a64134b1 /net-analyzer/ndsad
parentx11-misc/xvkbd: Old (diff)
downloadgentoo-379648951fb191bd5a4ac67631bc1b5befb4b806.tar.gz
gentoo-379648951fb191bd5a4ac67631bc1b5befb4b806.tar.bz2
gentoo-379648951fb191bd5a4ac67631bc1b5befb4b806.zip
net-analyzer/ndsad: Drop ULOG support
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/ndsad')
-rw-r--r--net-analyzer/ndsad/ndsad-1.33-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/ndsad/ndsad-1.33-r2.ebuild b/net-analyzer/ndsad/ndsad-1.33-r2.ebuild
new file mode 100644
index 000000000000..e7f9a919a4a4
--- /dev/null
+++ b/net-analyzer/ndsad/ndsad-1.33-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Cisco netflow probe from libpcap, ULOG, tee/divert sources"
+HOMEPAGE="https://sourceforge.net/projects/ndsad"
+SRC_URI="mirror://sourceforge/ndsad/ndsad-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="
+ >=net-libs/libpcap-0.8
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-conf_path.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-getpid.patch
+ "${FILESDIR}"/${P}-log-path.patch
+ "${FILESDIR}"/${P}-strncpy-overflow.patch
+)
+DOCS=( ChangeLog AUTHORS README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ doman ndsad.conf.5
+
+ insinto /etc
+ newins ndsad.conf ndsad.conf
+
+ newinitd "${FILESDIR}"/ndsad.init ndsad
+ newconfd "${FILESDIR}"/ndsad.conf.d ndsad
+}