summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-02-26 14:04:32 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-02-28 23:49:29 +0100
commit05769316cf7ab2a981b283c5263ea815cfe6821f (patch)
tree611b8d3b7df84848f59c5891fe00f523c7718ba6 /media-video
parentx11-wm/mutter: require gles2 for wayland, try to fix non-gles2 builds (diff)
downloadgentoo-05769316cf7ab2a981b283c5263ea815cfe6821f.tar.gz
gentoo-05769316cf7ab2a981b283c5263ea815cfe6821f.tar.bz2
gentoo-05769316cf7ab2a981b283c5263ea815cfe6821f.zip
media-video/obs-studio: bump to EAPI="7".
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/11160 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/obs-studio/obs-studio-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/media-video/obs-studio/obs-studio-9999.ebuild b/media-video/obs-studio/obs-studio-9999.ebuild
index 9cd8bdd75172..abb6a6df16e0 100644
--- a/media-video/obs-studio/obs-studio-9999.ebuild
+++ b/media-video/obs-studio/obs-studio-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python{3_4,3_5,3_6,3_7} )
@@ -24,7 +24,11 @@ SLOT="0"
IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speex truetype v4l"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-COMMON_DEPEND="
+BDEPEND="
+ luajit? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+"
+DEPEND="
>=dev-libs/jansson-2.5
dev-qt/qtcore:5
dev-qt/qtdeclarative:5
@@ -61,11 +65,7 @@ COMMON_DEPEND="
)
v4l? ( media-libs/libv4l )
"
-DEPEND="${COMMON_DEPEND}
- luajit? ( dev-lang/swig )
- python? ( dev-lang/swig )
-"
-RDEPEND="${COMMON_DEPEND}"
+RDEPEND="${DEPEND}"
CMAKE_REMOVE_MODULES_LIST=( FindFreetype )