summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/volumeicon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/volumeicon')
-rw-r--r--media-sound/volumeicon/Manifest2
-rw-r--r--media-sound/volumeicon/files/volumeicon-0.4.6-glib-2.31.patch30
-rw-r--r--media-sound/volumeicon/metadata.xml5
-rw-r--r--media-sound/volumeicon/volumeicon-0.4.6.ebuild34
-rw-r--r--media-sound/volumeicon/volumeicon-0.5.0.ebuild29
5 files changed, 100 insertions, 0 deletions
diff --git a/media-sound/volumeicon/Manifest b/media-sound/volumeicon/Manifest
new file mode 100644
index 000000000000..645acb5dc1ef
--- /dev/null
+++ b/media-sound/volumeicon/Manifest
@@ -0,0 +1,2 @@
+DIST volumeicon-0.4.6.tar.gz 136769 SHA256 32f94adc5f346404ae564405dd483ae4bd04212df08e46f18d369b4ba2cb6590
+DIST volumeicon-0.5.0.tar.gz 160089 SHA256 e5f1179f9ec5ab25e3740e4f6bbe0baa75368f0ae87d370197b3fbefb61bd782 SHA512 26c4973a600495886222920e6eea80a7d54ebecf9b9fa46dea6808e25bf3b5edc5b37ff0740da270e77faac687d2151d8cc53259b356e17ce99ed0e38b7fbe38 WHIRLPOOL 1f319c1a671be3677f02272683a36b4714d728d5022f1e640c2b0d130d80dc1958c07a8a5d28637ba47d7ac91d021676774cba90bae050d726c6d05132b980cc
diff --git a/media-sound/volumeicon/files/volumeicon-0.4.6-glib-2.31.patch b/media-sound/volumeicon/files/volumeicon-0.4.6-glib-2.31.patch
new file mode 100644
index 000000000000..6eeda5135f34
--- /dev/null
+++ b/media-sound/volumeicon/files/volumeicon-0.4.6-glib-2.31.patch
@@ -0,0 +1,30 @@
+http://bugs.gentoo.org/412473
+
+--- src/alsa_backend.c
++++ src/alsa_backend.c
+@@ -22,10 +22,8 @@
+ //##############################################################################
+
+ #include <alsa/asoundlib.h>
+-#include <glib/gstring.h>
++#include <glib.h>
+ #include <glib/gstdio.h>
+-#include <glib/glist.h>
+-#include <glib/giochannel.h>
+
+ #include "alsa_backend.h"
+
+--- src/oss_backend.c
++++ src/oss_backend.c
+@@ -26,10 +26,8 @@
+ #include <fcntl.h>
+ #include <assert.h>
+ #include <stdlib.h>
+-#include <glib/gstring.h>
++#include <glib.h>
+ #include <glib/gstdio.h>
+-#include <glib/glist.h>
+-#include <glib/giochannel.h>
+
+ #include "oss_backend.h"
+
diff --git a/media-sound/volumeicon/metadata.xml b/media-sound/volumeicon/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/volumeicon/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/volumeicon/volumeicon-0.4.6.ebuild b/media-sound/volumeicon/volumeicon-0.4.6.ebuild
new file mode 100644
index 000000000000..8796a700a201
--- /dev/null
+++ b/media-sound/volumeicon/volumeicon-0.4.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A lightweight volume control that sits in your systray"
+HOMEPAGE="http://softwarebakery.com/maato/volumeicon.html"
+SRC_URI="http://softwarebakery.com/maato/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="libnotify"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/alsa-lib
+ >=x11-libs/gtk+-2.16:2
+ x11-libs/libX11
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glib-2.31.patch
+}
+
+src_configure() {
+ # --enable-oss --with-oss-include-path=/usr/include/sys #419891
+ econf $(use_enable libnotify notify)
+}
diff --git a/media-sound/volumeicon/volumeicon-0.5.0.ebuild b/media-sound/volumeicon/volumeicon-0.5.0.ebuild
new file mode 100644
index 000000000000..b6015935f675
--- /dev/null
+++ b/media-sound/volumeicon/volumeicon-0.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A lightweight volume control that sits in your systray"
+HOMEPAGE="http://softwarebakery.com/maato/volumeicon.html"
+SRC_URI="http://softwarebakery.com/maato/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/alsa-lib
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog"
+
+src_configure() {
+ # $(use_enable !alsa oss) fails wrt #419891, is likely only for OSS4
+ econf $(use_enable libnotify notify)
+}