summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/pianobar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/pianobar')
-rw-r--r--media-sound/pianobar/Manifest1
-rw-r--r--media-sound/pianobar/metadata.xml8
-rw-r--r--media-sound/pianobar/pianobar-2014.09.28.ebuild52
-rw-r--r--media-sound/pianobar/pianobar-9999.ebuild52
4 files changed, 113 insertions, 0 deletions
diff --git a/media-sound/pianobar/Manifest b/media-sound/pianobar/Manifest
new file mode 100644
index 000000000000..d293cf19fe94
--- /dev/null
+++ b/media-sound/pianobar/Manifest
@@ -0,0 +1 @@
+DIST pianobar-2014.09.28.tar.bz2 51810 SHA256 6bd10218ad5d68c4c761e02c729627d2581b4a6db559190e7e52dc5df177e68f SHA512 3a9a508eaa4f1060ab456c4e28cd5447ed0a2e6a15b7694bf711ffa363d86c27483b1956da7f90919c9111c48752a99b9f704e721924903c017355dd577bc905 WHIRLPOOL 35db2f53b194d61c8601f27a787319036e5a59d86734ffd6ee00762fb66b2265c0f5b99aeea7ebffc9ebf5f8aa1430acc136e3486e6fa8cd2b355c439e96b68b
diff --git a/media-sound/pianobar/metadata.xml b/media-sound/pianobar/metadata.xml
new file mode 100644
index 000000000000..157326a7e891
--- /dev/null
+++ b/media-sound/pianobar/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-sound/pianobar/pianobar-2014.09.28.ebuild b/media-sound/pianobar/pianobar-2014.09.28.ebuild
new file mode 100644
index 000000000000..2f81e0e51c0f
--- /dev/null
+++ b/media-sound/pianobar/pianobar-2014.09.28.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit toolchain-funcs flag-o-matic multilib
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/PromyLOPh/pianobar.git"
+else
+ SRC_URI="http://6xq.net/projects/${PN}/${P}.tar.bz2"
+ KEYWORDS="amd64 x86"
+fi
+
+DESCRIPTION="A console-based replacement for Pandora's flash player"
+HOMEPAGE="http://6xq.net/projects/pianobar/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND="media-libs/libao
+ net-libs/gnutls
+ dev-libs/libgcrypt:0=
+ dev-libs/json-c
+ >=virtual/ffmpeg-9"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -e '/@echo /d' \
+ -e 's/@${CC}/${CC}/' \
+ -i Makefile || die
+}
+
+src_compile() {
+ append-cflags -std=c99
+ tc-export CC
+ emake DYNLINK=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr LIBDIR=/usr/$(get_libdir) DYNLINK=1 install
+ dodoc ChangeLog README
+
+ use static-libs || { rm "${D}"/usr/lib*/*.a || die; }
+
+ docinto contrib
+ dodoc -r contrib/{config-example,*.sh,eventcmd-examples}
+ docompress -x /usr/share/doc/${PF}/contrib
+}
diff --git a/media-sound/pianobar/pianobar-9999.ebuild b/media-sound/pianobar/pianobar-9999.ebuild
new file mode 100644
index 000000000000..d8bd6bf72694
--- /dev/null
+++ b/media-sound/pianobar/pianobar-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit toolchain-funcs flag-o-matic multilib
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/PromyLOPh/pianobar.git"
+else
+ SRC_URI="http://6xq.net/projects/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A console-based replacement for Pandora's flash player"
+HOMEPAGE="http://6xq.net/projects/pianobar/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="static-libs"
+
+RDEPEND="media-libs/libao
+ net-libs/gnutls
+ dev-libs/libgcrypt:0=
+ dev-libs/json-c
+ >=virtual/ffmpeg-9"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -e '/@echo /d' \
+ -e 's/@${CC}/${CC}/' \
+ -i Makefile || die
+}
+
+src_compile() {
+ append-cflags -std=c99
+ tc-export CC
+ emake DYNLINK=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr LIBDIR=/usr/$(get_libdir) DYNLINK=1 install
+ dodoc ChangeLog README
+
+ use static-libs || { rm "${D}"/usr/lib*/*.a || die; }
+
+ docinto contrib
+ dodoc -r contrib/{config-example,*.sh,eventcmd-examples}
+ docompress -x /usr/share/doc/${PF}/contrib
+}