summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-29 06:56:48 +0000
committerSam James <sam@gentoo.org>2021-12-29 07:10:40 +0000
commitf87161dba82594dc47e57805d5b11dfb79b32b9d (patch)
tree69d64736eae68142b7a6fadbfeafe30580a650d9 /media-sound/daudio
parentnet-misc/pcapfix: fully respect CFLAGS (diff)
downloadgentoo-f87161dba82594dc47e57805d5b11dfb79b32b9d.tar.gz
gentoo-f87161dba82594dc47e57805d5b11dfb79b32b9d.tar.bz2
gentoo-f87161dba82594dc47e57805d5b11dfb79b32b9d.zip
media-sound/daudio: update EAPI 6 -> 7, fix musl build
Closes: https://bugs.gentoo.org/715246 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/daudio')
-rw-r--r--media-sound/daudio/daudio-0.3-r1.ebuild6
-rw-r--r--media-sound/daudio/files/daudio-0.3-musl-stdint.patch82
2 files changed, 85 insertions, 3 deletions
diff --git a/media-sound/daudio/daudio-0.3-r1.ebuild b/media-sound/daudio/daudio-0.3-r1.ebuild
index 88cd0bcb1e04..0f7ca5bea943 100644
--- a/media-sound/daudio/daudio-0.3-r1.ebuild
+++ b/media-sound/daudio/daudio-0.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic toolchain-funcs
@@ -11,16 +11,16 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-#-sparc: 0.3: static audio on local daemon. No audio when client connects to amd64 daemon
+# -sparc: 0.3: static audio on local daemon. No audio when client connects to amd64 daemon
KEYWORDS="amd64 ~ppc -sparc x86"
-IUSE=""
DEPEND=">=media-libs/libmad-0.15.0b-r1"
RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-makefile.patch"
"${FILESDIR}/${P}-qa-implicit-declarations.patch"
+ "${FILESDIR}/${P}-musl-stdint.patch"
)
src_prepare() {
diff --git a/media-sound/daudio/files/daudio-0.3-musl-stdint.patch b/media-sound/daudio/files/daudio-0.3-musl-stdint.patch
new file mode 100644
index 000000000000..ff70b900d1f8
--- /dev/null
+++ b/media-sound/daudio/files/daudio-0.3-musl-stdint.patch
@@ -0,0 +1,82 @@
+https://bugs.gentoo.org/715246
+--- a/client/net.c
++++ b/client/net.c
+@@ -20,6 +20,7 @@
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <stdio.h>
++#include <stdint.h>
+ #include <errno.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+@@ -69,7 +70,7 @@ int netinit(char *hostname, int port) {
+ }
+ net_raddr.sin_family = AF_INET;
+ net_raddr.sin_port = htons(port);
+- net_raddr.sin_addr.s_addr = *((u_int32_t *) host->h_addr);
++ net_raddr.sin_addr.s_addr = *((uint32_t *) host->h_addr);
+ return(s);
+ }
+
+--- a/server/bcast.c
++++ b/server/bcast.c
+@@ -21,6 +21,7 @@
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <stdio.h>
++#include <stdint.h>
+
+ #include "../common/port.h"
+ #include "timer.h"
+@@ -75,11 +76,11 @@ int b_init(void) {
+
+ addr.sin_family = AF_INET;
+ addr.sin_port = htons(BROADCASTPORT_D);
+- addr.sin_addr.s_addr = (u_int32_t) INADDR_ANY;
++ addr.sin_addr.s_addr = (uint32_t) INADDR_ANY;
+
+ baddr.sin_family = AF_INET;
+ baddr.sin_port = htons(BROADCASTPORT_C);
+- baddr.sin_addr.s_addr = (u_int32_t) INADDR_BROADCAST;
++ baddr.sin_addr.s_addr = (uint32_t) INADDR_BROADCAST;
+
+ if(bind(b_sock, (struct sockaddr *) &addr, sizeof(struct sockaddr_in)) == -1)
+ return(-1);
+--- a/server/local.c
++++ b/server/local.c
+@@ -21,6 +21,7 @@
+ #include <unistd.h>
+ #include <mad.h>
+ #include <stdio.h>
++#include <stdint.h>
+ #include <string.h>
+ #include <errno.h>
+ #include <fcntl.h>
+@@ -207,7 +208,7 @@ int l_init(void) {
+
+ addr.sin_family = AF_INET;
+ addr.sin_port = htons(LISTENPORT);
+- addr.sin_addr.s_addr = (u_int32_t) INADDR_ANY;
++ addr.sin_addr.s_addr = (uint32_t) INADDR_ANY;
+
+ if(bind(*s, (struct sockaddr *) &addr, sizeof(struct sockaddr_in)) == -1)
+ return(-1);
+--- a/streamer/streamer.c
++++ b/streamer/streamer.c
+@@ -25,6 +25,7 @@
+ #include <sys/socket.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <stdint.h>
+ #include <stdlib.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+@@ -129,7 +130,7 @@ int main(int argc, char *argv[]) {
+ }
+ addr.sin_family = AF_INET;
+ addr.sin_port = htons(LISTENPORT);
+- addr.sin_addr.s_addr = (u_int32_t) htonl(INADDR_LOOPBACK);
++ addr.sin_addr.s_addr = (uint32_t) htonl(INADDR_LOOPBACK);
+
+ if(connect(s, (struct sockaddr *) &addr, sizeof(struct sockaddr_in)) == -1) {
+ perror("Failed to connect to localhost:5555");