summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2023-10-28 13:01:10 +0200
committerSam James <sam@gentoo.org>2023-10-28 22:43:56 +0100
commit4df03b53e1e18559ef77d9ed2e756db7f6262a3b (patch)
tree3036a85b379bbf2ea6b7b29b4ed595adbb617bee /media-libs
parentmedia-libs/opencolorio: 2.3.0 Correctly recover CXX_FLAGS (diff)
downloadgentoo-4df03b53e1e18559ef77d9ed2e756db7f6262a3b.tar.gz
gentoo-4df03b53e1e18559ef77d9ed2e756db7f6262a3b.tar.bz2
gentoo-4df03b53e1e18559ef77d9ed2e756db7f6262a3b.zip
media-libs/opencolorio: 2.3.0 support SIMD, drop old cmake option
reflect upstream changes in the ebuild: - dropped USE_SSE and added extended SIMD support https://github.com/AcademySoftwareFoundation/OpenColorIO/commit/9cc24865599579f02fa07c09880518bef2058a03 arm support depends on - dropped OCIO_UISE_OIIO_CMAKE_CONFIG https://github.com/AcademySoftwareFoundation/OpenColorIO/commit/e93efe3b703d491faf4c4ead0823fb0e48734b1b Closes: https://bugs.gentoo.org/914863 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/opencolorio/opencolorio-2.3.0.ebuild35
1 files changed, 32 insertions, 3 deletions
diff --git a/media-libs/opencolorio/opencolorio-2.3.0.ebuild b/media-libs/opencolorio/opencolorio-2.3.0.ebuild
index 13f9c323a420..f86fc7933d70 100644
--- a/media-libs/opencolorio/opencolorio-2.3.0.ebuild
+++ b/media-libs/opencolorio/opencolorio-2.3.0.ebuild
@@ -17,7 +17,12 @@ SLOT="0/$(ver_cut 1-2)"
# minizip-ng: ~arm ~arm64 ~ppc64 ~riscv
# osl: ~riscv
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="apps cpu_flags_x86_sse2 doc opengl python test"
+CPU_USE=(
+ x86_{avx,avx2,avx512f,f16c,sse2,sse3,sse4_1,sse4_2,ssse3}
+ # requires https://github.com/DLTcollab/sse2neon
+ # arm_neon
+)
+IUSE="apps ${CPU_USE[@]/#/cpu_flags_} doc opengl python test"
# TODO: drop opengl? It does nothing without building either the apps or the testsuite
REQUIRED_USE="
apps? ( opengl )
@@ -114,9 +119,33 @@ src_configure() {
"-DOCIO_BUILD_PYTHON=$(usex python)"
"-DOCIO_BUILD_TESTS=$(usex test)"
"-DOCIO_INSTALL_EXT_PACKAGES=NONE"
- "-DOCIO_USE_OIIO_CMAKE_CONFIG=ON"
- "-DOCIO_USE_SSE=$(usex cpu_flags_x86_sse2)"
+ # allow the user to tell OCIO to display more information when searching and building the dependencies.
+ # "-DOCIO_VERBOSE=YES"
+
+ "-DOCIO_USE_SIMD=ON"
)
+
+ if use amd64 || use x86 ; then
+ mycmakeargs+=(
+ "-DOCIO_USE_SSE2=$(usex cpu_flags_x86_sse2)"
+ "-DOCIO_USE_SSE3=$(usex cpu_flags_x86_sse3)"
+ "-DOCIO_USE_SSSE3=$(usex cpu_flags_x86_ssse3)"
+ "-DOCIO_USE_SSE4=$(usex cpu_flags_x86_sse4_1)"
+ "-DOCIO_USE_SSE42=$(usex cpu_flags_x86_sse4_2)"
+ "-DOCIO_USE_AVX=$(usex cpu_flags_x86_avx)"
+ "-DOCIO_USE_AVX2=$(usex cpu_flags_x86_avx2)"
+ "-DOCIO_USE_AVX512=$(usex cpu_flags_x86_avx512f)"
+ "-DOCIO_USE_F16C=$(usex cpu_flags_x86_f16c)"
+ )
+ fi
+
+ # requires https://github.com/DLTcollab/sse2neon
+ # if use arm || use arm64 ; then
+ # mycmakeargs+=(
+ # "-DOCIO_USE_SSE2NEON=$(usex cpu_flags_arm_neon)"
+ # )
+ # fi
+
use python && mycmakeargs+=(
"-DOCIO_PYTHON_VERSION=${EPYTHON/python/}"
"-DPython_EXECUTABLE=${PYTHON}"