summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-29 10:35:51 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-29 10:37:25 -0700
commit5c1b8b4038ee152e30de111ee673fc1ee57b245a (patch)
tree48dd94efa5ac68940df5901d21c1384c34363afe /media-libs
parentdev-python/dicttoxml-1.7.4-r1: revbump, modernize a bit, py38 (diff)
downloadgentoo-5c1b8b4038ee152e30de111ee673fc1ee57b245a.tar.gz
gentoo-5c1b8b4038ee152e30de111ee673fc1ee57b245a.tar.bz2
gentoo-5c1b8b4038ee152e30de111ee673fc1ee57b245a.zip
media-libs/mesa: Replace vulkan REQUIRED_USE with pkg_pretend()
Ignore USE=vulkan if no supported VIDEO_CARDS are set, like we do with other USE flags. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-20.0.5.ebuild9
-rw-r--r--media-libs/mesa/mesa-9999.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/media-libs/mesa/mesa-20.0.5.ebuild b/media-libs/mesa/mesa-20.0.5.ebuild
index 85944a36141e..0bd61593e8de 100644
--- a/media-libs/mesa/mesa-20.0.5.ebuild
+++ b/media-libs/mesa/mesa-20.0.5.ebuild
@@ -44,7 +44,6 @@ REQUIRED_USE="
gles1? ( egl )
gles2? ( egl )
vulkan? ( dri3
- || ( video_cards_i965 video_cards_iris video_cards_radeonsi )
video_cards_radeonsi? ( llvm ) )
vulkan-overlay? ( vulkan )
wayland? ( egl gbm )
@@ -260,6 +259,14 @@ llvm_check_deps() {
}
pkg_pretend() {
+ if use vulkan; then
+ if ! use video_cards_i965 &&
+ ! use video_cards_iris &&
+ ! use video_cards_radeonsi; then
+ ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain i965, irisi, or radeonsi"
+ fi
+ fi
+
if use opencl; then
if ! use video_cards_r600 &&
! use video_cards_radeonsi; then
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 59a1d4fc57ca..800cbffbe700 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -44,7 +44,6 @@ REQUIRED_USE="
gles1? ( egl )
gles2? ( egl )
vulkan? ( dri3
- || ( video_cards_i965 video_cards_iris video_cards_radeonsi )
video_cards_radeonsi? ( llvm ) )
vulkan-overlay? ( vulkan )
wayland? ( egl gbm )
@@ -261,6 +260,14 @@ llvm_check_deps() {
}
pkg_pretend() {
+ if use vulkan; then
+ if ! use video_cards_i965 &&
+ ! use video_cards_iris &&
+ ! use video_cards_radeonsi; then
+ ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain i965, irisi, or radeonsi"
+ fi
+ fi
+
if use opencl; then
if ! use video_cards_r600 &&
! use video_cards_radeonsi; then