summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-23 23:57:21 +0000
committerSam James <sam@gentoo.org>2020-11-23 23:57:21 +0000
commitf1800fdaa32c75cec4609c27972445c1794e2643 (patch)
tree96bb6e2a3a55991a8029284487a09cd8b2bbc5fa /media-libs/raspberrypi-userland-bin
parentdev-lang/j: remote last-rited package (diff)
downloadgentoo-f1800fdaa32c75cec4609c27972445c1794e2643.tar.gz
gentoo-f1800fdaa32c75cec4609c27972445c1794e2643.tar.bz2
gentoo-f1800fdaa32c75cec4609c27972445c1794e2643.zip
media-libs/raspberrypi-userland-bin: bump to 20201022
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/raspberrypi-userland-bin')
-rw-r--r--media-libs/raspberrypi-userland-bin/Manifest1
-rw-r--r--media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201022.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/raspberrypi-userland-bin/Manifest b/media-libs/raspberrypi-userland-bin/Manifest
index 487bb6cedd47..7f1192e56cfe 100644
--- a/media-libs/raspberrypi-userland-bin/Manifest
+++ b/media-libs/raspberrypi-userland-bin/Manifest
@@ -1,2 +1,3 @@
DIST raspberrypi-firmware-1.20170303.tar.gz 118888867 BLAKE2B d90fc012d4371a797ed52172f0d0f94ea33901bbf10fc59f1ce0f54fbeb74a849b46dbbd4f71a73a7de655a4ed27586ee354e1535079e304bd66513452a33193 SHA512 cb0015fcaa607039db2ff40cadcfcafd0cf2ec7dd1df47f38414540fb1f86d626648bf6403989007895b0617c13ff4ec233a7b1987986224c09a8209e7732501
DIST raspberrypi-firmware-1.20190709.tar.gz 158835870 BLAKE2B 4e63b3308adcd75f69f66966f1c927449aa8dc65211e6ca5a27dd2a0ed6ed32cc85ad42221308f4fb3a852d9f278400cfe4f723f306abe102341568408027174 SHA512 6a0610c97db47441ede8e4f8436958899f678bf065a0fbde06de7945a1ac4d5f754a0e10d928d77759ba1cbf82654d85d9cb9c91b970c3fe9590560267033522
+DIST raspberrypi-firmware-1.20201022.tar.gz 189827375 BLAKE2B 94c38f60d688c8e3ebab830912daccbb6c04bdd3d88f6ca0d07d85be0a6b12c53f0266b4c258ed4694f30bad5db30fb6d30feabfd0b7668735a9a806b820d325 SHA512 876758179df27109984b6c3f4849fdcdc6bdcc2769495fcc83c97fc3ff4d07b9f3cd58086be877503f72c9e5417d2be6d6c33bce4cbb3b862055117c9cc26db8
diff --git a/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201022.ebuild b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201022.ebuild
new file mode 100644
index 000000000000..dedbb39c6c92
--- /dev/null
+++ b/media-libs/raspberrypi-userland-bin/raspberrypi-userland-bin-1.20201022.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="raspberrypi-firmware-${PV}"
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/firmware-${PV}"
+
+LICENSE="BSD GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="-* ~arm ~arm64"
+IUSE="+hardfp examples"
+
+RDEPEND="!media-libs/raspberrypi-userland"
+DEPEND="${DEPEND}"
+RESTRICT="binchecks strip"
+
+src_install() {
+ cd $(usex hardfp hardfp/ "")opt/vc || die
+
+ insinto /opt/vc
+ doins -r include
+
+ into /opt
+ dobin bin/*
+
+ insopts -m 0755
+ insinto "/opt/vc/lib"
+ doins -r lib/*
+
+ doenvd "${FILESDIR}"/04${PN}
+
+ if use examples ; then
+ insopts -m 0644
+ docinto examples
+ dodoc -r src/hello_pi
+ fi
+}