summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/quarter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/quarter')
-rw-r--r--media-libs/quarter/Manifest1
-rw-r--r--media-libs/quarter/files/quarter-1.0.0-gcc44.patch11
-rw-r--r--media-libs/quarter/metadata.xml8
-rw-r--r--media-libs/quarter/quarter-1.0.0-r1.ebuild49
4 files changed, 69 insertions, 0 deletions
diff --git a/media-libs/quarter/Manifest b/media-libs/quarter/Manifest
new file mode 100644
index 000000000000..6dbd214c5e0b
--- /dev/null
+++ b/media-libs/quarter/Manifest
@@ -0,0 +1 @@
+DIST Quarter-1.0.0.tar.gz 617534 SHA256 ed7a29856e2bdc9db20b7c4fa27c47af1bf325d62ef3700fccbc83476f41da1a SHA512 ab7828889b612425c6341f69abaf6bc5c02ed5f918a5ad631ad9e0a6ecb9fd5800e08d091fd39bb05141e0db521d305471f66a3d14f149928add3f1d776e497b WHIRLPOOL cfb6f8d770449b7b00fa04c60f6607b87a4c5620a1b5363e46bdc3e62eb39ec42d6a0a7d1f793d96a7bc0d5af4db5c4c227219c4790fe6a9bd67241b8a44652c
diff --git a/media-libs/quarter/files/quarter-1.0.0-gcc44.patch b/media-libs/quarter/files/quarter-1.0.0-gcc44.patch
new file mode 100644
index 000000000000..e0f422b4cd36
--- /dev/null
+++ b/media-libs/quarter/files/quarter-1.0.0-gcc44.patch
@@ -0,0 +1,11 @@
+diff -ruN Quarter-1.0.0/src/Quarter/Quarter.cpp my/src/Quarter/Quarter.cpp
+--- Quarter-1.0.0/src/Quarter/Quarter.cpp 2009-01-26 22:47:07.000000000 +0100
++++ my/src/Quarter/Quarter.cpp 2014-08-14 01:48:45.019728780 +0200
+@@ -123,6 +123,7 @@
+ \subpage examiner
+ */
+
++#include <stdio.h>
+
+ #include <Inventor/SoDB.h>
+ #include <Inventor/nodekits/SoNodeKit.h>
diff --git a/media-libs/quarter/metadata.xml b/media-libs/quarter/metadata.xml
new file mode 100644
index 000000000000..e4c38b722575
--- /dev/null
+++ b/media-libs/quarter/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>reavertm@gentoo.org</email>
+ <name>Maciej Mrozowski</name>
+</maintainer>
+</pkgmetadata>
diff --git a/media-libs/quarter/quarter-1.0.0-r1.ebuild b/media-libs/quarter/quarter-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..1359ff911a73
--- /dev/null
+++ b/media-libs/quarter/quarter-1.0.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+MY_P="${P/q/Q}"
+
+DESCRIPTION="A glue between Nokia Qt4 and Coin3D"
+HOMEPAGE="http://www.coin3d.org/lib/quarter"
+SRC_URI="ftp://ftp.coin3d.org/pub/coin/src/all/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug doc static-libs"
+
+RDEPEND="
+ >=media-libs/coin-3.0.0[javascript]
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc44.patch"
+)
+
+DOCS=(AUTHORS NEWS README)
+
+src_configure() {
+ local myeconfargs=(
+ htmldir="${ROOT}usr/share/doc/${PF}/html"
+ --enable-pkgconfig
+ --with-coin
+ $(use_enable debug)
+ $(use_enable debug symbols)
+ $(use_enable doc html)
+ )
+ autotools-utils_src_configure
+}