summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-12 12:39:10 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-12 12:55:47 +0100
commit10c29d339cd28361f4c79daa80b3e8c2d094f62d (patch)
tree6cd066fedf5ebd30cf561d282f9d4cb65bc6b4ec /media-libs/mlt
parentkde-apps/kross-interpreters: Drop 18.08.3 (r0) (diff)
downloadgentoo-10c29d339cd28361f4c79daa80b3e8c2d094f62d.tar.gz
gentoo-10c29d339cd28361f4c79daa80b3e8c2d094f62d.tar.bz2
gentoo-10c29d339cd28361f4c79daa80b3e8c2d094f62d.zip
media-libs/mlt: 6.12.0 version bump, switch to ruby25
Bug: https://bugs.gentoo.org/672984 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/mlt')
-rw-r--r--media-libs/mlt/Manifest1
-rw-r--r--media-libs/mlt/files/mlt-6.12.0-frei0r-w-tractor.patch37
-rw-r--r--media-libs/mlt/files/mlt-6.12.0-rgb-to-yuv-accuracy.patch169
-rw-r--r--media-libs/mlt/files/mlt-6.12.0-seconds-digits.patch22
-rw-r--r--media-libs/mlt/mlt-6.12.0.ebuild219
5 files changed, 448 insertions, 0 deletions
diff --git a/media-libs/mlt/Manifest b/media-libs/mlt/Manifest
index b884ece8480d..22521d2f15e4 100644
--- a/media-libs/mlt/Manifest
+++ b/media-libs/mlt/Manifest
@@ -1 +1,2 @@
DIST mlt-6.10.0.tar.gz 1384632 BLAKE2B 4bbcf95409df1ea1828d2b34e6d6663cf83f5672641034f775d029037505051c5490c46c69e104811aaf776794be2df95913d094319f4a2dbba0c42117abe15e SHA512 6f374f20f1dc851792c1075537cf7e977038fb557b2bd5d5816c1fc69d471947c8469c914cf662766f3b503ae819881bf2b4e1673e0f7a84309e0fb671a9de1b
+DIST mlt-6.12.0.tar.gz 1395646 BLAKE2B 18dc06c4075d8d51bc7f62d027adda92c359275b9ad2131cc015b4402b1b7a9438fe87b617075017b9fd5e9696b82c4c840fa6dd83188bd0cedb7f01d2158283 SHA512 ed2cc0eeda45558ae6f1ec8780dfd413641953dc12dc32dccf655649f68f8e6088d39fefb7bef7bae042a41096976004446019d82ea162785bc487009cb97680
diff --git a/media-libs/mlt/files/mlt-6.12.0-frei0r-w-tractor.patch b/media-libs/mlt/files/mlt-6.12.0-frei0r-w-tractor.patch
new file mode 100644
index 000000000000..e655f805f539
--- /dev/null
+++ b/media-libs/mlt/files/mlt-6.12.0-frei0r-w-tractor.patch
@@ -0,0 +1,37 @@
+From 30621f28fd3a21a4162de17a12d943e811566b5e Mon Sep 17 00:00:00 2001
+From: Dan Dennedy <dan@dennedy.org>
+Date: Wed, 5 Dec 2018 11:14:54 -0800
+Subject: [PATCH] Fix frei0r producer not working with tractor.
+
+Reported in https://forum.shotcut.org/t/color-bars-working-not-
+correctly/8308
+---
+ src/modules/frei0r/producer_frei0r.c | 8 ++------
+ 1 file changed, 2 insertions(+), 6 deletions(-)
+
+diff --git a/src/modules/frei0r/producer_frei0r.c b/src/modules/frei0r/producer_frei0r.c
+index 9a90f6b6b..d1547f6c5 100644
+--- a/src/modules/frei0r/producer_frei0r.c
++++ b/src/modules/frei0r/producer_frei0r.c
+@@ -26,12 +26,7 @@
+
+ static int producer_get_image( mlt_frame frame, uint8_t **buffer, mlt_image_format *format, int *width, int *height, int writable )
+ {
+-
+- // Obtain properties of frame
+- mlt_properties properties = MLT_FRAME_PROPERTIES( frame );
+-
+- // Obtain the producer for this frame
+- mlt_producer producer = mlt_properties_get_data( properties, "producer_frei0r", NULL );
++ mlt_producer producer = mlt_frame_pop_service( frame );
+
+ // Choose suitable out values if nothing specific requested
+ if ( *width <= 0 )
+@@ -83,6 +78,7 @@ int producer_get_frame( mlt_producer producer, mlt_frame_ptr frame, int index )
+ mlt_properties_set_double( properties, "aspect_ratio", mlt_profile_sar( profile ) );
+
+ // Push the get_image method
++ mlt_frame_push_service( *frame, producer );
+ mlt_frame_push_get_image( *frame, producer_get_image );
+ }
+ \ No newline at end of file
diff --git a/media-libs/mlt/files/mlt-6.12.0-rgb-to-yuv-accuracy.patch b/media-libs/mlt/files/mlt-6.12.0-rgb-to-yuv-accuracy.patch
new file mode 100644
index 000000000000..d0930c5ac63b
--- /dev/null
+++ b/media-libs/mlt/files/mlt-6.12.0-rgb-to-yuv-accuracy.patch
@@ -0,0 +1,169 @@
+From adc5a2284b3a1073cb364c5f07d1d7c97e94c937 Mon Sep 17 00:00:00 2001
+From: Dan Dennedy <dan@dennedy.org>
+Date: Fri, 30 Nov 2018 15:26:15 -0800
+Subject: [PATCH] Fix color accuracy of RGB->YUV conversion.
+
+Fixes https://github.com/mltframework/shotcut/issues/674
+---
+ src/modules/avformat/common.c | 2 ++
+ src/modules/avformat/common.h | 1 +
+ src/modules/avformat/consumer_avformat.c | 7 +------
+ src/modules/avformat/filter_avcolour_space.c | 7 +------
+ src/modules/avformat/filter_swscale.c | 12 ++++--------
+ src/modules/avformat/producer_avformat.c | 12 ++++++------
+ 6 files changed, 15 insertions(+), 26 deletions(-)
+
+diff --git a/src/modules/avformat/common.c b/src/modules/avformat/common.c
+index 2b1f1fd5d..dca9dbaee 100644
+--- a/src/modules/avformat/common.c
++++ b/src/modules/avformat/common.c
+@@ -22,6 +22,8 @@
+ #include <libavutil/channel_layout.h>
+ #include <libavutil/samplefmt.h>
+
++int mlt_default_sws_flags = SWS_BICUBIC | SWS_FULL_CHR_H_INP | SWS_FULL_CHR_H_INT | SWS_ACCURATE_RND;
++
+ int mlt_to_av_sample_format( mlt_audio_format format )
+ {
+ switch( format )
+diff --git a/src/modules/avformat/common.h b/src/modules/avformat/common.h
+index 54df63e93..ce0f0f079 100644
+--- a/src/modules/avformat/common.h
++++ b/src/modules/avformat/common.h
+@@ -29,5 +29,6 @@ mlt_channel_layout av_channel_layout_to_mlt( int64_t layout );
+ mlt_channel_layout get_channel_layout_or_default( const char* name, int channels );
+ int set_luma_transfer( struct SwsContext *context, int src_colorspace,
+ int dst_colorspace, int src_full_range, int dst_full_range );
++extern int mlt_default_sws_flags;
+
+ #endif // COMMON_H
+diff --git a/src/modules/avformat/consumer_avformat.c b/src/modules/avformat/consumer_avformat.c
+index eab96271f..1e445ef76 100644
+--- a/src/modules/avformat/consumer_avformat.c
++++ b/src/modules/avformat/consumer_avformat.c
+@@ -1956,12 +1956,7 @@ static void *consumer_thread( void *arg )
+ mlt_image_format_planes( img_fmt, width, height, image, video_avframe.data, video_avframe.linesize );
+
+ // Do the colour space conversion
+- int flags = SWS_BICUBIC | SWS_ACCURATE_RND;
+- if ( pix_fmt == AV_PIX_FMT_YUYV422 || pix_fmt == AV_PIX_FMT_YUV422P16LE )
+- flags |= SWS_FULL_CHR_H_INP;
+- else
+- flags |= SWS_FULL_CHR_H_INT;
+-
++ int flags = mlt_default_sws_flags;
+ struct SwsContext *context = sws_getContext( width, height, pick_pix_fmt( img_fmt ),
+ width, height, pix_fmt, flags, NULL, NULL, NULL);
+ int src_colorspace = mlt_properties_get_int( frame_properties, "colorspace" );
+diff --git a/src/modules/avformat/filter_avcolour_space.c b/src/modules/avformat/filter_avcolour_space.c
+index f25cf092b..89ee6b522 100644
+--- a/src/modules/avformat/filter_avcolour_space.c
++++ b/src/modules/avformat/filter_avcolour_space.c
+@@ -84,14 +84,9 @@ static int av_convert_image( uint8_t *out, uint8_t *in, int out_fmt, int in_fmt,
+ int in_stride[4];
+ uint8_t *out_data[4];
+ int out_stride[4];
+- int flags = SWS_BICUBIC | SWS_ACCURATE_RND;
++ int flags = mlt_default_sws_flags;
+ int error = -1;
+
+- if ( out_fmt == AV_PIX_FMT_YUYV422 || out_fmt == AV_PIX_FMT_YUV422P16LE )
+- flags |= SWS_FULL_CHR_H_INP;
+- else
+- flags |= SWS_FULL_CHR_H_INT;
+-
+ if ( in_fmt == AV_PIX_FMT_YUV422P16LE )
+ mlt_image_format_planes(mlt_image_yuv422p16, width, height, in, in_data, in_stride);
+ else
+diff --git a/src/modules/avformat/filter_swscale.c b/src/modules/avformat/filter_swscale.c
+index 475036a6f..52c165f9f 100644
+--- a/src/modules/avformat/filter_swscale.c
++++ b/src/modules/avformat/filter_swscale.c
+@@ -1,6 +1,6 @@
+ /*
+ * filter_swscale.c -- image scaling filter
+- * Copyright (C) 2008-2017 Meltytech, LLC
++ * Copyright (C) 2008-2018 Meltytech, LLC
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+@@ -88,23 +88,19 @@ static int filter_scale( mlt_frame frame, uint8_t **image, mlt_image_format *for
+ interp = SWS_LANCZOS;
+ else if ( strcmp( interps, "spline" ) == 0 )
+ interp = SWS_SPLINE;
+- interp |= SWS_ACCURATE_RND;
++
++ // Set swscale flags to get good quality
++ interp |= SWS_FULL_CHR_H_INP | SWS_FULL_CHR_H_INT | SWS_ACCURATE_RND;
+
+ // Determine the output image size.
+ int out_size = mlt_image_format_size( *format, owidth, oheight, NULL );
+
+- // Set swscale flags to get good quality
+ switch ( *format )
+ {
+ case mlt_image_yuv422:
+- interp |= SWS_FULL_CHR_H_INP;
+- break;
+ case mlt_image_rgb24:
+- interp |= SWS_FULL_CHR_H_INT;
+- break;
+ case mlt_image_rgb24a:
+ case mlt_image_opengl:
+- interp |= SWS_FULL_CHR_H_INT;
+ break;
+ default:
+ // XXX: we only know how to rescale packed formats
+diff --git a/src/modules/avformat/producer_avformat.c b/src/modules/avformat/producer_avformat.c
+index 9b96b4e5c..d24ca41e7 100644
+--- a/src/modules/avformat/producer_avformat.c
++++ b/src/modules/avformat/producer_avformat.c
+@@ -1281,7 +1281,7 @@ static int sliced_h_pix_fmt_conv_proc( int id, int idx, int jobs, void* cookie )
+ av_opt_set_int( sws, "dstw", slice_w, 0 );
+ av_opt_set_int( sws, "dsth", h, 0 );
+ av_opt_set_int( sws, "dst_format", ctx->dst_format, 0 );
+- av_opt_set_int( sws, "sws_flags", ctx->flags | SWS_FULL_CHR_H_INP, 0 );
++ av_opt_set_int( sws, "sws_flags", ctx->flags, 0 );
+
+ av_opt_set_int( sws, "src_h_chr_pos", -513, 0 );
+ av_opt_set_int( sws, "src_v_chr_pos", src_v_chr_pos, 0 );
+@@ -1338,7 +1338,7 @@ static int sliced_h_pix_fmt_conv_proc( int id, int idx, int jobs, void* cookie )
+ static int convert_image( producer_avformat self, AVFrame *frame, uint8_t *buffer, int pix_fmt,
+ mlt_image_format *format, int width, int height, uint8_t **alpha )
+ {
+- int flags = SWS_BICUBIC | SWS_ACCURATE_RND;
++ int flags = mlt_default_sws_flags;
+ mlt_profile profile = mlt_service_profile( MLT_PRODUCER_SERVICE( self->parent ) );
+ int result = self->yuv_colorspace;
+
+@@ -1400,7 +1400,7 @@ static int convert_image( producer_avformat self, AVFrame *frame, uint8_t *buffe
+ else if ( *format == mlt_image_rgb24 )
+ {
+ struct SwsContext *context = sws_getContext( width, height, src_pix_fmt,
+- width, height, AV_PIX_FMT_RGB24, flags | SWS_FULL_CHR_H_INT, NULL, NULL, NULL);
++ width, height, AV_PIX_FMT_RGB24, flags, NULL, NULL, NULL);
+ uint8_t *out_data[4];
+ int out_stride[4];
+ av_image_fill_arrays(out_data, out_stride, buffer, AV_PIX_FMT_RGB24, width, height, IMAGE_ALIGN);
+@@ -1413,7 +1413,7 @@ static int convert_image( producer_avformat self, AVFrame *frame, uint8_t *buffe
+ else if ( *format == mlt_image_rgb24a || *format == mlt_image_opengl )
+ {
+ struct SwsContext *context = sws_getContext( width, height, src_pix_fmt,
+- width, height, AV_PIX_FMT_RGBA, flags | SWS_FULL_CHR_H_INT, NULL, NULL, NULL);
++ width, height, AV_PIX_FMT_RGBA, flags, NULL, NULL, NULL);
+ uint8_t *out_data[4];
+ int out_stride[4];
+ av_image_fill_arrays(out_data, out_stride, buffer, AV_PIX_FMT_RGBA, width, height, IMAGE_ALIGN);
+@@ -1475,10 +1475,10 @@ static int convert_image( producer_avformat self, AVFrame *frame, uint8_t *buffe
+ {
+ #if defined(FFUDIV) && (LIBAVFORMAT_VERSION_INT >= ((55<<16)+(48<<8)+100))
+ struct SwsContext *context = sws_getContext( width, height, src_pix_fmt,
+- width, height, AV_PIX_FMT_YUYV422, flags | SWS_FULL_CHR_H_INP, NULL, NULL, NULL);
++ width, height, AV_PIX_FMT_YUYV422, flags, NULL, NULL, NULL);
+ #else
+ struct SwsContext *context = sws_getContext( width, height, pix_fmt,
+- width, height, AV_PIX_FMT_YUYV422, flags | SWS_FULL_CHR_H_INP, NULL, NULL, NULL);
++ width, height, AV_PIX_FMT_YUYV422, flags, NULL, NULL, NULL);
+ #endif
+ AVPicture output;
+ avpicture_fill( &output, buffer, AV_PIX_FMT_YUYV422, width, height ); \ No newline at end of file
diff --git a/media-libs/mlt/files/mlt-6.12.0-seconds-digits.patch b/media-libs/mlt/files/mlt-6.12.0-seconds-digits.patch
new file mode 100644
index 000000000000..c00accefd1e3
--- /dev/null
+++ b/media-libs/mlt/files/mlt-6.12.0-seconds-digits.patch
@@ -0,0 +1,22 @@
+From 64a71150650616ab0309da1a76e37e762572f641 Mon Sep 17 00:00:00 2001
+From: Brian Matherly <code@brianmatherly.com>
+Date: Mon, 19 Nov 2018 22:44:07 -0600
+Subject: [PATCH] Fix number of digits for seconds.
+
+---
+ src/modules/plus/filter_timer.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/modules/plus/filter_timer.c b/src/modules/plus/filter_timer.c
+index 519f1f72a..32da3281d 100644
+--- a/src/modules/plus/filter_timer.c
++++ b/src/modules/plus/filter_timer.c
+@@ -90,7 +90,7 @@ static void get_timer_str( mlt_filter filter, mlt_frame frame, char* text )
+ }
+ else if ( !strcmp( format, "MM:SS.SS" ) )
+ {
+- snprintf( text, MAX_TEXT_LEN, "%02d:%02.2f", hours * 60 + mins, secs );
++ snprintf( text, MAX_TEXT_LEN, "%02d:%05.2f", hours * 60 + mins, secs );
+ }
+ else if ( !strcmp( format, "SS" ) )
+ { \ No newline at end of file
diff --git a/media-libs/mlt/mlt-6.12.0.ebuild b/media-libs/mlt/mlt-6.12.0.ebuild
new file mode 100644
index 000000000000..cb1ff2b99085
--- /dev/null
+++ b/media-libs/mlt/mlt-6.12.0.ebuild
@@ -0,0 +1,219 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+# this ebuild currently only supports installing ruby bindings for a single ruby version
+# so USE_RUBY must contain only a single value (the latest stable) as the ebuild calls
+# /usr/bin/${USE_RUBY} directly
+USE_RUBY="ruby25"
+inherit python-single-r1 ruby-single toolchain-funcs
+
+DESCRIPTION="Open source multimedia framework for television broadcasting"
+HOMEPAGE="https://www.mltframework.org/"
+SRC_URI="https://github.com/mltframework/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="compressed-lumas cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 debug ffmpeg fftw frei0r
+gtk jack kdenlive libav libsamplerate lua melt opencv opengl python qt5 rtaudio ruby sdl vdpau xine xml"
+# java perl php tcl vidstab
+IUSE="${IUSE} kernel_linux"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+#rtaudio will use OSS on non linux OSes
+RDEPEND="
+ >=media-libs/libebur128-1.2.2
+ ffmpeg? (
+ libav? ( >=media-video/libav-12:0=[vdpau?] )
+ !libav? ( media-video/ffmpeg:0=[vdpau?] )
+ )
+ fftw? ( sci-libs/fftw:3.0= )
+ frei0r? ( media-plugins/frei0r-plugins )
+ gtk? (
+ media-libs/libexif
+ x11-libs/gtk+:2
+ x11-libs/pango
+ )
+ jack? (
+ >=dev-libs/libxml2-2.5
+ media-libs/ladspa-sdk
+ virtual/jack
+ )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )
+ lua? ( >=dev-lang/lua-5.1.4-r4:= )
+ opencv? ( >=media-libs/opencv-3.2.0:= )
+ opengl? ( media-video/movit )
+ python? ( ${PYTHON_DEPS} )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-libs/libexif
+ x11-libs/libX11
+ )
+ rtaudio? (
+ >=media-libs/rtaudio-4.1.2
+ kernel_linux? ( media-libs/alsa-lib )
+ )
+ ruby? ( ${RUBY_DEPS} )
+ sdl? (
+ media-libs/libsdl2[X,opengl,video]
+ media-libs/sdl2-image
+ )
+ xine? ( >=media-libs/xine-lib-1.1.2_pre20060328-r7 )
+ xml? ( >=dev-libs/libxml2-2.5 )"
+# java? ( >=virtual/jre-1.5 )
+# perl? ( dev-lang/perl )
+# php? ( dev-lang/php )
+# sox? ( media-sound/sox )
+# tcl? ( dev-lang/tcl:0= )
+# vidstab? ( media-libs/libvidstab )
+SWIG_DEPEND=">=dev-lang/swig-2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ compressed-lumas? ( virtual/imagemagick-tools[png] )
+ lua? ( ${SWIG_DEPEND} virtual/pkgconfig )
+ python? ( ${SWIG_DEPEND} )
+ ruby? ( ${SWIG_DEPEND} )"
+# java? ( ${SWIG_DEPEND} >=virtual/jdk-1.5 )
+# perl? ( ${SWIG_DEPEND} )
+# php? ( ${SWIG_DEPEND} )
+# tcl? ( ${SWIG_DEPEND} )
+
+DOCS=( AUTHORS ChangeLog NEWS README docs/{framework,melt,mlt{++,-xml}}.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.10.0-swig-underlinking.patch
+ "${FILESDIR}"/${P}-seconds-digits.patch
+ "${FILESDIR}"/${P}-rgb-to-yuv-accuracy.patch
+ "${FILESDIR}"/${P}-frei0r-w-tractor.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # respect CFLAGS LDFLAGS when building shared libraries. Bug #308873
+ for x in python lua; do
+ sed -i "/mlt.so/s: -lmlt++ :& ${CFLAGS} ${LDFLAGS} :" src/swig/$x/build || die
+ done
+ sed -i "/^LDFLAGS/s: += :& ${LDFLAGS} :" src/swig/ruby/build || die
+
+ sed -i -e "s/env ruby/${USE_RUBY}/" src/swig/ruby/* || die
+}
+
+src_configure() {
+ tc-export CC CXX
+
+ local myconf=(
+ --enable-gpl
+ --enable-gpl3
+ --enable-motion-est
+ --target-arch=$(tc-arch)
+ --disable-kde
+ --disable-sdl
+ --disable-swfdec
+ $(use_enable debug)
+ $(use compressed-lumas && echo ' --luma-compress')
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable gtk gtk2)
+ $(use_enable jack jackrack)
+ $(use_enable ffmpeg avformat)
+ $(use ffmpeg && echo ' --avformat-swscale')
+ $(use_enable fftw plus)
+ $(use_enable frei0r)
+ $(use_enable melt)
+ $(use_enable opencv)
+ $(use_enable opengl)
+ $(use_enable libsamplerate resample)
+ $(use_enable rtaudio)
+ $(use vdpau && echo ' --avformat-vdpau')
+ $(use_enable sdl sdl2)
+ $(use_enable xml)
+ $(use_enable xine)
+ $(use_enable kdenlive)
+ --disable-sox
+ )
+ #$(use_enable sox) FIXME
+
+ if use qt5 ; then
+ myconf+=(
+ --enable-qt
+ --qt-includedir=$(pkg-config Qt5Core --variable=includedir)
+ --qt-libdir=$(pkg-config Qt5Core --variable=libdir)
+ )
+ else
+ myconf+=( --disable-qt )
+ fi
+
+ if use x86 || use amd64 ; then
+ myconf+=( $(use_enable cpu_flags_x86_mmx mmx) )
+ else
+ myconf+=( --disable-mmx )
+ fi
+
+ if ! use melt; then
+ sed -i -e "s;src/melt;;" Makefile || die
+ fi
+
+ # TODO: add swig language bindings
+ # see also https://www.mltframework.org/twiki/bin/view/MLT/ExtremeMakeover
+
+ local swig_lang
+ # TODO: java perl php tcl
+ for i in lua python ruby ; do
+ use $i && swig_lang="${swig_lang} $i"
+ done
+ [[ -z "${swig_lang}" ]] && swig_lang="none"
+
+ econf ${myconf[@]} --swig-languages="${swig_lang}"
+
+ sed -i -e s/^OPT/#OPT/ "${S}/config.mak" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins -r demo
+
+ docinto swig
+
+ # Install SWIG bindings
+ if use lua; then
+ cd "${S}"/src/swig/lua || die
+ exeinto $(pkg-config --variable INSTALL_CMOD lua)
+ doexe mlt.so
+ dodoc play.lua
+ fi
+
+ if use python; then
+ cd "${S}"/src/swig/python || die
+ insinto $(python_get_sitedir)
+ doins mlt.py
+ exeinto $(python_get_sitedir)
+ doexe _mlt.so
+ dodoc play.py
+ python_optimize
+ fi
+
+ if use ruby; then
+ cd "${S}"/src/swig/ruby || die
+ exeinto $("${EPREFIX}"/usr/bin/${USE_RUBY} -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')
+ doexe mlt.so
+ dodoc play.rb thumbs.rb
+ fi
+ # TODO: java perl php tcl
+}