summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2018-04-22 00:00:49 +0200
committerJonas Stein <jstein@gentoo.org>2018-04-22 00:01:04 +0200
commit39f51b31aafed2b9127c5d68366309a7a4449d93 (patch)
tree42d8ce82bfb893139b16e4cafda5de5f57584f33 /media-gfx
parentsys-fs/btrfsmaintenance: bump to version 0.4.1 (diff)
downloadgentoo-39f51b31aafed2b9127c5d68366309a7a4449d93.tar.gz
gentoo-39f51b31aafed2b9127c5d68366309a7a4449d93.tar.bz2
gentoo-39f51b31aafed2b9127c5d68366309a7a4449d93.zip
media-gfx/uniconvertor: QA Fix: xdg_utils
Add missing update funtions to the ebuild. Closes: https://bugs.gentoo.org/633604 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/uniconvertor/uniconvertor-2.0_pre379-r1.ebuild14
-rw-r--r--media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild12
2 files changed, 23 insertions, 3 deletions
diff --git a/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r1.ebuild b/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r1.ebuild
index bb227cb03b18..6f983cf383fd 100644
--- a/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r1.ebuild
+++ b/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1
+inherit distutils-r1 xdg-utils
DESCRIPTION="Convert vector graphic file formats like .cdr, .svg, wmf and more."
HOMEPAGE="https://sk1project.net/modules.php?name=Products&product=uniconvertor"
@@ -52,3 +52,13 @@ python_test() {
cd src/unittests || die
${EPYTHON} all_tests.py || die
}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
diff --git a/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild b/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild
index 93d5343814c0..2a5d72d35690 100644
--- a/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild
+++ b/media-gfx/uniconvertor/uniconvertor-2.0_pre379-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1
+inherit distutils-r1 xdg-utils
DESCRIPTION="Convert vector graphic file formats like .cdr, .svg, wmf and more."
HOMEPAGE="https://sk1project.net/modules.php?name=Products&product=uniconvertor"
@@ -61,3 +61,13 @@ python_test() {
cd src/unittests || die
${EPYTHON} all_tests.py || die
}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}