summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/gnome-screenshot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/gnome-screenshot')
-rw-r--r--media-gfx/gnome-screenshot/Manifest2
-rw-r--r--media-gfx/gnome-screenshot/files/gnome-screenshot-3.14.0-use-dash.patch23
-rw-r--r--media-gfx/gnome-screenshot/gnome-screenshot-3.14.0-r1.ebuild57
-rw-r--r--media-gfx/gnome-screenshot/gnome-screenshot-3.16.2.ebuild51
-rw-r--r--media-gfx/gnome-screenshot/metadata.xml5
5 files changed, 138 insertions, 0 deletions
diff --git a/media-gfx/gnome-screenshot/Manifest b/media-gfx/gnome-screenshot/Manifest
new file mode 100644
index 000000000000..600ce6d95f68
--- /dev/null
+++ b/media-gfx/gnome-screenshot/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-screenshot-3.14.0.tar.xz 259796 SHA256 d96f108421ab04ee5d26387387df3858764e61d7718c7376cbf87890bf33912a SHA512 b8ccdc9db548824eb6e7bc7c783c429363a510921c2187d5daa3f83cfda202a3a0e447db1cb49649940add84e4e404c2a821f96ec3e895e0fc3f549362bf79a3 WHIRLPOOL a2347d6509336d9872557a6db29657d15ecb22a642b5d2c20836b4f32559f166617e620f77676a67703a939a515e2ef4d1e5e1c793ba588e8dd915300c11ea58
+DIST gnome-screenshot-3.16.2.tar.xz 279828 SHA256 5dd4bafb3deb0967866726ba89dab62bbd6dc3bda3b190474281142aa3dee948 SHA512 98092e2779cc6fa67a40a2318c1f5637ac948f0c1c933552b66483230c9b17751f88082a2812635121b09af06a6e3e98e0f6f69aba97ebc8bfd4cd55d7d50135 WHIRLPOOL fc7d5e5f88fb78e400459685b1c65dbd07f3908471368aa15714ff41825c565f02285a101dc2b3ba2cf978e9fb2247c43a3d67cb3681a711639cf99a9928944a
diff --git a/media-gfx/gnome-screenshot/files/gnome-screenshot-3.14.0-use-dash.patch b/media-gfx/gnome-screenshot/files/gnome-screenshot-3.14.0-use-dash.patch
new file mode 100644
index 000000000000..5a6580ee3f35
--- /dev/null
+++ b/media-gfx/gnome-screenshot/files/gnome-screenshot-3.14.0-use-dash.patch
@@ -0,0 +1,23 @@
+From aa23783c39f96dd0b45f70d82557736a5b884c55 Mon Sep 17 00:00:00 2001
+From: Cosimo Cecchi <cosimoc@gnome.org>
+Date: Wed, 28 Jan 2015 12:43:58 +0000
+Subject: filename-builder: use dash for time format separator
+
+We can't use colons, but a separator here still looks nice. Use a dash.
+
+diff --git a/src/screenshot-filename-builder.c b/src/screenshot-filename-builder.c
+index 06706d6..5eade9c 100644
+--- a/src/screenshot-filename-builder.c
++++ b/src/screenshot-filename-builder.c
+@@ -130,7 +130,7 @@ build_path (AsyncExistenceJob *job)
+ GDateTime *d;
+
+ d = g_date_time_new_now_local ();
+- origin = g_date_time_format (d, "%Y-%m-%d %H:%M:%S");
++ origin = g_date_time_format (d, "%Y-%m-%d %H-%M-%S");
+ g_date_time_unref (d);
+ }
+ else
+--
+cgit v0.10.1
+
diff --git a/media-gfx/gnome-screenshot/gnome-screenshot-3.14.0-r1.ebuild b/media-gfx/gnome-screenshot/gnome-screenshot-3.14.0-r1.ebuild
new file mode 100644
index 000000000000..9c1aeb7e7362
--- /dev/null
+++ b/media-gfx/gnome-screenshot/gnome-screenshot-3.14.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 readme.gentoo
+
+DESCRIPTION="Screenshot utility for GNOME"
+HOMEPAGE="https://git.gnome.org/browse/gnome-screenshot"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# libcanberra 0.26-r2 is needed for gtk+:3 fixes
+COMMON_DEPEND="
+ >=dev-libs/glib-2.35.1:2[dbus]
+ >=media-libs/libcanberra-0.26-r2[gtk3]
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-3.0.3:3
+ x11-libs/libX11
+ x11-libs/libXext
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ !<gnome-extra/gnome-utils-3.4
+"
+# ${PN} was part of gnome-utils before 3.4
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xextproto
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="${P} saves screenshots in ~/Pictures/ and defaults to
+ non-interactive mode when launched from a terminal. If you want to choose
+ where to save the screenshot, run 'gnome-screenshot --interactive'"
+
+src_prepare() {
+ # filename-builder: use dash for time format separator (from 'master')
+ epatch "${FILESDIR}"/${PN}-3.14.0-use-dash.patch
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/media-gfx/gnome-screenshot/gnome-screenshot-3.16.2.ebuild b/media-gfx/gnome-screenshot/gnome-screenshot-3.16.2.ebuild
new file mode 100644
index 000000000000..e2d3c37bb85a
--- /dev/null
+++ b/media-gfx/gnome-screenshot/gnome-screenshot-3.16.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 readme.gentoo
+
+DESCRIPTION="Screenshot utility for GNOME"
+HOMEPAGE="https://git.gnome.org/browse/gnome-screenshot"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# libcanberra 0.26-r2 is needed for gtk+:3 fixes
+COMMON_DEPEND="
+ >=dev-libs/glib-2.35.1:2[dbus]
+ >=media-libs/libcanberra-0.26-r2[gtk3]
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-3.0.3:3
+ x11-libs/libX11
+ x11-libs/libXext
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ !<gnome-extra/gnome-utils-3.4
+"
+# ${PN} was part of gnome-utils before 3.4
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xextproto
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="${P} saves screenshots in ~/Pictures/ and defaults to
+ non-interactive mode when launched from a terminal. If you want to choose
+ where to save the screenshot, run 'gnome-screenshot --interactive'"
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/media-gfx/gnome-screenshot/metadata.xml b/media-gfx/gnome-screenshot/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/media-gfx/gnome-screenshot/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>