summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-03-30 06:17:30 +0200
committerJeroen Roovers <jer@gentoo.org>2016-03-30 06:17:30 +0200
commit41fccacb21f580b97c190a2310ead9d7c35fd7d1 (patch)
tree35d13f928f30360e61d712ac8f6662aec2b04a50 /media-gfx/fbida/files
parentsys-apps/sandbox: fix crashes w/some ELFs #578524 (diff)
downloadgentoo-41fccacb21f580b97c190a2310ead9d7c35fd7d1.tar.gz
gentoo-41fccacb21f580b97c190a2310ead9d7c35fd7d1.tar.bz2
gentoo-41fccacb21f580b97c190a2310ead9d7c35fd7d1.zip
media-gfx/fbida: Old.
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-gfx/fbida/files')
-rw-r--r--media-gfx/fbida/files/fbida-2.09-giflib.patch97
-rw-r--r--media-gfx/fbida/files/fbida-2.09-make.patch36
2 files changed, 0 insertions, 133 deletions
diff --git a/media-gfx/fbida/files/fbida-2.09-giflib.patch b/media-gfx/fbida/files/fbida-2.09-giflib.patch
deleted file mode 100644
index 50c005589974..000000000000
--- a/media-gfx/fbida/files/fbida-2.09-giflib.patch
+++ /dev/null
@@ -1,97 +0,0 @@
---- a/rd/read-gif.c
-+++ b/rd/read-gif.c
-@@ -25,7 +25,13 @@
- if (GIF_ERROR == DGifGetRecordType(h->gif,&RecordType)) {
- if (debug)
- fprintf(stderr,"gif: DGifGetRecordType failed\n");
-- PrintGifError();
-+#if GIFLIB_MAJOR >= 5
-+ GifErrorString(D_GIF_ERR_NOT_GIF_FILE);
-+#elif (GIFLIB_MAJOR >= 4 && GIFLIB_MINOR >=2)
-+ GifErrorString();
-+#else
-+ PrintGifError();
-+#endif
- return -1;
- }
- switch (RecordType) {
-@@ -42,7 +48,13 @@
- if (rc == GIF_ERROR) {
- if (debug)
- fprintf(stderr,"gif: DGifGetExtension failed\n");
-+#if GIFLIB_MAJOR >= 5
-+ GifErrorString(D_GIF_ERR_NOT_GIF_FILE);
-+#elif (GIFLIB_MAJOR >= 4 && GIFLIB_MINOR >=2)
-+ GifErrorString();
-+#else
- PrintGifError();
-+#endif
- return -1;
- }
- if (debug) {
-@@ -93,12 +105,19 @@
- struct gif_state *h;
- GifRecordType RecordType;
- int i, image = 0;
-+#if (GIFLIB_MAJOR >=5 && GIFLIB_MINOR >= 1)
-+ int ErrorCode;
-+#endif
-
- h = malloc(sizeof(*h));
- memset(h,0,sizeof(*h));
-
- h->infile = fp;
-+#if GIFLIB_MAJOR >= 5
-+ h->gif = DGifOpenFileHandle(fileno(fp), NULL);
-+#else
- h->gif = DGifOpenFileHandle(fileno(fp));
-+#endif
- h->row = malloc(h->gif->SWidth * sizeof(GifPixelType));
-
- while (0 == image) {
-@@ -108,7 +127,15 @@
- if (GIF_ERROR == DGifGetImageDesc(h->gif)) {
- if (debug)
- fprintf(stderr,"gif: DGifGetImageDesc failed\n");
-+#if (GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1)
-+ GifErrorString(D_GIF_ERR_NO_IMAG_DSCR);
-+#elif GIFLIB_MAJOR >= 5
-+ GifErrorString(NULL);
-+#elif (GIFLIB_MAJOR >= 4 && GIFLIB_MINOR >=2)
-+ GifErrorString();
-+#else
- PrintGifError();
-+#endif
- }
- if (NULL == h->gif->SColorMap &&
- NULL == h->gif->Image.ColorMap) {
-@@ -156,7 +183,11 @@
- oops:
- if (debug)
- fprintf(stderr,"gif: fatal error, aborting\n");
-+#if (GIFLIB_MAJOR >=5 && GIFLIB_MINOR >= 1)
-+ DGifCloseFile(h->gif, &ErrorCode);
-+#else
- DGifCloseFile(h->gif);
-+#endif
- fclose(h->infile);
- free(h->row);
- free(h);
-@@ -193,10 +224,17 @@
- gif_done(void *data)
- {
- struct gif_state *h = data;
-+#if (GIFLIB_MAJOR >=5 && GIFLIB_MINOR >= 1)
-+ int ErrorCode;
-+#endif
-
- if (debug)
- fprintf(stderr,"gif: done, cleaning up\n");
-+#if (GIFLIB_MAJOR >=5 && GIFLIB_MINOR >= 1)
-+ DGifCloseFile(h->gif, &ErrorCode);
-+#else
- DGifCloseFile(h->gif);
-+#endif
- fclose(h->infile);
- if (h->il)
- free(h->il);
diff --git a/media-gfx/fbida/files/fbida-2.09-make.patch b/media-gfx/fbida/files/fbida-2.09-make.patch
deleted file mode 100644
index 61c19a3cfc72..000000000000
--- a/media-gfx/fbida/files/fbida-2.09-make.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/GNUmakefile
-+++ b/GNUmakefile
-@@ -30,8 +30,8 @@
-
- ac_jpeg_ver = $(shell \
- $(call ac_init,for libjpeg version);\
-- $(call ac_s_cmd,echo -e '\#include <jpeglib.h>\nJPEG_LIB_VERSION' \
-- | cpp | tail -n 1);\
-+ $(call ac_s_cmd,printf '\#include <jpeglib.h>\nJPEG_LIB_VERSION' \
-+ | $(CPP) | tail -n 1);\
- $(call ac_fini))
-
- define make-config
---- a/mk/Autoconf.mk
-+++ b/mk/Autoconf.mk
-@@ -24,7 +24,7 @@ ifneq ($(verbose),no)
- ac_fini = echo "... result is $${rc}" >&2; echo >&2; echo "$${rc}"
- else
- # normal
-- ac_init = echo -n "checking $(1) ... " >&2; rc=no
-+ ac_init = printf '%s' "checking $(1) ... " >&2; rc=no
- ac_b_cmd = $(1) >/dev/null 2>&1 && rc=yes
- ac_s_cmd = rc=`$(1) 2>/dev/null`
- ac_fini = echo "$${rc}" >&2; echo "$${rc}"
-@@ -162,7 +162,7 @@ config: Make.config
- @true
-
- Make.config: $(srcdir)/GNUmakefile
-- @echo -e "$(make-config-q)" > $@
-+ @printf '%b' "$(make-config-q)" > $@
- @echo
- @echo "Make.config written, edit if needed"
- @echo
---
-1.7.5.3
-