summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-23 14:24:20 +0100
committerMarek Szuba <marecki@gentoo.org>2021-05-23 16:00:00 +0100
commitc2dcd5faefc3f0b0b365fc5c37404fb9ff56a924 (patch)
treecd38d304df3accce41f4b545b81973b4d182c775 /media-gfx/darktable
parentmedia-gfx/darktable-3.4.1: require <=media-libs/openexr-3 for USE=openexr (diff)
downloadgentoo-c2dcd5faefc3f0b0b365fc5c37404fb9ff56a924.tar.gz
gentoo-c2dcd5faefc3f0b0b365fc5c37404fb9ff56a924.tar.bz2
gentoo-c2dcd5faefc3f0b0b365fc5c37404fb9ff56a924.zip
media-gfx/darktable: do not depend on LLVM+Clang
Darktable only needs LLVM+Clang if one want to test-build its OpenCL kernels during installation. This is useful for developers working on said kernels but feels unnecessary for users, especially given it involves such a heavyweight dependency. Therefore, disable the test-building of OpenCL kernels and remove the sys-devel/{llvm,clang} dependencies. Closes: https://bugs.gentoo.org/791448 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-gfx/darktable')
-rw-r--r--media-gfx/darktable/darktable-2.6.2.ebuild10
-rw-r--r--media-gfx/darktable/darktable-3.4.1.ebuild26
-rw-r--r--media-gfx/darktable/darktable-9999.ebuild28
3 files changed, 20 insertions, 44 deletions
diff --git a/media-gfx/darktable/darktable-2.6.2.ebuild b/media-gfx/darktable/darktable-2.6.2.ebuild
index 394e2f5295a8..dbca73f7b5f2 100644
--- a/media-gfx/darktable/darktable-2.6.2.ebuild
+++ b/media-gfx/darktable/darktable-2.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -59,12 +59,7 @@ COMMON_DEPEND="
openexr? ( media-libs/openexr:0= )
webp? ( media-libs/libwebp:0= )
"
-DEPEND="${COMMON_DEPEND}
- opencl? (
- >=sys-devel/clang-4
- >=sys-devel/llvm-4
- )
-"
+DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}
kwallet? ( >=kde-frameworks/kwallet-5.34.0-r1 )
"
@@ -93,6 +88,7 @@ src_configure() {
local mycmakeargs=(
-DBUILD_PRINT=$(usex cups)
-DCUSTOM_CFLAGS=ON
+ -DTESTBUILD_OPENCL_PROGRAMS=OFF
-DUSE_CAMERA_SUPPORT=$(usex gphoto2)
-DUSE_COLORD=$(usex colord)
-DUSE_FLICKR=$(usex flickr)
diff --git a/media-gfx/darktable/darktable-3.4.1.ebuild b/media-gfx/darktable/darktable-3.4.1.ebuild
index d3f396135595..54b4518a454b 100644
--- a/media-gfx/darktable/darktable-3.4.1.ebuild
+++ b/media-gfx/darktable/darktable-3.4.1.ebuild
@@ -37,14 +37,11 @@ REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
-BDEPEND="
- dev-util/intltool
+BDEPEND="dev-util/intltool
virtual/pkgconfig
nls? ( sys-devel/gettext )
- test? ( >=dev-python/jsonschema-3.2.0 )
-"
-COMMON_DEPEND="
- dev-db/sqlite:3
+ test? ( >=dev-python/jsonschema-3.2.0 )"
+DEPEND="dev-db/sqlite:3
dev-libs/json-glib
dev-libs/libxml2:2
>=dev-libs/pugixml-1.8:0=
@@ -74,20 +71,12 @@ COMMON_DEPEND="
lua? ( ${LUA_DEPS} )
opencl? ( virtual/opencl )
openexr? ( <media-libs/openexr-3.0.0:0= )
- webp? ( media-libs/libwebp:0= )
-"
-DEPEND="${COMMON_DEPEND}
- opencl? (
- >=sys-devel/clang-4
- >=sys-devel/llvm-4
- )
-"
-RDEPEND="${COMMON_DEPEND}
- kwallet? ( >=kde-frameworks/kwallet-5.34.0-r1 )
-"
+ webp? ( media-libs/libwebp:0= )"
+RDEPEND="${DEPEND}
+ kwallet? ( >=kde-frameworks/kwallet-5.34.0-r1 )"
PATCHES=(
- "${FILESDIR}"/"${PN}"-find-opencl-header.patch
+ "${FILESDIR}"/${PN}-find-opencl-header.patch
"${FILESDIR}"/${PN}-3.0.2_cmake-march-autodetection.patch
"${FILESDIR}"/${PN}-3.4.0_jsonschema-automagic.patch
)
@@ -128,6 +117,7 @@ src_configure() {
-DCUSTOM_CFLAGS=ON
-DDONT_USE_INTERNAL_LUA=ON
-DRAWSPEED_ENABLE_LTO=$(usex lto)
+ -DTESTBUILD_OPENCL_PROGRAMS=OFF
-DUSE_AVIF=$(usex avif)
-DUSE_CAMERA_SUPPORT=$(usex gphoto2)
-DUSE_COLORD=$(usex colord)
diff --git a/media-gfx/darktable/darktable-9999.ebuild b/media-gfx/darktable/darktable-9999.ebuild
index e2dca8478be7..696f97a42ff2 100644
--- a/media-gfx/darktable/darktable-9999.ebuild
+++ b/media-gfx/darktable/darktable-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -37,14 +37,11 @@ REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
-BDEPEND="
- dev-util/intltool
+BDEPEND="dev-util/intltool
virtual/pkgconfig
nls? ( sys-devel/gettext )
- test? ( >=dev-python/jsonschema-3.2.0 )
-"
-COMMON_DEPEND="
- dev-db/sqlite:3
+ test? ( >=dev-python/jsonschema-3.2.0 )"
+DEPEND="dev-db/sqlite:3
dev-libs/json-glib
dev-libs/libxml2:2
>=dev-libs/pugixml-1.8:0=
@@ -74,20 +71,12 @@ COMMON_DEPEND="
lua? ( ${LUA_DEPS} )
opencl? ( virtual/opencl )
openexr? ( media-libs/openexr:0= )
- webp? ( media-libs/libwebp:0= )
-"
-DEPEND="${COMMON_DEPEND}
- opencl? (
- >=sys-devel/clang-4
- >=sys-devel/llvm-4
- )
-"
-RDEPEND="${COMMON_DEPEND}
- kwallet? ( >=kde-frameworks/kwallet-5.34.0-r1 )
-"
+ webp? ( media-libs/libwebp:0= )"
+RDEPEND="${DEPEND}
+ kwallet? ( >=kde-frameworks/kwallet-5.34.0-r1 )"
PATCHES=(
- "${FILESDIR}"/"${PN}"-find-opencl-header.patch
+ "${FILESDIR}"/${PN}-find-opencl-header.patch
"${FILESDIR}"/${PN}-3.0.2_cmake-march-autodetection.patch
"${FILESDIR}"/${PN}-3.4.0_jsonschema-automagic.patch
)
@@ -128,6 +117,7 @@ src_configure() {
-DCUSTOM_CFLAGS=ON
-DDONT_USE_INTERNAL_LUA=ON
-DRAWSPEED_ENABLE_LTO=$(usex lto)
+ -DTESTBUILD_OPENCL_PROGRAMS=OFF
-DUSE_AVIF=$(usex avif)
-DUSE_CAMERA_SUPPORT=$(usex gphoto2)
-DUSE_COLORD=$(usex colord)