summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mate-base/mate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mate-base/mate')
-rw-r--r--mate-base/mate/mate-1.8.0.ebuild74
-rw-r--r--mate-base/mate/metadata.xml19
2 files changed, 93 insertions, 0 deletions
diff --git a/mate-base/mate/mate-1.8.0.ebuild b/mate-base/mate/mate-1.8.0.ebuild
new file mode 100644
index 000000000000..41491a52c2f4
--- /dev/null
+++ b/mate-base/mate/mate-1.8.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit versionator
+
+MATE_MV="$(get_version_component_range 1-2)"
+
+SRC_URI=""
+DESCRIPTION="Meta ebuild for MATE, a traditional desktop environment"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="metapackage"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+base -bluetooth +themes +extras"
+
+S="${WORKDIR}"
+
+RDEPEND="
+ =mate-base/mate-desktop-${MATE_MV}*
+ =mate-base/mate-menus-${MATE_MV}*
+ =mate-base/mate-panel-${MATE_MV}*
+ =mate-base/mate-session-manager-${MATE_MV}*
+ =mate-base/mate-settings-daemon-${MATE_MV}*
+ =x11-wm/marco-${MATE_MV}*
+ base? (
+ =mate-base/caja-${MATE_MV}*
+ =mate-base/mate-applets-${MATE_MV}*
+ =mate-base/mate-control-center-${MATE_MV}*
+ =mate-extra/mate-media-${MATE_MV}*
+ =x11-misc/mozo-${MATE_MV}*
+ =x11-terms/mate-terminal-${MATE_MV}*
+ )
+ bluetooth? ( net-wireless/blueman:0 )
+ themes? (
+ =x11-themes/mate-backgrounds-${MATE_MV}*
+ =x11-themes/mate-icon-theme-${MATE_MV}*
+ =x11-themes/mate-themes-${MATE_MV}*
+ )
+ extras? (
+ =app-arch/engrampa-${MATE_MV}*
+ =app-editors/pluma-${MATE_MV}*
+ =app-text/atril-${MATE_MV}*
+ =mate-extra/mate-calc-${MATE_MV}*
+ =mate-extra/mate-power-manager-${MATE_MV}*
+ =mate-extra/mate-screensaver-${MATE_MV}*
+ =mate-extra/mate-system-monitor-${MATE_MV}*
+ =mate-extra/mate-utils-${MATE_MV}*
+ =media-gfx/eom-${MATE_MV}*
+ )
+"
+
+PDEPEND="virtual/notification-daemon:0"
+
+pkg_postinst() {
+ elog "For installation, usage and troubleshooting details regarding MATE;"
+ elog "read more about it at Gentoo Wiki: https://wiki.gentoo.org/wiki/MATE"
+ elog ""
+ elog "MATE 1.8 had some packages renamed, replaced and/or dropped; for more"
+ elog "details, see http://mate-desktop.org/blog/2014-03-04-mate-1-8-released"
+ elog ""
+ elog "MATE 1.6 has moved from mateconf to gsettings. This means that the"
+ elog "desktop settings and panel applets will return to their default."
+ elog "You will have to reconfigure your desktop appearance."
+ elog ""
+ elog "There is mate-conf-import that converts from mateconf to gsettings."
+ elog ""
+ elog "For support with mate-conf-import see the following MATE forum topic:"
+ elog "http://forums.mate-desktop.org/viewtopic.php?f=16&t=1650"
+}
diff --git a/mate-base/mate/metadata.xml b/mate-base/mate/metadata.xml
new file mode 100644
index 000000000000..a2016fc9c027
--- /dev/null
+++ b/mate-base/mate/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mate</herd>
+ <use>
+ <flag name="base">Install base MATE Desktop applications that are
+ recommended for the most common usage; for example, this installs
+ the file manager. Disable this and other USE flags if you want a
+ more minimal MATE Desktop.</flag>
+ <flag name="themes">Install MATE Desktop's themes; if you use other
+ themes, you can disable this to spare some space and time.</flag>
+ <flag name="extras">Install additional MATE Desktop applications that
+ are recommended for extended usage of the MATE Desktop as upstream
+ sees it; for example, this installs MATE Desktop's office related
+ applications. Disable this if you plan to use your own non-MATE
+ Desktop alternatives or a custom mixture of MATE and non-MATE
+ packages.</flag>
+ </use>
+</pkgmetadata>