summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-24 02:58:55 +0100
committerSam James <sam@gentoo.org>2022-06-24 04:13:49 +0100
commit5dd27f1032275822f8303e9c5f48919a7e80bd6f (patch)
tree538f4ee2c308d29a4388ac4a283f7639236847a8 /mail-client/mailx
parentnet-misc/bsdwhois: fix build on musl (diff)
downloadgentoo-5dd27f1032275822f8303e9c5f48919a7e80bd6f.tar.gz
gentoo-5dd27f1032275822f8303e9c5f48919a7e80bd6f.tar.bz2
gentoo-5dd27f1032275822f8303e9c5f48919a7e80bd6f.zip
mail-client/mailx: fix build on musl
Thanks-to: CFuga <cfuga@cfuga.mx> Closes: https://bugs.gentoo.org/719512 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-client/mailx')
-rw-r--r--mail-client/mailx/files/mailx-8.1.2-20180807-musl-CCEQ.patch17
-rw-r--r--mail-client/mailx/mailx-8.1.2.20180807.ebuild1
2 files changed, 18 insertions, 0 deletions
diff --git a/mail-client/mailx/files/mailx-8.1.2-20180807-musl-CCEQ.patch b/mail-client/mailx/files/mailx-8.1.2-20180807-musl-CCEQ.patch
new file mode 100644
index 000000000000..d04ddd789e3a
--- /dev/null
+++ b/mail-client/mailx/files/mailx-8.1.2-20180807-musl-CCEQ.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/719512
+
+Tiny definition copied from /usr/include/termios.h.
+--- a/tty.c
++++ b/tty.c
+@@ -57,6 +57,10 @@
+ size_t cursor;
+ };
+
++#ifndef CCEQ
++#define CCEQ(val, c) ((c) == (val) && (val) != _POSIX_VDISABLE)
++#endif
++
+ static void tty_flush(struct tty *);
+ static int tty_getc(struct tty *);
+ static int tty_insert(struct tty *, int, int);
+
diff --git a/mail-client/mailx/mailx-8.1.2.20180807.ebuild b/mail-client/mailx/mailx-8.1.2.20180807.ebuild
index d542d75a55b2..4b3f28a1d294 100644
--- a/mail-client/mailx/mailx-8.1.2.20180807.ebuild
+++ b/mail-client/mailx/mailx-8.1.2.20180807.ebuild
@@ -33,6 +33,7 @@ src_prepare() {
eapply "${WORKDIR}/debian/patches"
eapply "${FILESDIR}/${PN}-8.1.2.20050715-offsetof.patch"
eapply "${FILESDIR}/${PN}-8.1.2.20180807-fno-common.patch"
+ eapply "${FILESDIR}/${PN}-8.1.2-20180807-musl-CCEQ.patch"
eapply_user
}