summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 17:58:57 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 17:59:30 +0100
commit4fa26bd9039450d46ad06cf145269faaa52519f6 (patch)
treed645b1a0a679cdb6881107856459f2a85b87c3cb /kde-misc
parentdev-lang/go: 1.17.6 bump (diff)
downloadgentoo-4fa26bd9039450d46ad06cf145269faaa52519f6.tar.gz
gentoo-4fa26bd9039450d46ad06cf145269faaa52519f6.tar.bz2
gentoo-4fa26bd9039450d46ad06cf145269faaa52519f6.zip
kde-misc/tellico: Fix build with USE=-taglib
Thanks-to: Lars Wendler <polynomial-c@gentoo.org> Closes: https://bugs.gentoo.org/830806 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/tellico/files/tellico-3.4.3-taglib-ifdef.patch35
-rw-r--r--kde-misc/tellico/tellico-3.4.3.ebuild2
2 files changed, 37 insertions, 0 deletions
diff --git a/kde-misc/tellico/files/tellico-3.4.3-taglib-ifdef.patch b/kde-misc/tellico/files/tellico-3.4.3-taglib-ifdef.patch
new file mode 100644
index 000000000000..94986ea3003d
--- /dev/null
+++ b/kde-misc/tellico/files/tellico-3.4.3-taglib-ifdef.patch
@@ -0,0 +1,35 @@
+From 9d450037f708cc2300d2767e5171bb08e48077a9 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Sat, 8 Jan 2022 20:35:37 +0100
+Subject: [PATCH] Fix build without HAVE_TAGLIB
+
+Gentoo-bug: https://bugs.gentoo.org/830806
+
+CCBUG: 446551
+---
+ src/translators/audiofileimporter.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/translators/audiofileimporter.cpp b/src/translators/audiofileimporter.cpp
+index 2b3372f4..a18ed14a 100644
+--- a/src/translators/audiofileimporter.cpp
++++ b/src/translators/audiofileimporter.cpp
+@@ -57,6 +57,7 @@
+ #include <QVBoxLayout>
+ #include <QApplication>
+
++#ifdef HAVE_TAGLIB
+ namespace {
+ bool hasValue(const TagLib::PropertyMap& pmap, const char* key) {
+ const TagLib::String keyString(key);
+@@ -70,6 +71,7 @@ namespace {
+ QString();
+ }
+ }
++#endif
+
+ using Tellico::Import::AudioFileImporter;
+
+--
+2.34.1
+
diff --git a/kde-misc/tellico/tellico-3.4.3.ebuild b/kde-misc/tellico/tellico-3.4.3.ebuild
index a83ef948cde1..3c34e17b6b7e 100644
--- a/kde-misc/tellico/tellico-3.4.3.ebuild
+++ b/kde-misc/tellico/tellico-3.4.3.ebuild
@@ -73,6 +73,8 @@ BDEPEND="
sys-devel/gettext
"
+PATCHES=( "${FILESDIR}/${P}-taglib-ifdef.patch" )
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_Csv=ON