summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:14:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-14 23:25:03 +0100
commit576fc933c81aa6e526d87290af95e8e898e70ecb (patch)
tree73f9a202bcb454043dbb6b731d9b56ed4c5f49eb /kde-apps/kolourpaint
parentdev-haskell/stack-bin: bump up to 1.6.1 (diff)
downloadgentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.gz
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.tar.bz2
gentoo-576fc933c81aa6e526d87290af95e8e898e70ecb.zip
kde-apps: Add KDE Applications 17.12.0
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'kde-apps/kolourpaint')
-rw-r--r--kde-apps/kolourpaint/Manifest1
-rw-r--r--kde-apps/kolourpaint/kolourpaint-17.12.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-apps/kolourpaint/Manifest b/kde-apps/kolourpaint/Manifest
index b74f923cfd98..bcb94044669e 100644
--- a/kde-apps/kolourpaint/Manifest
+++ b/kde-apps/kolourpaint/Manifest
@@ -1 +1,2 @@
DIST kolourpaint-17.08.3.tar.xz 5546536 BLAKE2B 14f1950f8b9cf0af985998489b7a369ad64ebf531d1a3c8763236114bb076db9a530c2950d877cf854067b02374eccf3367e9ef7694f46d0bf0bee4c8da4ce42 SHA512 4b7ff817eb8d35ae7d0d9c4f96036b1236d974e08f2db79080658b7b7b78111deaf23340f0216c9c60c367324cd36f4d62470220ab1bff27f6277c2a09b3dce2
+DIST kolourpaint-17.12.0.tar.xz 5546408 BLAKE2B 0f23180d56aad83df6663f86ef18f88e966b627c5d289dc0d73e4eb4f0402f5c6525e9b4c7cbe0145c903c4f8485cac051f54df406c2679d5d3952d74068f498 SHA512 523fa56796d3491d020a2f39ef26abeebf39167efd7274f85f1fec4a85dd6f99b0f07df92ad0c10d10bd017e7b107b403ac747f9230ae5099da51575a4e8890c
diff --git a/kde-apps/kolourpaint/kolourpaint-17.12.0.ebuild b/kde-apps/kolourpaint/kolourpaint-17.12.0.ebuild
new file mode 100644
index 000000000000..69dda0e51a86
--- /dev/null
+++ b/kde-apps/kolourpaint/kolourpaint-17.12.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="Paint Program by KDE"
+HOMEPAGE="https://www.kde.org/applications/graphics/kolourpaint/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD-2 LGPL-2 LGPL-2+ || ( LGPL-2.1 LGPL-3 ) GPL-2 handbook? ( FDL-1.2 )"
+IUSE="scanner"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ scanner? ( $(add_kdeapps_dep libksane) )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package scanner KF5Sane)
+ )
+
+ kde5_src_configure
+}