summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-08-18 14:56:42 -0700
committerYixun Lan <dlan@gentoo.org>2024-08-22 10:50:38 +0000
commitc1d10c23329a9641a086276a531657594d6cda31 (patch)
tree0f40fa7dadc694063f47186f3d03487bbdd81418 /gui-libs
parentdev-util/hyprwayland-scanner: drop 0.3.1, 0.3.4, 0.3.7 (diff)
downloadgentoo-c1d10c23329a9641a086276a531657594d6cda31.tar.gz
gentoo-c1d10c23329a9641a086276a531657594d6cda31.tar.bz2
gentoo-c1d10c23329a9641a086276a531657594d6cda31.zip
gui-libs/aquamarine: add 0.3.2
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/aquamarine/Manifest1
-rw-r--r--gui-libs/aquamarine/aquamarine-0.3.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/gui-libs/aquamarine/Manifest b/gui-libs/aquamarine/Manifest
index 572ffb67659e..e50bf96267ba 100644
--- a/gui-libs/aquamarine/Manifest
+++ b/gui-libs/aquamarine/Manifest
@@ -1,3 +1,4 @@
DIST aquamarine-0.1.1.tar.gz 70241 BLAKE2B 511e03fed61f970b6309f4cc630e6cfee9eabb4b2d95da27699aa9b38e8e20922847272c9bb4467fb59f428b7137196be2e31cf4e34ac0bb61df5e1520c6f27a SHA512 5e51db094d8a30b53f6bd0e8895039adb354f04428c49e6d1b6fdbbc13d9e8ee02d42da1f9d78bb495a0cd8e286888323a5dbdf663ae6df7495072ed6ab4abc2
DIST aquamarine-0.2.0.tar.gz 71350 BLAKE2B d44df5f3785f381e86e05617741c114be5b3a29dda9995e84853c35753ddbac55f2f59ec4e1074829c2eb60439469b89eb0ffa6ebe98193d3bea2c975a033767 SHA512 2665ecb764f374f22a6cda88b6ede09e48ba76c245b9922a41daa13eed2c0eca51915a553829d4c9ee22d5b84c2ff9af6b8672908ad7c2f3d6d4838437c53de0
DIST aquamarine-0.3.1.tar.gz 73065 BLAKE2B 9e66d6e6da33e62917b10b395ed1eb9ca6f721b38d787ccd6197f1b14af69cafba42994081d95b13f8dcc311b997d950a8070bca47097020bb4c80c91651b698 SHA512 78428d9571f90f424cb91fa1a1b262e1433fe3b8b2c7c7a1a8799f3346c2e2efa1fd3738903d08aeb776f5ff65f4fbe2ebc3eee1481c3a8067bf163d3cea6efb
+DIST aquamarine-0.3.2.tar.gz 73834 BLAKE2B 6fef169866c4e7dc4df6b3168c2e7c950fe62572979689010934af4c5aea7223734f3be5a85ed0c8884b32e73962d08ceb2a1e745423169642a68439f5c54dc1 SHA512 ed5e17cbbf6bff579db657366e7035b765979821fc2be95c420b290f1f25625d29c25ac30ab49183b58654ae442f18382f8bb0931aae57a796a24a14f4baacea
diff --git a/gui-libs/aquamarine/aquamarine-0.3.2.ebuild b/gui-libs/aquamarine/aquamarine-0.3.2.ebuild
new file mode 100644
index 000000000000..f6ad41a30f68
--- /dev/null
+++ b/gui-libs/aquamarine/aquamarine-0.3.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Aquamarine is a very light linux rendering backend library"
+HOMEPAGE="https://github.com/hyprwm/aquamarine"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+# Upstream states that the simpleWindow test is broken, see bug 936653
+RESTRICT="test"
+RDEPEND="
+ dev-libs/wayland
+ media-libs/mesa[opengl]
+ media-libs/libdisplay-info
+ >=dev-libs/libinput-1.26.1
+ >=dev-util/hyprwayland-scanner-0.4.0
+ >=gui-libs/hyprutils-0.1.5
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/libdrm
+ x11-libs/pango
+ x11-libs/pixman
+ virtual/libudev
+ sys-apps/hwdata
+ >=sys-auth/seatd-0.8.0
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i "/add_compile_options(-O3)/d" "${S}/CMakeLists.txt" || die
+ cmake_src_prepare
+}