summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUwe Scholz <u.scholz83@gmx.de>2021-12-03 22:45:01 +0100
committerIonen Wolkens <ionen@gentoo.org>2021-12-03 21:54:44 -0500
commitf38206959bf6e2d9d4cc9a7395c0e5c389449bff (patch)
tree4bd166101f03786c2c760c9961c4ad69c630e34b /gnome-extra
parentdev-python/raet: disable py3.10 (diff)
downloadgentoo-f38206959bf6e2d9d4cc9a7395c0e5c389449bff.tar.gz
gentoo-f38206959bf6e2d9d4cc9a7395c0e5c389449bff.tar.bz2
gentoo-f38206959bf6e2d9d4cc9a7395c0e5c389449bff.zip
gnome-extra/gnome-commander: add version 1.12.3.1
Closes: https://bugs.gentoo.org/827842 Signed-off-by: Uwe Scholz <u.scholz83@gmx.de> Package-Manager: Portage-3.0.28, Repoman-3.0.3 Closes: https://github.com/gentoo/gentoo/pull/23172 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-commander/Manifest1
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.12.3.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/gnome-extra/gnome-commander/Manifest b/gnome-extra/gnome-commander/Manifest
index 00ba7ade584e..9d0d16260a5a 100644
--- a/gnome-extra/gnome-commander/Manifest
+++ b/gnome-extra/gnome-commander/Manifest
@@ -1,2 +1,3 @@
DIST gnome-commander-1.12.1.tar.xz 7532412 BLAKE2B 92a4c71e716aca5354cd53ca10440ce11426f9baa11342c37a8dbd5d3fe2898ea9e7aa577d584d0e91e85a8213a5480dd045c6d0ffbd05155b05d74c2a0b52e7 SHA512 74756af9a720ab81904e3f7834ae008af67d635cc1d1b961420d02c029616465dfe06a18bc5b443d0a9725cfefe6e9f7cdba68faa62515f8ccb85a2246867010
DIST gnome-commander-1.12.2.tar.xz 7529048 BLAKE2B 468279fcfd25111c673d7ce75124bb4b1773c74952759f749e6e526c0525ec801484a9be01f5819942302d634c7427b313e25fea85c3d792d66967d4edf92ca7 SHA512 0f56450a09fcf8a73cc31e91564b133fd5fd199ea75c9376a2c329e070554c2c3ae4916f899940f92ddea5fff29656c9485a207dd22a28f1cda12a46f4cab32c
+DIST gnome-commander-1.12.3.1.tar.xz 7530232 BLAKE2B 34a4cabafab52ab6f94619dafac4db87c12909eef22c13d50356dad925f129da182348eabd8993f69ffc398db163f81ec59c9a102530a9b49f7714b5d7c6db68 SHA512 1206d545493deeb2237af6b9026baf6faab2a8f6ae86eb1abb5c2e5ceb6212ad66382d3abd07c89f14271ac8709d14548f0bfe68fb0e11b1779e0c061e0272e5
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.12.3.1.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.12.3.1.ebuild
new file mode 100644
index 000000000000..925df5278f1f
--- /dev/null
+++ b/gnome-extra/gnome-commander/gnome-commander-1.12.3.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 optfeature toolchain-funcs
+
+DESCRIPTION="A graphical, full featured, twin-panel file manager"
+HOMEPAGE="https://gcmd.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chm exif gsf pdf samba taglib test +unique"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-text/yelp-tools
+ dev-libs/atk
+ dev-libs/glib:2
+ gnome-base/gconf:2
+ gnome-base/gnome-vfs
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/harfbuzz:=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/pango
+ chm? ( dev-libs/chmlib )
+ exif? ( >=media-gfx/exiv2-0.14 )
+ gsf? ( gnome-extra/libgsf:= )
+ pdf? ( >=app-text/poppler-0.18 )
+ samba? ( gnome-base/gnome-vfs:=[samba] )
+ taglib? ( >=media-libs/taglib-1.4 )
+ unique? ( >=dev-libs/libunique-0.9.3:1 )
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+DEPEND="
+ test? ( >=dev-cpp/gtest-1.7.0 )
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with chm libchm) \
+ $(use_with exif exiv2) \
+ $(use_with gsf libgsf) \
+ $(use_with pdf poppler) \
+ $(use_with samba) \
+ $(use_with taglib) \
+ $(use_with unique)
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ optfeature "synchronizing files and directories" dev-util/meld
+ optfeature "viewing the documentation" gnome-extra/yelp
+}