summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-04-11 16:44:21 +0300
committerMart Raudsepp <leio@gentoo.org>2018-04-11 16:45:04 +0300
commit911a328327d90f7d98aa6b45e55ad0df2458cc21 (patch)
tree84f156e163ccdc4e213752581bf9c10eb9786df8 /gnome-extra
parentapp-admin/kubectx: Remove old (diff)
downloadgentoo-911a328327d90f7d98aa6b45e55ad0df2458cc21.tar.gz
gentoo-911a328327d90f7d98aa6b45e55ad0df2458cc21.tar.bz2
gentoo-911a328327d90f7d98aa6b45e55ad0df2458cc21.zip
gnome-extra/gnome-boxes: bump to 3.24.1
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-boxes/Manifest1
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-3.24.1.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
index f73ae8027671..e1d617cd3bb5 100644
--- a/gnome-extra/gnome-boxes/Manifest
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -1 +1,2 @@
DIST gnome-boxes-3.24.0.tar.xz 1710652 BLAKE2B 0b574fcb54c9a6ab2323f08caabd8aa3d201bcd0f83fcaf6b5dc15aef0da8fc6718128f28cfa0d50c02ad341d699c1cbadec89dbc50c1a4bea08865bd8e3f0d4 SHA512 979d5c0f2cef052e2713508fc2fd46d64a3a325edd38dd0aa99f2e9700efd3f84916847b35487f9d7eb5e5e1c5f3b4b712b649fecf1523821c3488fa6b250026
+DIST gnome-boxes-3.24.1.tar.xz 1710348 BLAKE2B ce90cc1a6baefa45c1a553b059f4fa7ac5c9a6fbd7a2d71377a9c6f38fddb7ac5a110f38d0a65b45cf2ba948ebee6026cc22b5f93a2ba521c9db6cb20bd3dc37 SHA512 a687dd65af91d717862bba0a81d715b64de1092cbb5ffd8a756fe80988c84110127f186007e8cf4011bf23cc0ec0adb346ead72ef47c655f85a7fcb9ed3ec393
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-3.24.1.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-3.24.1.ebuild
new file mode 100644
index 000000000000..5792e84d40f2
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-3.24.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome2 linux-info readme.gentoo-r1 vala
+
+DESCRIPTION="Simple GNOME 3 application to access remote or virtual systems"
+HOMEPAGE="https://wiki.gnome.org/Apps/Boxes"
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+# We force 'bindist' due to licenses from gnome-boxes-nonfree
+IUSE="" #bindist
+
+KEYWORDS="~amd64"
+
+# NOTE: sys-fs/* stuff is called via exec()
+# FIXME: ovirt is not available in tree
+# FIXME: use vala.eclass but only because of libgd not being able
+# to use its pre-generated files so do not copy all the
+# vala deps like live ebuild has.
+# FIXME: qemu probably needs to depend on spice[smartcard]
+# directly with USE=spice
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/gobject-introspection-0.9.6:=
+ >=dev-libs/libxml2-2.7.8:2
+ >=sys-libs/libosinfo-0.2.12
+ >=app-emulation/qemu-1.3.1[spice,smartcard,usbredir]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/libvirt-glib-0.2.3
+ >=x11-libs/gtk+-3.19.8:3
+ >=net-libs/gtk-vnc-0.4.4[gtk3]
+ app-crypt/libsecret
+ app-emulation/spice[smartcard]
+ >=net-misc/spice-gtk-0.32[gtk3,smartcard,usbredir]
+ virtual/libusb:1
+
+ >=app-misc/tracker-0.16:0=[iso]
+
+ >=sys-apps/util-linux-2.20
+ >=net-libs/libsoup-2.38:2.4
+
+ sys-fs/mtools
+ >=virtual/libgudev-165:=
+"
+# !bindist? ( gnome-extra/gnome-boxes-nonfree )
+
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Before running gnome-boxes, you will need to load the KVM modules.
+If you have an Intel Processor, run:
+# modprobe kvm-intel
+
+If you have an AMD Processor, run:
+# modprobe kvm-amd"
+
+pkg_pretend() {
+ linux-info_get_any_version
+
+ if linux_config_exists; then
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes!"
+ fi
+ fi
+}
+
+src_prepare() {
+ # Do not change CFLAGS, wondering about VALA ones but appears to be
+ # needed as noted in configure comments below
+ sed 's/CFLAGS="$CFLAGS -O0 -ggdb3"//' -i configure{.ac,} || die
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # debug needed for splitdebug proper behavior (cardoe), bug #????
+ gnome2_src_configure \
+ --enable-debug \
+ --disable-strict-cc \
+ --disable-ovirt
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}