summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-15 11:27:18 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-15 12:52:54 -0400
commit106f850e6480d24f20b87c5b3c6af5b089fbabe1 (patch)
tree3c6172091baec20e415aa5d17f4075184ae03215 /gnome-base/gvfs
parentgames-puzzle/gnome-sudoku: Version bump to 45.0 (diff)
downloadgentoo-106f850e6480d24f20b87c5b3c6af5b089fbabe1.tar.gz
gentoo-106f850e6480d24f20b87c5b3c6af5b089fbabe1.tar.bz2
gentoo-106f850e6480d24f20b87c5b3c6af5b089fbabe1.zip
gnome-base/gvfs: Version bump to 1.52.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32806 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base/gvfs')
-rw-r--r--gnome-base/gvfs/Manifest1
-rw-r--r--gnome-base/gvfs/gvfs-1.52.0.ebuild155
2 files changed, 156 insertions, 0 deletions
diff --git a/gnome-base/gvfs/Manifest b/gnome-base/gvfs/Manifest
index f05fb5f83732..8a6e776db2b1 100644
--- a/gnome-base/gvfs/Manifest
+++ b/gnome-base/gvfs/Manifest
@@ -1 +1,2 @@
DIST gvfs-1.50.6.tar.xz 1229872 BLAKE2B bd14b8d8f3f4dd96102032a80853ddb3b1df8bdfd589e10483b39aa2055c4ec1e3c2a78872f535563eff60224d39536bcfed168707ea7e061517fa39ad3e6c76 SHA512 f289d5c45306e270fcbc0c66bb9583ad10c03492eb843d170cf5543afbf20226c22554abc7fc658e1c86d41feee9028f038c977995241f9b84a51ab31d6bdd67
+DIST gvfs-1.52.0.tar.xz 1231912 BLAKE2B 357a72597a0a173a878942d4c71b9372eed0546c914b7a24b1703964279b834c3efb4b3f335e26385d68e4f0f46e40244561a1650ed61a34b345708bd972afb2 SHA512 afc23ad81d8bd5a79430bf52f35f2e9a6121371d8a8df3f1837c7711ad709c58007039045ccb6798502e7f5bfc075724f5cd62831d0084299b4df906f651966a
diff --git a/gnome-base/gvfs/gvfs-1.52.0.ebuild b/gnome-base/gvfs/gvfs-1.52.0.ebuild
new file mode 100644
index 000000000000..bbd7d673fd42
--- /dev/null
+++ b/gnome-base/gvfs/gvfs-1.52.0.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+TMPFILES_OPTIONAL=1
+inherit gnome.org gnome2-utils meson systemd tmpfiles xdg
+
+DESCRIPTION="Virtual filesystem implementation for GIO"
+HOMEPAGE="https://wiki.gnome.org/Projects/gvfs"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="afp archive bluray cdda elogind fuse google keyring gnome-online-accounts gphoto2 +http ios mtp nfs policykit samba systemd test +udev udisks zeroconf"
+RESTRICT="!test? ( test )"
+# elogind/systemd only relevant to udisks (in v1.38.1)
+REQUIRED_USE="
+ ?? ( elogind systemd )
+ cdda? ( udev )
+ google? ( gnome-online-accounts )
+ gphoto2? ( udev )
+ mtp? ( udev )
+ udisks? ( udev )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.70.0:2
+ >=gnome-base/gsettings-desktop-schemas-3.33.0
+ afp? ( >=dev-libs/libgcrypt-1.2.2:0= )
+ sys-apps/dbus
+ app-crypt/gcr:0=
+ policykit? (
+ >=sys-auth/polkit-0.114
+ sys-libs/libcap
+ )
+ http? (
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-3.0.0:3.0
+ )
+ zeroconf? ( >=net-dns/avahi-0.6[dbus] )
+ udev? ( >=dev-libs/libgudev-147:= )
+ fuse? (
+ >=sys-fs/fuse-3.0.0:3
+ virtual/tmpfiles
+ )
+ udisks? ( >=sys-fs/udisks-1.97:2 )
+ systemd? ( >=sys-apps/systemd-206:0= )
+ elogind? ( >=sys-auth/elogind-229:0= )
+ ios? (
+ >=app-pda/libimobiledevice-1.2:=
+ >=app-pda/libplist-1:=
+ )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.17.1:= )
+ keyring? ( app-crypt/libsecret )
+ bluray? ( media-libs/libbluray:= )
+ mtp? (
+ virtual/libusb:1
+ >=media-libs/libmtp-1.1.15:=
+ )
+ samba? ( >=net-fs/samba-4[client] )
+ archive? ( app-arch/libarchive:= )
+ cdda? (
+ dev-libs/libcdio:0=
+ >=dev-libs/libcdio-paranoia-0.78.2:=
+ )
+ google? ( >=dev-libs/libgdata-0.18.0:=[crypt,gnome-online-accounts] )
+ gphoto2? ( >=media-libs/libgphoto2-2.5.0:= )
+ nfs? ( >=net-fs/libnfs-1.9.8:= )
+ virtual/openssh
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ dev-util/gdbus-codegen
+ test? ( dev-libs/libgdata )
+"
+
+src_configure() {
+ local enable_logind="false"
+ if use systemd || use elogind; then
+ enable_logind="true"
+ fi
+
+ # currently HAVE_GCRYPT and linkage only used with afp; check it on big
+ # bumps (grep for HAVE_GCRYPT and enable_gcrypt); adjust depends if changes
+ local enable_gcrypt="false"
+ if use afp; then
+ enable_gcrypt="true"
+ fi
+
+ # currently HAVE_LIBUSB and linkage only used with mtp; check it on big
+ # bumps (grep for HAVE_LIBUSB and enable_libusb); adjust depends if changes
+ local enable_libusb="false"
+ if use mtp; then
+ enable_libusb="true"
+ fi
+
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ -Dtmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d
+ $(meson_use policykit admin)
+ $(meson_use ios afc)
+ $(meson_use afp)
+ $(meson_use archive)
+ $(meson_use cdda)
+ $(meson_use zeroconf dnssd)
+ $(meson_use gnome-online-accounts goa)
+ $(meson_use google)
+ $(meson_use gphoto2)
+ $(meson_use http)
+ $(meson_use mtp)
+ $(meson_use nfs)
+ -Dsftp=true
+ $(meson_use samba smb)
+ $(meson_use udisks udisks2)
+ $(meson_use bluray)
+ $(meson_use fuse)
+ -Dgcr=true
+ -Dgcrypt=${enable_gcrypt}
+ $(meson_use udev gudev)
+ $(meson_use keyring keyring)
+ -Dlogind=${enable_logind}
+ -Dlibusb=${enable_libusb}
+ # wouldn't install any of it as of 1.38.1; some tests need it,
+ # but they aren't automated tests in 1.38.1
+ -Ddevel_utils=false
+ -Dinstalled_tests=false
+ -Dman=true
+ -Dprivileged_group=wheel
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ if use fuse; then
+ tmpfiles_process gvfsd-fuse-tmpfiles.conf
+ fi
+
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ gnome2_giomodule_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+ gnome2_giomodule_cache_update
+}