summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-19 11:56:45 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-19 12:01:30 -0400
commitd121de267dc651fe6b1505a1c38c4fba0522b4b0 (patch)
treef8b7f3b39c7ad5d6f28e9aff7071fe2ac06205f1 /games-simulation
parentgames-simulation/crashtest: EAPI 6->8, plib to RDEPEND, use EPREFIX (diff)
downloadgentoo-d121de267dc651fe6b1505a1c38c4fba0522b4b0.tar.gz
gentoo-d121de267dc651fe6b1505a1c38c4fba0522b4b0.tar.bz2
gentoo-d121de267dc651fe6b1505a1c38c4fba0522b4b0.zip
games-simulation/crrcsim: EAPI 6->8, cgal[-shared], missing deps
This already can use CGAL headers-only and only needed the -lCGAL link attempt removed. Moved to DEPEND-only, fixes bug #790779. (hopefully right way to handle CGAL now) Missing deps: opengl, glu, gmp, and jpeg wrt bug #739384. (gmp is always used with cgal regardless of patch or cgal[-gmp]) Removed unnecessary -buildsystem patch, -DCRRC_DATA_PATH is already used for data path and portaudio can use ac_cv_header_portaudio_h. Closes: https://bugs.gentoo.org/739384 Closes: https://bugs.gentoo.org/790779 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild b/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
new file mode 100644
index 000000000000..f32c81a4c523
--- /dev/null
+++ b/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Model-airplane flight simulation program"
+HOMEPAGE="https://sourceforge.net/projects/crrcsim/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portaudio"
+
+RDEPEND="
+ dev-libs/gmp:=
+ media-libs/libsdl[X,sound,joystick,opengl,video]
+ media-libs/plib
+ virtual/glu
+ virtual/jpeg
+ virtual/opengl
+ portaudio? ( media-libs/portaudio )"
+DEPEND="
+ ${RDEPEND}
+ sci-mathematics/cgal"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc6.patch
+)
+
+DOCS=( AUTHORS HISTORY )
+
+src_configure() {
+ econf ac_cv_header_portaudio_h=$(usex portaudio)
+}
+
+src_compile() {
+ emake CGAL_LIBS=
+}
+
+src_install() {
+ default
+
+ doicon packages/icons/${PN}.png
+ make_desktop_entry ${PN} CRRCSim
+}